发布时间 :2005-01-06 00:00:00
修订时间 :2008-09-05 16:40:59

[原文]Cross-site scripting (XSS) vulnerability in namazu.cgi for Namazu 2.0.13 and earlier allows remote attackers to inject arbitrary HTML and web script via a query that starts with a tab ("%09") character, which prevents the rest of the query from being properly sanitized.

[CNNVD]Namazu 字符编码 跨站脚本攻击漏洞(CNNVD-200501-012)

        Namazu 2.0.13及之前版本的namazu.cgi存在跨站点脚本攻击(XSS)漏洞。
        远程攻击者可以借助一个以Tab符("%09") 开头的查询,绕过对查询串的检测,从而注入任意的HTML和web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:namazu:namazu:2.0.8Namazu 2.0.8
cpe:/a:namazu:namazu:2.0.13Namazu 2.0.13
cpe:/a:namazu:namazu:2.0.7Namazu 2.0.7

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  namazu-tab-query-xss(18623)
(UNKNOWN)  BID  12053

- 漏洞信息

Namazu 字符编码 跨站脚本攻击漏洞
中危 跨站脚本
2005-01-06 00:00:00 2006-09-21 00:00:00
        Namazu 2.0.13及之前版本的namazu.cgi存在跨站点脚本攻击(XSS)漏洞。
        远程攻击者可以借助一个以Tab符("%09") 开头的查询,绕过对查询串的检测,从而注入任意的HTML和web脚本。

- 公告与补丁


- 漏洞信息

Namazu namazu.cgi Tab Character XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Namazu contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate queries beginning from a tab ("%09") upon submission to the 'namazu.cgi' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-15 Unknow
2004-12-15 Unknow

- 解决方案

Upgrade to version 2.0.14 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Namazu Multiple Remote Vulnerabilities
Input Validation Error 12053
Yes No
2004-12-15 12:00:00 2009-07-12 09:26:00
The vendor disclosed these vulnerabilities.

- 受影响的程序版本

Namazu Project Namazu 2.0.13
Namazu Project Namazu 2.0.12
+ S.u.S.E. Linux 8.1
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
+ S.u.S.E. Linux Connectivity Server
+ S.u.S.E. Linux Desktop 1.0
+ S.u.S.E. Linux Enterprise Server 9
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 8.2
Namazu Project Namazu 2.0.10
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ RedHat Linux 7.0 J sparc
+ RedHat Linux 7.0 J i386
+ RedHat Linux 7.0 J alpha
Namazu Project Namazu 2.0.9
Namazu Project Namazu 2.0.8
Namazu Project Namazu 2.0.7
Namazu Project Namazu 1.3 .0.11
Namazu Project Namazu 1.3 .0.10
Namazu Project Namazu 1.2 .0.2
HP System Management Homepage 2.0.2
HP System Management Homepage 2.0.1
HP System Management Homepage 2.0
Namazu Project Namazu 2.0.14
HP System Management Homepage 2.1

- 不受影响的程序版本

Namazu Project Namazu 2.0.14
HP System Management Homepage 2.1

- 漏洞讨论

Namazu is reported prone to multiple vulnerabilities. These issues result from insufficient sanitization of user-supplied data. The following issues were identified:

Namazu is reported prone to a cross-site scripting vulnerability. This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

Namazu is also reported prone to a potential file upload vulnerability. This issue may allow remote attackers to upload malicious script files to a vulnerable server. If the attacker is able to execute the script, this may allow for remote compromise of the server.

In addition of the issues described above, the vendor has stated that users should upgrade from versions 1.2 and older to a newer version. It is believed that the older versions contain numerous unspecified vulnerabilities.

The cross-site scripting vulnerability affects Namazu versions 2.0.13 and prior. The file upload vulnerability is present in Namazu versions and older.

- 漏洞利用

An exploit is not required.

- 解决方案

Fedora has released advisories FEDORA-2004-557 and FEDORA-2004-558 to address these issues in Fedora Core 2 and Fedora Core 3. Please see the referenced advisories for more information.

Debian has released advisory DSA 627-1 to address the cross-site scripting vulnerability. Please see the attached advisory for details on obtaining and applying fixes.

The vendor has released Namazu 2.0.14 to address these issues:

SuSE Linux has released a summary report (SUSE-SR:2005:001) advising that this as well as other issues have been resolved. Please see the referenced advisory for more information.

HP has released revision 1 of advisory HPSBMA01212 to address various issue affecting System Management Homepage. Please see the referenced advisory for more information.

Namazu Project Namazu 1.2 .0.2

Namazu Project Namazu 1.3 .0.11

Namazu Project Namazu 1.3 .0.10

Namazu Project Namazu 2.0.10

Namazu Project Namazu 2.0.12

Namazu Project Namazu 2.0.13

Namazu Project Namazu 2.0.7

Namazu Project Namazu 2.0.8

Namazu Project Namazu 2.0.9

- 相关参考