CVE-2004-1304
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:29:45
NMCOS    

[原文]Stack-based buffer overflow in the ELF header parsing code in file before 4.12 allows attackers to execute arbitrary code via a crafted ELF file.


[CNNVD]file ELF 栈溢出漏洞(CNNVD-200501-082)

        file是类Unix系统下查看文件格式的工具。
        file 4.12之前版本中ELF头解析代码存在堆栈溢出漏洞。
        这一漏洞可被攻击者利用,通过特别构造的ELF文件执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:trustix:secure_linux:2.2Trustix Secure Linux 2.2
cpe:/a:file:file:4.9
cpe:/a:file:file:4.5
cpe:/a:file:file:4.10
cpe:/a:file:file:4.1
cpe:/o:trustix:secure_linux:2.0Trustix Secure Linux 2.0
cpe:/a:file:file:4.7
cpe:/a:file:file:4.11
cpe:/a:file:file:4.0
cpe:/a:file:file:4.6
cpe:/o:trustix:secure_linux:2.1Trustix Secure Linux 2.1
cpe:/a:file:file:4.2
cpe:/a:file:file:4.4
cpe:/a:file:file:4.8
cpe:/o:gentoo:linuxGentoo Linux
cpe:/a:file:file:4.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1304
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1304
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-082
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11771
(VENDOR_ADVISORY)  BID  11771
http://xforce.iss.net/xforce/xfdb/18368
(VENDOR_ADVISORY)  XF  file-elf-header-bo(18368)
http://www.trustix.net/errata/2004/0063/
(UNKNOWN)  TRUSTIX  2004-0063
http://www.gentoo.org/security/en/glsa/glsa-200412-07.xml
(UNKNOWN)  GENTOO  GLSA-200412-07
http://securitytracker.com/id?1012433
(UNKNOWN)  SECTRACK  1012433

- 漏洞信息

file ELF 栈溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        file是类Unix系统下查看文件格式的工具。
        file 4.12之前版本中ELF头解析代码存在堆栈溢出漏洞。
        这一漏洞可被攻击者利用,通过特别构造的ELF文件执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        ftp://ftp.astron.com/pub/file/

- 漏洞信息

12255
file ELF Header Parsing Unspecified Stack Manipulation
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-11-26 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

File ELF Header Unspecified Buffer Overflow Vulnerability
Boundary Condition Error 11771
Yes No
2004-11-29 12:00:00 2009-07-12 08:06:00
The individual or individuals responsible for disclosure of these issues are currently unknown; these issues were disclosed in the referenced Trustix advisory.

- 受影响的程序版本

Trustix Secure Linux 2.2
Trustix Secure Linux 2.1
Trustix Secure Linux 2.0
Trustix Secure Enterprise Linux 2.0
SeriousSam SeriousEngine
+ Delphieye Nitro Family
+ Playlogic International Alpha Black Zero 1.0 4
+ SeriousSam The Second Encounter 1.0.7
Gentoo Linux
file file 4.11
file file 4.10
file file 4.9
file file 4.8
file file 4.7
file file 4.6
file file 4.5
file file 4.4
file file 4.3
file file 4.2
file file 4.1
file file 4.0
file file 4.12

- 不受影响的程序版本

file file 4.12

- 漏洞讨论

The file command is affected by a buffer overflow vulnerability. This issue is due to a failure of the application to properly validate string lengths in the affected file prior to copying them into static process buffers.

An attacker may leverage this issue to execute arbitrary code with the privileges of a user that processes the malicious file with the affected utility. This may be leveraged to escalate privileges or to gain unauthorized access.

- 漏洞利用

Currently we are not aware of any exploits for these issues. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Trustix linux has released advisory TSL-2004-0063 along with fixes dealing with this issue. Please see the referenced advisory for more information.

The vendor has released an upgrade dealing with this issue.

Gentoo Linux has released advisory GLSA 200412-07 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
emerge --sync
emerge --ask --oneshot --verbose ">=sys-apps/file-4.12"
Please see the referenced advisory for further information.

SUSE has released advisory SUSE-SR:2004:004 along with fixes dealing with this and other issues. Please see the referenced advisory for more information.


Trustix Secure Enterprise Linux 2.0

Trustix Secure Linux 2.1

Trustix Secure Linux 2.2

file file 4.0

file file 4.1

file file 4.10

file file 4.11

file file 4.2

file file 4.3

file file 4.4

file file 4.5

file file 4.6

file file 4.7

file file 4.8

file file 4.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站