CVE-2004-1289
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-05 16:40:53
NMCOS    

[原文]Multiple buffer overflows in (1) the getline function in pcalutil.c and (2) the get_holiday function in readfile.c for pcal 4.7.1 allow remote attackers to execute arbitrary code via a crafted calendar file.


[CNNVD]pcal 多个 缓冲区溢出漏洞(CNNVD-200501-218)

        pcal是一款日历工具程序。
        pcal 4.7.1中pcalutil.c的getline函数和readfile.c的get_holiday函数存在缓冲区溢出漏洞。
        远程攻击者可使用特别构造当日历文件,利用此漏洞执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pcal:pcal:4.6.0
cpe:/a:pcal:pcal:4.1.0
cpe:/a:pcal:pcal:4.3.0
cpe:/a:pcal:pcal:4.7.0
cpe:/a:pcal:pcal:4.5.0
cpe:/a:pcal:pcal:4.7.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1289
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1289
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-218
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18552
(UNKNOWN)  XF  pcal-getline-pcalutil-bo(18552)
http://tigger.uic.edu/~jlongs2/holes/pcal.txt
(VENDOR_ADVISORY)  MISC  http://tigger.uic.edu/~jlongs2/holes/pcal.txt

- 漏洞信息

pcal 多个 缓冲区溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        pcal是一款日历工具程序。
        pcal 4.7.1中pcalutil.c的getline函数和readfile.c的get_holiday函数存在缓冲区溢出漏洞。
        远程攻击者可使用特别构造当日历文件,利用此漏洞执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://sourceforge.net/projects/pcal/files/

- 漏洞信息

12463
pcal pcalutil.c getline() Function Calendar File Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PCAL Calendar File get_holiday Buffer Overflow Vulnerability
Boundary Condition Error 12036
Yes No
2004-12-15 12:00:00 2009-07-12 09:26:00
Discovery is credited to Danny Lungstrom.

- 受影响的程序版本

PCAL PCAL 4.7.1
PCAL PCAL 4.7 .0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
PCAL PCAL 4.6 .0
PCAL PCAL 4.5 .0
PCAL PCAL 4.3 .0
PCAL PCAL 4.1 .0
PCAL PCAL 4.8 .0

- 不受影响的程序版本

PCAL PCAL 4.8 .0

- 漏洞讨论

PCAL is prone to a buffer overflow vulnerability. This issue is exposed when the application handles a calendar file that contains excessively long holiday data. Since calendar files may originate from an external or untrusted source, this vulnerability is considered to be remote in nature.

Successful exploitation of this issue will result in execution of arbitrary code as the user of the application.

- 漏洞利用

The following exploit example has been published:

- 解决方案

Debian has released advisory DSA 625-1 to address this issue. Please see the attached advisory for further information on obtaining and applying fixes.

The vendor has addressed this vulnerability in PCAL 4.8.0.


PCAL PCAL 4.1 .0

PCAL PCAL 4.3 .0

PCAL PCAL 4.5 .0

PCAL PCAL 4.6 .0

PCAL PCAL 4.7 .0

PCAL PCAL 4.7.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站