CVE-2004-1288
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:29:44
NMCOS    

[原文]Buffer overflow in the parse_html function in o3read.c for o3read 0.0.3 allows remote attackers to execute arbitrary code via a crafted SXW file.


[CNNVD]o3read o3read.c 缓冲区溢出漏洞(CNNVD-200501-197)

        o3read是一款开源的文档格式转换器。
        o3read 0.0.3中o3read.c的 parse_html 函数存在缓冲区溢出漏洞。
        使得远程攻击者可利用此漏洞,通过特别构造的SXW文件执行任意代码性代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1288
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1288
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-197
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18547
(UNKNOWN)  XF  o3read-parsehtml-bo(18547)
http://www.gentoo.org/security/en/glsa/glsa-200501-20.xml
(UNKNOWN)  GENTOO  GLSA-200501-20
http://tigger.uic.edu/~jlongs2/holes/o3read.txt
(VENDOR_ADVISORY)  MISC  http://tigger.uic.edu/~jlongs2/holes/o3read.txt

- 漏洞信息

o3read o3read.c 缓冲区溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        o3read是一款开源的文档格式转换器。
        o3read 0.0.3中o3read.c的 parse_html 函数存在缓冲区溢出漏洞。
        使得远程攻击者可利用此漏洞,通过特别构造的SXW文件执行任意代码性代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://
        http://siag.nu/pub/o3read/

- 漏洞信息

12457
o3read parse_html Function SXW Document Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

O3Read HTML Parser Buffer Overflow Vulnerability
Boundary Condition Error 12000
Yes No
2004-12-17 12:00:00 2009-07-12 09:26:00
Discovery is credited to Wiktor Kopec.

- 受影响的程序版本

Siag o3read 0.0.3
+ Gentoo Linux
Siag o3read 0.0.4

- 不受影响的程序版本

Siag o3read 0.0.4

- 漏洞讨论

o3read is prone to a buffer overflow vulnerability. This issue is exposed when the program parses HTML content during file format conversion. This issue is considered to be remote in nature since it is possible that files may originate from an external or untrusted source.

Successful exploitation will result in code execution with the privileges of the user running the application.

- 漏洞利用

The following exploit example has been published:

- 解决方案

Gentoo has released an advisory to provide updates for this issue. Updates may be applied by running the following commands as the superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=app-text/o3read-0.0.4"

This issue has been addressed in o3read 0.0.4.


Siag o3read 0.0.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站