发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:29:44

[原文]Buffer overflow in the strexpand function in string.c for LinPopUp 1.2.0 allows remote attackers to execute arbitrary code via a crafted message that is not properly handled during a Reply operation.

[CNNVD]LinPopUp string.c 缓冲区溢出漏洞(CNNVD-200501-064)

        LinPopUp 1.2.0中string.c的strexpand函数存在缓冲区溢出。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  linpopup-strexpand-bo(18627)

- 漏洞信息

LinPopUp string.c 缓冲区溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
        LinPopUp 1.2.0中string.c的strexpand函数存在缓冲区溢出。

- 公告与补丁


- 漏洞信息

LinPopUp strexpand() Function Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

LinPopUp Remote Buffer Overflow Vulnerability
Boundary Condition Error 11997
Yes No
2004-12-15 12:00:00 2009-07-12 09:26:00
Discovery is credited to Stephen Dranger.

- 受影响的程序版本

LinPopUp LinPopUp 1.2
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
Gentoo Linux

- 漏洞讨论

LinPopUp is reported prone to a remote buffer overflow vulnerability. This issue arises because the application fails to carry out proper boundary checks before copying user-supplied data in to sensitive process buffers. It is reported that this issue can allow an attacker to gain unauthorized access to a computer in the context of the application.

An attacker can exploit this issue by crafting a malicious message that contains excessive string data, replacement memory addresses, and executable instructions to trigger this issue.

LinPopUp version 1.2.0 is reported prone to this vulnerability. It is likely that other versions are affected as well.

- 漏洞利用

A proof of concept exploit is available. This has not been verified by Symantec:

- 解决方案

Gentoo Linux has released advisory GLSA 200501-01 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
emerge --sync
emerge --ask --oneshot --verbose ">=net-im/linpopup-2.0.4-r1"
Please see the referenced advisory for further information.

Debian has released advisory DSA 632-1 to provide updates that address this vulnerability. Please see the attached advisory for further information on obtaining and applying updates.

LinPopUp LinPopUp 1.2

- 相关参考