CVE-2004-1274
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-05 16:40:51
NMCS    

[原文]The DownloadLoop function in main.c for greed 0.81p allows remote attackers to execute arbitrary code via a GRX file containing a filename with shell metacharacters.


[CNNVD]Greed DownloadLoop() 远程代码执行漏洞(CNNVD-200501-071)

        Greed是一款网络文件传输软件。
        Greed 0.81p版本中DownloadLoop函数存在远程代码执行漏洞。
        远程攻击者可通过一个包含shell的GRX文件,执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1274
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1274
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-071
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18634
(UNKNOWN)  XF  greed-downloadloop-command-execution(18634)
http://tigger.uic.edu/~jlongs2/holes/greed.txt
(VENDOR_ADVISORY)  MISC  http://tigger.uic.edu/~jlongs2/holes/greed.txt

- 漏洞信息

Greed DownloadLoop() 远程代码执行漏洞
危急 边界条件错误
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        Greed是一款网络文件传输软件。
        Greed 0.81p版本中DownloadLoop函数存在远程代码执行漏洞。
        远程攻击者可通过一个包含shell的GRX文件,执行任意代码。

- 公告与补丁

        目前厂商还没有提供此漏洞的相关补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://sheepkiller.nerim.net/ports/greed/
        注:项目已停止,无后继更新

- 漏洞信息

MySQL MaxDB WebDAV IF Parameter Remote Buffer Overflow Vulnerability
Boundary Condition Error 13378
Yes No
2005-04-26 12:00:00 2009-07-12 02:06:00
iDEFENSE Labs is credited with this discovery.

- 受影响的程序版本

MySQL AB MaxDB 7.5 .00.25
MySQL AB MaxDB 7.5 .00.24
MySQL AB MaxDB 7.5 .00.23
MySQL AB MaxDB 7.5 .00.19
MySQL AB MaxDB 7.5 .00.18
MySQL AB MaxDB 7.5 .00.16
MySQL AB MaxDB 7.5 .00.15
MySQL AB MaxDB 7.5 .00.14
MySQL AB MaxDB 7.5 .00.12
MySQL AB MaxDB 7.5 .00.11
MySQL AB MaxDB 7.5 .00.08
MySQL AB MaxDB 7.5 .00
MySQL AB MaxDB 7.5 .00.26

- 不受影响的程序版本

MySQL AB MaxDB 7.5 .00.26

- 漏洞讨论

A remote buffer overflow vulnerability affects MySQL MaxDB. This issue is due to a failure of the application to properly validate the length of user-supplied strings prior to copying them into static process buffers.

An attacker may exploit this issue to execute arbitrary code with the privileges of the user that activated the vulnerable application. This may facilitate unauthorized access or privilege escalation.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released an upgrade dealing with this issue.


MySQL AB MaxDB 7.5 .00.18

MySQL AB MaxDB 7.5 .00.08

MySQL AB MaxDB 7.5 .00.25

MySQL AB MaxDB 7.5 .00.12

MySQL AB MaxDB 7.5 .00.16

MySQL AB MaxDB 7.5 .00.23

MySQL AB MaxDB 7.5 .00.19

MySQL AB MaxDB 7.5 .00.24

MySQL AB MaxDB 7.5 .00.14

MySQL AB MaxDB 7.5 .00.11

MySQL AB MaxDB 7.5 .00.15

MySQL AB MaxDB 7.5 .00

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站