CVE-2004-1262
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-05 16:40:49
NMCO    

[原文]Buffer overflow in the bsb_open_header function in libbsb for bsb2ppm 0.0.6 allows remote attackers to execute arbitrary code via crafted BSB pictures.


[CNNVD]libbsb bsb2ppm 缓冲区溢出漏洞(CNNVD-200501-186)

        libbsb是一套C的BSB类型文件操作库,也包含了一些BSB文件与其他文件格式的转换程序。
        libbsb0.0.6版本中bsb2ppm程序的bsb_open_header函数存在缓冲溢出漏洞。
        远程攻击者可以通过特别构造的BSB图片,利用此漏洞执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1262
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1262
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-186
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18586
(UNKNOWN)  XF  bsb2ppm-bsbopenheader-bo(18586)
http://tigger.uic.edu/~jlongs2/holes/bsb2ppm.txt
(VENDOR_ADVISORY)  MISC  http://tigger.uic.edu/~jlongs2/holes/bsb2ppm.txt

- 漏洞信息

libbsb bsb2ppm 缓冲区溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        libbsb是一套C的BSB类型文件操作库,也包含了一些BSB文件与其他文件格式的转换程序。
        libbsb0.0.6版本中bsb2ppm程序的bsb_open_header函数存在缓冲溢出漏洞。
        远程攻击者可以通过特别构造的BSB图片,利用此漏洞执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://sourceforge.net/projects/libbsb/files/

- 漏洞信息

12434
libbsb bsb2ppm bsb_open_header() Function Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站