发布时间 :2005-01-10 00:00:00
修订时间 :2016-10-17 22:52:30

[原文]Cross-site scripting (XSS) vulnerability in index.php in Advanced Guestbook 2.3.1, 2.2, and possibly other versions allows remote attackers to inject arbitrary web script or HTML via the entry parameter.

[CNNVD]AdvancedGuestbook index.php 跨站脚本攻击漏洞(CNNVD-200501-163)

        Advance Guesbook是一套Web留言板程序。
        Advanced Guestbook 2.3.1、2.2,也可能还有其他版本中的index.php存在跨站点脚本攻击漏洞。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20041202 Advanced Guestbook
(UNKNOWN)  BUGTRAQ  20041204 Re: Advanced Guestbook
(UNKNOWN)  BID  11798
(UNKNOWN)  XF  advguestbook-indexphp-xss(18334)

- 漏洞信息

AdvancedGuestbook index.php 跨站脚本攻击漏洞
中危 跨站脚本
2005-01-10 00:00:00 2007-01-02 00:00:00
        Advance Guesbook是一套Web留言板程序。
        Advanced Guestbook 2.3.1、2.2,也可能还有其他版本中的index.php存在跨站点脚本攻击漏洞。

- 公告与补丁


- 漏洞信息 (24797)

Advanced Guestbook 2.2/2.3 Cross-Site Scripting Vulnerability (EDBID:24797)
php webapps
2004-12-02 Verified
0 Emile van Elen
N/A [点击下载]

It is reported that Advanced Guestbook is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in version 2.3.1 of Advanced Guestbook. Other versions may also be affected.<script>alert(document.cookie)</script>		

- 漏洞信息

Advanced Guestbook index.php entry Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Advanced Guestbook contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the entry variable upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-02 Unknow
2004-12-02 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者