CVE-2004-1210
CVSS6.8
发布时间 :2005-01-10 00:00:00
修订时间 :2016-10-17 22:52:26
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in proxylog.dat in IPCop 1.4.1 and possibly other versions, allows remote attackers to inject arbitrary web script or HTML via the (1) url or (2) part variables.


[CNNVD]IPCop proxylog.dat 跨站脚本攻击漏洞(CNNVD-200501-154)

        IPCop是一个Linux防火墙的发布版,提供防火墙功能,通过Web界面管理。
        IPCop(1.4.1版本,也可能包含其他版本)中的proxylog.dat存在跨站点脚本攻击漏洞。
        远程攻击者可利用url变量或其他某些变量,注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1210
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1210
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-154
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110197682705001&w=2
(UNKNOWN)  BUGTRAQ  20041201 [KA Advisory 0411291] IPCop Cross Site Scripting Vulnerability in proxylog.dat
http://www.securityfocus.com/bid/11779
(UNKNOWN)  BID  11779
http://xforce.iss.net/xforce/xfdb/18301
(UNKNOWN)  XF  ipcop-proxylogdat-xss(18301)

- 漏洞信息

IPCop proxylog.dat 跨站脚本攻击漏洞
中危 跨站脚本
2005-01-10 00:00:00 2007-01-02 00:00:00
远程  
        IPCop是一个Linux防火墙的发布版,提供防火墙功能,通过Web界面管理。
        IPCop(1.4.1版本,也可能包含其他版本)中的proxylog.dat存在跨站点脚本攻击漏洞。
        远程攻击者可利用url变量或其他某些变量,注入任意web脚本或HTML。

- 公告与补丁

        目前厂商还没有提供此漏洞的相关补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://sourceforge.net/apps/trac/ipcop/wiki

- 漏洞信息 (24792)

IPCop 1.4.1 Web Administration Interface Proxy Log HTML Injection Vulnerability (EDBID:24792)
multiple webapps
2004-11-30 Verified
0 Paul Kurczaba
N/A [点击下载]
source: http://www.securityfocus.com/bid/11779/info

IPCop is reported susceptible to an HTML injection vulnerability in its proxy log viewer. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated web pages.

This vulnerability allows remote, attacker-supplied malicious HTML or script code to be displayed to administrative users. This code would be executed in the context of the affected Web application. It is conjectured that it may be possible for attackers to cause administrative actions to be executed on their behalf when an administrator views the Squid logs. Theft of cookie-based authentication credentials and other attacks are also likely.

Version 1.4.1 of IPCop is reportedly vulnerable. Other versions may also be affected.

GET /<script>alert('XSS_PoC')</script> HTTP/1.1
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Host: example.com
Connection: Close		

- 漏洞信息

12243
IPCop proxylog.dat Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-06 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站