CVE-2004-1202
CVSS6.8
发布时间 :2005-01-10 00:00:00
修订时间 :2016-10-17 22:52:16
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in parser.php in phpCMS 1.2.1 and earlier, with non-stealth and debug modes enabled, allows remote attackers to inject arbitrary web script or HTML via the file parameter.


[CNNVD]phpCMS parser.php 跨站脚本执行漏洞(CNNVD-200501-022)

        phpCMS是一款基于PHP的内容服务程序。
        phpCMS 1.2.1及之前版本的parser.php存在跨站脚本攻击漏洞。
        当运行于no-stealth及debug模式下,远程攻击者可利用file参数注入任意Web脚本及HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpcms:phpcms:1.2
cpe:/a:phpcms:phpcms:1.1.9
cpe:/a:phpcms:phpcms:1.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1202
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1202
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-022
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2004-November/029499.html
(PATCH)  FULLDISC  20041126 phpCMS <= 1.2.1 Xss Vulnerability, Information disclosure
http://marc.info/?l=bugtraq&m=110149207123510&w=2
(UNKNOWN)  BUGTRAQ  20041126 phpCMS <= 1.2.1 Xss Vulnerability, Information disclosure
http://www.phpcms.de/download/index.en.html
(PATCH)  CONFIRM  http://www.phpcms.de/download/index.en.html
http://www.securityfocus.com/bid/11765
(PATCH)  BID  11765
http://xforce.iss.net/xforce/xfdb/18272
(PATCH)  XF  phpcms-parser-xss(18272)

- 漏洞信息

phpCMS parser.php 跨站脚本执行漏洞
中危 跨站脚本
2005-01-10 00:00:00 2007-01-02 00:00:00
远程  
        phpCMS是一款基于PHP的内容服务程序。
        phpCMS 1.2.1及之前版本的parser.php存在跨站脚本攻击漏洞。
        当运行于no-stealth及debug模式下,远程攻击者可利用file参数注入任意Web脚本及HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://sourceforge.net/projects/phpcms/files/

- 漏洞信息

12134
phpCMS parser.php file Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

phpCMS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the file variable upon submission to the parser.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-11-26 Unknow
2004-11-26 Unknow

- 解决方案

Upgrade to version 1.2.1pl1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站