CVE-2004-1187
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:29:27
NMCOP    

[原文]Heap-based buffer overflow in the pnm_get_chunk function for xine 0.99.2, and other packages such as MPlayer that use the same code, allows remote attackers to execute arbitrary code via long PNA_TAG values, a different vulnerability than CVE-2004-1188.


[CNNVD]Xine pnm_get_chunk 栈溢出漏洞(CNNVD-200501-205)

        是一个类UNIX操作系统下的多媒体播放引擎。
        Xine0.99.2中pnm_get_chunk函数存在栈溢出漏洞。
        攻击者可通过使用超长的PNA_TAG值,触发溢出,导致可执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:mandrakesoft:mandrake_linux:10.0::amd64
cpe:/a:xine:xine-lib:1_beta1
cpe:/a:xine:xine-lib:0.9.13
cpe:/a:xine:xine-lib:1_rc0
cpe:/a:xine:xine-lib:1_rc3c
cpe:/a:xine:xine:1_rc3b
cpe:/a:mplayer:mplayer:0.91
cpe:/a:xine:xine:1_rc0a
cpe:/a:xine:xine:1_beta12
cpe:/a:mplayer:mplayer:0.92_cvs
cpe:/a:xine:xine:1_rc3a
cpe:/a:xine:xine:1_alpha
cpe:/a:xine:xine:0.9.13
cpe:/a:xine:xine:1_beta9
cpe:/a:xine:xine:1_beta8
cpe:/a:xine:xine:1_rc2
cpe:/a:xine:xine-lib:1_beta9
cpe:/a:xine:xine-lib:1_beta11
cpe:/a:xine:xine:1_beta11
cpe:/a:mplayer:mplayer:0.90_pre
cpe:/a:xine:xine:1_rc1
cpe:/a:mplayer:mplayer:1.0_pre4
cpe:/a:xine:xine:1_rc7
cpe:/a:xine:xine-lib:1_rc3
cpe:/a:xine:xine-lib:1_rc5
cpe:/a:xine:xine:1_rc5
cpe:/a:mplayer:mplayer:0.92
cpe:/a:mplayer:mplayer:1.0_pre2
cpe:/a:xine:xine-lib:1_rc6a
cpe:/a:xine:xine:1_beta5
cpe:/a:xine:xine-lib:1_beta2
cpe:/a:xine:xine:1_beta4
cpe:/a:xine:xine-lib:1_beta5
cpe:/a:xine:xine-lib:1_alpha
cpe:/a:xine:xine:0.9.8
cpe:/a:mplayer:mplayer:head_cvs
cpe:/a:xine:xine-lib:0.99
cpe:/a:xine:xine-lib:1_beta12
cpe:/a:xine:xine:1_beta1
cpe:/a:xine:xine:1_beta10
cpe:/o:mandrakesoft:mandrake_linux:10.1MandrakeSoft Mandrake Linux 10.1
cpe:/a:xine:xine-lib:0.9.8
cpe:/a:mplayer:mplayer:0.90_rc
cpe:/a:xine:xine-lib:1_beta7
cpe:/a:mplayer:mplayer:1.0_pre3
cpe:/a:xine:xine:1_beta6
cpe:/a:xine:xine-lib:1_rc6
cpe:/a:mplayer:mplayer:1.0_pre5
cpe:/a:mplayer:mplayer:1.0_pre5try1
cpe:/a:xine:xine-lib:1_beta8
cpe:/o:mandrakesoft:mandrake_linux:10.1::x86_64
cpe:/a:xine:xine-lib:1_beta3
cpe:/a:xine:xine-lib:1_rc3a
cpe:/a:xine:xine:1_rc3
cpe:/a:xine:xine:1_beta2
cpe:/a:xine:xine:1_rc6
cpe:/a:mplayer:mplayer:0.90_rc4
cpe:/a:mplayer:mplayer:1.0_pre5try2
cpe:/a:xine:xine:1_beta3
cpe:/a:xine:xine-lib:1_rc2
cpe:/a:xine:xine-lib:1_rc7
cpe:/a:xine:xine:1_beta7
cpe:/a:xine:xine:1_rc4
cpe:/a:xine:xine-lib:1_rc4
cpe:/a:xine:xine:1_rc6a
cpe:/a:xine:xine-lib:1_beta10
cpe:/a:xine:xine-lib:1_rc1
cpe:/o:mandrakesoft:mandrake_linux:10.0MandrakeSoft Mandrake Linux 10.0
cpe:/a:mplayer:mplayer:1.0_pre1
cpe:/a:xine:xine-lib:1_beta4
cpe:/a:xine:xine-lib:1_beta6
cpe:/a:xine:xine:1_rc0
cpe:/a:mplayer:mplayer:0.92.1
cpe:/a:xine:xine:0.9.18
cpe:/a:mplayer:mplayer:1.0_pre3try2
cpe:/a:xine:xine:1_rc8
cpe:/a:mplayer:mplayer:0.90
cpe:/a:xine:xine-lib:1_rc3b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1187
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1187
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-205
(官方数据源) CNNVD

- 其它链接及资源

http://www.idefense.com/application/poi/display?id=176&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20041221 Multiple Vendor Xine version 0.99.2 PNM Handler PNA_TAG Heap Overflow Vulnerability
http://xforce.iss.net/xforce/xfdb/18640
(UNKNOWN)  XF  xine-pnatag-bo(18640)
http://www.mplayerhq.hu/MPlayer/patches/pnm_fix_20041215.diff
(UNKNOWN)  CONFIRM  http://www.mplayerhq.hu/MPlayer/patches/pnm_fix_20041215.diff
http://www.mandriva.com/security/advisories?name=MDKSA-2005:011
(UNKNOWN)  MANDRAKE  MDKSA-2005:011
http://cvs.sourceforge.net/viewcvs.py/xine/xine-lib/src/input/pnm.c?r1=1.20&r2=1.21
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/xine/xine-lib/src/input/pnm.c?r1=1.20&r2=1.21

- 漏洞信息

Xine pnm_get_chunk 栈溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-28 00:00:00
远程  
        是一个类UNIX操作系统下的多媒体播放引擎。
        Xine0.99.2中pnm_get_chunk函数存在栈溢出漏洞。
        攻击者可通过使用超长的PNA_TAG值,触发溢出,导致可执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.xine-project.org/releases

- 漏洞信息 (F35476)

iDEFENSE Security Advisory 2004-12-21.2 (PacketStormID:F35476)
2004-12-31 00:00:00
iDefense Labs  idefense.com
advisory,remote,overflow,arbitrary
CVE-2004-1187
[点击下载]

iDEFENSE Security Advisory 12.21.2004-2 - Remote exploitation of a buffer overflow in version 0.99.2 of xine could allow execution of arbitrary code. The vulnerability specifically exists in the PNA_TAG handling code of the pnm_get_chunk() function. The function does not check the if the length of an input to be stored in a fixed size buffer is larger than the buffer size.

Multiple Vendor Xine version 0.99.2 PNM Handler PNA_TAG Heap Overflow
Vulnerability

iDEFENSE Security Advisory 12.21.04
www.idefense.com/application/poi/display?id=176&type=vulnerabilities
December 21, 2004

I. BACKGROUND

Xine is a multimedia player which runs on multiple platforms.
More information is available at:

   http://xinehq.de/

II. DESCRIPTION

Remote exploitation of a buffer overflow in version 0.99.2 of xine could

allow execution of arbitrary code.

The vulnerability specifically exists in the PNA_TAG handling code of 
the pnm_get_chunk() function. The function does not check the if the 
length of an input to be stored in a fixed size buffer is larger than 
the buffer size.

III. ANALYSIS

Exploitation of this vulnerability allows execution of arbitrary code 
with the privileges of the targeted user.

In order to exploit this vulnerability, an attacker would have to 
convince the targeted user to open a connection to a malicious PNM 
server with xine, using a pnm://address/ URL. Depending on configuration

options, this may be exploitable simply by clicking on a link, or it may

require the user to launch the application, specifically requesting the 
malicious content.

IV. DETECTION

iDEFENSE Labs has confirmed the existence of this vulnerability in xine 
version 0.99.2. It is suspected that earlier versions of xine also 
contain this vulnerability.

This vulnerability also affects MPlayer prior to MPlayer 1.0pre5try2.

V. WORKAROUND
iDEFENSE is currently unaware of any effective workarounds for this 
issue.

VI. VENDOR RESPONSE

xine-lib 1-rc8 was released to address this vulnerability and is
available for download at:

   http://xinehq.de/index.php/releases
   
An xine patch for this vulnerability is available at:

 
http://cvs.sourceforge.net/viewcvs.py/xine/xine-lib/src/input/pnm.c?r1=1
.20&r2=1.21

An MPlayer patch for this vulnerability is available at:

   http://www.mplayerhq.hu/MPlayer/patches/pnm_fix_20041215.diff

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
names CAN-2004-1187 to these issues. This is a candidate for inclusion
in the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

12/10/2004  Initial vendor notification
12/11/2004  Initial vendor response
12/21/2004  Public disclosure

IX. CREDIT

The discoverer of this vulnerability wishes to remain anonymous.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

X. LEGAL NOTICES

Copyright (c) 2004 iDEFENSE, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.
    

- 漏洞信息

12661
xine PNM Handler PNA_TAG Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Patch / RCS, Upgrade
Exploit Private Vendor Verified, Coordinated Disclosure

- 漏洞描述

- 时间线

2004-12-21 Unknow
Unknow 2004-12-21

- 解决方案

Upgrade to version 1-rc8 or higher, as it has been reported to fix this vulnerability. In addition, xine and Mplayer have released patches for some older versions.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站