CVE-2004-1179
CVSS2.1
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:40:37
NMCOPS    

[原文]The debstd script in debmake 3.6.x before 3.6.10 and 3.7.x before 3.7.7 allows local users to overwrite arbitrary files via a symlink attack on temporary directories.


[CNNVD]Debian Debmake本地不安全临时文件创建漏洞(CNNVD-200412-373)

        debmake 3.6.10之前的3.6.x版本和3.7.x之前的3.7.x版本的debstd脚本存在漏洞。本地用户可以借助临时目录的符号链接攻击覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:debian:debmake:3.6.9Debian debmake 3.6.9
cpe:/a:debian:debmake:3.7.6Debian debmake 3.7.6
cpe:/a:debian:debmake:3.6Debian debmake 3.6
cpe:/a:debian:debmake:3.7Debian debmake 3.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1179
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1179
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-373
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12078
(PATCH)  BID  12078
http://www.derkeiler.com/Mailing-Lists/Full-Disclosure/2004-12/0645.html
(PATCH)  FULLDISC  20041223 [USN-49-1] debmake vulnerability
http://www.debian.org/security/2004/dsa-615
(VENDOR_ADVISORY)  DEBIAN  DSA-615
http://secunia.com/advisories/13633/
(PATCH)  SECUNIA  13633
http://xforce.iss.net/xforce/xfdb/18646
(UNKNOWN)  XF  debmake-debstd-symlink(18646)

- 漏洞信息

Debian Debmake本地不安全临时文件创建漏洞
低危 设计错误
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        debmake 3.6.10之前的3.6.x版本和3.7.x之前的3.7.x版本的debstd脚本存在漏洞。本地用户可以借助临时目录的符号链接攻击覆盖任意文件。

- 公告与补丁

        Debian has released an advisory (DSA 615-1) and an upgrade dealing with this issue. Please see the referenced advisory for more information.
        Ubuntu has released an advisory (USN-49-1) dealing with this issue. Please see the referenced advisory for more information.
        Debian debmake 3.6.9
        
        Ubuntu Ubuntu Linux 4.1 ppc
        
        Ubuntu Ubuntu Linux 4.1 ia32
        
        Ubuntu Ubuntu Linux 4.1 ia64
        

- 漏洞信息 (F35485)

dsa-615.txt (PacketStormID:F35485)
2004-12-31 00:00:00
 
advisory,arbitrary
linux,debian
CVE-2004-1179
[点击下载]

Debian Security Advisory 615-1 - It has been noticed that the debstd script from debmake, a deprecated helper package for Debian packaging, created temporary directories in an insecure manner. This can be exploited by a malicious user to overwrite arbitrary files owned by the victim.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 615-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
December 22nd, 2004                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : debmake
Vulnerability  : insecure temporary files
Problem-Type   : local
Debian-specific: yes
CVE ID         : CAN-2004-1179
Debian Bug     : 286382

Javier Fern    

- 漏洞信息

12567
Debian debmake debstd Script Insecure Temporary Directory Arbitrary File Overwrite
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Debian Debmake Local Insecure Temporary File Creation Vulnerability
Design Error 12078
No Yes
2004-12-22 12:00:00 2009-07-12 09:26:00
Javier Fernández-Sanguino Peña is credited with the discovery of this issue.

- 受影响的程序版本

Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Debian debmake 3.6.9
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
Debian debmake 3.6.10
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 不受影响的程序版本

Debian debmake 3.6.10
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

A local insecure file creation vulnerability affects Debian's debmake. This issue is due to a design error that causes the affected application to create temporary files insecurely.

An attacker may leverage this issue to corrupt arbitrary files with the privileges of the user that activates the affected application.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Debian has released an advisory (DSA 615-1) and an upgrade dealing with this issue. Please see the referenced advisory for more information.

Ubuntu has released an advisory (USN-49-1) dealing with this issue. Please see the referenced advisory for more information.


Debian debmake 3.6.9

Ubuntu Ubuntu Linux 4.1 ia32

Ubuntu Ubuntu Linux 4.1 ia64

Ubuntu Ubuntu Linux 4.1 ppc

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站