CVE-2004-1171
CVSS2.1
发布时间 :2005-01-10 00:00:00
修订时间 :2016-10-17 22:52:00
NMCOS    

[原文]KDE 3.2.x and 3.3.0 through 3.3.2, when saving credentials that are (1) manually entered by the user or (2) created by the SMB protocol handler, stores those credentials for plaintext in the user's .desktop file, which may be created with world-readable permissions, which could allow local users to obtain usernames and passwords for remote resources such as SMB shares.


[CNNVD]KDE SMB用户凭证 信息泄露漏洞(CNNVD-200501-180)

        KDE是一个运行于类Unix操作系统的桌面环境。
        KDE 3.2.x及3.3.0至3.3.2版本中存在信息泄露漏洞。
        在保存用户手工输入或由 SMB 协议处理器创建的SMB用户凭证时,KDE以明文方式将用户凭证保存于用户的.desktop文件中,而该文件是所有人可读的。使得本地用户可以获取SMB用户名和密码,从而获得远程资源。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:mandrakesoft:mandrake_linux:10.1::x86_64
cpe:/o:kde:kde:3.2.2
cpe:/o:kde:kde:3.3.1
cpe:/o:kde:kde:3.2
cpe:/o:kde:kde:3.2.1
cpe:/o:redhat:fedora_core:core_2.0
cpe:/o:mandrakesoft:mandrake_linux:10.0::amd64
cpe:/o:redhat:fedora_core:core_3.0
cpe:/o:mandrakesoft:mandrake_linux:10.1MandrakeSoft Mandrake Linux 10.1
cpe:/o:kde:kde:3.3
cpe:/o:kde:kde:3.2.3
cpe:/o:kde:kde:3.3.2
cpe:/o:mandrakesoft:mandrake_linux:10.0MandrakeSoft Mandrake Linux 10.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1171
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1171
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-180
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/fulldisclosure/2004-11/1292.html
(UNKNOWN)  FULLDISC  20041129 Password Disclosure for SMB Shares in KDE's Konqueror
http://marc.info/?l=bugtraq&m=110178786809694&w=2
(UNKNOWN)  BUGTRAQ  20041129 Password Disclosure for SMB Shares in KDE's Konqueror
http://marc.info/?l=bugtraq&m=110261063201488&w=2
(UNKNOWN)  BUGTRAQ  20041209 KDE Security Advisory: plain text password exposure
http://securitytracker.com/id?1012471
(UNKNOWN)  SECTRACK  1012471
http://www.ciac.org/ciac/bulletins/p-051.shtml
(UNKNOWN)  CIAC  P-051
http://www.gentoo.org/security/en/glsa/glsa-200412-16.xml
(UNKNOWN)  GENTOO  GLSA-200412-16
http://www.kb.cert.org/vuls/id/305294
(VENDOR_ADVISORY)  CERT-VN  VU#305294
http://www.kde.org/info/security/advisory-20041209-1.txt
(UNKNOWN)  CONFIRM  http://www.kde.org/info/security/advisory-20041209-1.txt
http://www.mandriva.com/security/advisories?name=MDKSA-2004:150
(UNKNOWN)  MANDRAKE  MDKSA-2004:150
http://www.sec-consult.com/index.php?id=118
(UNKNOWN)  MISC  http://www.sec-consult.com/index.php?id=118
http://www.securityfocus.com/bid/11866
(VENDOR_ADVISORY)  BID  11866
http://xforce.iss.net/xforce/xfdb/18267
(UNKNOWN)  XF  kde-smb-password-plaintext(18267)

- 漏洞信息

KDE SMB用户凭证 信息泄露漏洞
低危 设计错误
2005-01-10 00:00:00 2005-10-20 00:00:00
本地  
        KDE是一个运行于类Unix操作系统的桌面环境。
        KDE 3.2.x及3.3.0至3.3.2版本中存在信息泄露漏洞。
        在保存用户手工输入或由 SMB 协议处理器创建的SMB用户凭证时,KDE以明文方式将用户凭证保存于用户的.desktop文件中,而该文件是所有人可读的。使得本地用户可以获取SMB用户名和密码,从而获得远程资源。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.kde.org/download/

- 漏洞信息

12248
KDE Konqueror Shortcut SMB Share Password Disclosure

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-11-29 2004-10-06
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

KDE Plaintext Password Disclosure Vulnerability
Design Error 11866
No Yes
2004-12-09 12:00:00 2009-07-12 08:07:00
Discovery is credited to Daniel Fabian.

- 受影响的程序版本

S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux 8.1
S.u.S.E. Linux 8.0 i386
S.u.S.E. Linux 8.0
Red Hat Fedora Core3
Red Hat Fedora Core2
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
KDE KDE 3.3.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
+ Debian Linux 3.1
KDE KDE 3.3.1
+ Red Hat Fedora Core3
KDE KDE 3.3
KDE KDE 3.2.3
KDE KDE 3.2.2
+ KDE KDE 3.2.2
+ Red Hat Fedora Core2
KDE KDE 3.2.1
KDE KDE 3.2

- 漏洞讨论

KDE is reported prone to a plaintext password disclosure vulnerability. This issue presents itself when a link to a remote file is created by various KDE applications including Konqueror Web browser. The URI may contain authentication credentials to access the remote resource such as a Samba share.

An attacker can disclose these credentials by accessing the potentially world readable link reference file created by KDE.

- 漏洞利用

An exploit is not required to leverage this issue.

- 解决方案

KDE security has released patches to address this issue in KDE 3.2.3, 3.3.1, and 3.3.2. Please see the KDE advisory in Web references for more information.

RedHat has released advisories FEDORA-2004-548, FEDORA-2004-549, FEDORA-2004-550, and FEDORA-2004-551 to address this issue in Fedora Core 2 and 3. Please see the referenced advisories for further information.

Mandrake has released advisory MDKSA-2004:150 and fixes to address this issue. Please see the referenced advisory for further information.

Gentoo has released an advisory to provide updates for this issue. Updates may be applied by running the following commands as the superuser:

(For kdelibs)
emerge --sync
emerge --ask --oneshot --verbose ">=kde-base/kdelibs-3.2.3-r4"

(For kdebase)
emerge --sync
emerge --ask --oneshot --verbose ">=kde-base/kdebase-3.2.3-r3"

SuSE Linux has released a security summary report (SUSE-SR:2005:003) that contains fixes to address this and other vulnerabilities. Customers are advised to peruse the referenced advisory for further information regarding obtaining and applying appropriate updates.


KDE KDE 3.2

KDE KDE 3.2.1

KDE KDE 3.2.2

KDE KDE 3.2.3

KDE KDE 3.3

KDE KDE 3.3.1

KDE KDE 3.3.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站