CVE-2004-1167
CVSS5.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:29:26
NMCO    

[原文]mirrorselect before 0.89 creates temporary files in a world-writable location with predictable file names, which allows remote attackers to overwrite arbitrary files via a symlink attack.


[CNNVD]Gentoo Mirrorselect 文件覆盖漏洞(CNNVD-200501-155)

        mirrorselect是一个镜像站点选择程序。
        mirrorselect 0.89及之前版本存在文件覆盖漏洞。
        由于mirrorselect在任意用户均可写的位置上创建临时文件,并且文件名是可被预测的,这使得远程攻击者可通过符号链接方式,覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gentoo:mirrorselect:0.88Gentoo mirrorselect 0.88
cpe:/a:gentoo:mirrorselect:0.86Gentoo mirrorselect 0.86
cpe:/a:gentoo:mirrorselect:0.82Gentoo mirrorselect 0.82
cpe:/a:gentoo:mirrorselect:0.80Gentoo mirrorselect 0.80
cpe:/a:gentoo:mirrorselect:0.87Gentoo mirrorselect 0.87
cpe:/a:gentoo:mirrorselect:0.83Gentoo mirrorselect 0.83
cpe:/a:gentoo:mirrorselect:0.81Gentoo mirrorselect 0.81
cpe:/a:gentoo:mirrorselect:0.84Gentoo mirrorselect 0.84
cpe:/a:gentoo:mirrorselect:0.85Gentoo mirrorselect 0.85

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1167
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1167
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-155
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200412-05.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200412-05
http://xforce.iss.net/xforce/xfdb/18382
(VENDOR_ADVISORY)  XF  mirrorselect-symlink(18382)
http://secunia.com/advisories/13392/
(UNKNOWN)  SECUNIA  13392

- 漏洞信息

Gentoo Mirrorselect 文件覆盖漏洞
中危 未知
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        mirrorselect是一个镜像站点选择程序。
        mirrorselect 0.89及之前版本存在文件覆盖漏洞。
        由于mirrorselect在任意用户均可写的位置上创建临时文件,并且文件名是可被预测的,这使得远程攻击者可通过符号链接方式,覆盖任意文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.gentoo.org/security/en/glsa/glsa-200412-05.xml

- 漏洞信息

12254
Gentoo mirrorselect Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Gentoo mirrorselect contains a flaw that may allow a malicious user to overwrite arbitrary files using symlink attacks. The issue is triggered when mirrorselect is executed and it overwritten the file with the user running mirror select permissions. It is possible that the flaw may allow arbitrary files being overwritten resulting in a loss of integrity.

- 时间线

2004-12-07 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.89 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站