CVE-2004-1153
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:29:21
NMCOP    

[原文]Format string vulnerability in Adobe Acrobat Reader 6.0.0 through 6.0.2 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via an .ETD document containing format string specifiers in (1) title or (2) baseurl fields.


[CNNVD]Adobe AcrobatReader .ETD 格式串漏洞(CNNVD-200501-069)

        Adobe Acrobat Reader是使用较为广泛的PDF文档查看器。
        Adobe AcrobatReader6.0.0至6.0.2版本中存在格式串漏洞。
        由于在处理.etd文件时存在处理格式串错误,远程攻击者可以利用这个漏洞,通过构造title或baseurl中包含特殊格式串的.ETD文档,导致程序崩溃或执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:adobe:acrobat_reader:8.0Adobe Acrobat Reader 8.0
cpe:/a:adobe:acrobat_reader:6.0.2Adobe Acrobat Reader 6.0.2
cpe:/a:adobe:acrobat_reader:6.0Adobe Acrobat Reader 6.0

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:2919Adobe Acrobat Reader .ETD Document Code Execution Vulnerability
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1153
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1153
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-069
(官方数据源) CNNVD

- 其它链接及资源

http://www.idefense.com/application/poi/display?id=163&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20041214 Adobe Reader 6.0 .ETD File Format String Vulnerability
http://xforce.iss.net/xforce/xfdb/18478
(UNKNOWN)  XF  adobe-acrobat-etd-format-string(18478)
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2679
(UNKNOWN)  CONFIRM  http://www.adobe.com/support/downloads/detail.jsp?ftpID=2679

- 漏洞信息

Adobe AcrobatReader .ETD 格式串漏洞
危急 格式化字符串
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        Adobe Acrobat Reader是使用较为广泛的PDF文档查看器。
        Adobe AcrobatReader6.0.0至6.0.2版本中存在格式串漏洞。
        由于在处理.etd文件时存在处理格式串错误,远程攻击者可以利用这个漏洞,通过构造title或baseurl中包含特殊格式串的.ETD文档,导致程序崩溃或执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.adobe.com/products/reader/

- 漏洞信息 (F35341)

iDEFENSE Security Advisory 2004-12-13.2 (PacketStormID:F35341)
2004-12-30 00:00:00
iDefense Labs,Greg MacManus  idefense.com
advisory,remote,arbitrary
CVE-2004-1153
[点击下载]

iDEFENSE Security Advisory 12.13.2004-2 - Remote exploitation of a format string vulnerability in version 6.0.2 of Adobe's Reader could allow attackers to execute arbitrary code.

Adobe Reader 6.0 .ETD File Format String Vulnerability 

iDEFENSE Security Advisory 12.13.04
www.idefense.com/application/poi/display?id=163&type=vulnerabilities
December 14, 2004

I. BACKGROUND

Adobe Acrobat Reader is a program for viewing Portable Document Format
(PDF) documents. More information is available at the following site:

   http://www.adobe.com/products/acrobat/readermain.html

II. DESCRIPTION

Remote exploitation of a format string vulnerability in version 6.0.2 
of Adobe's Reader could allow attackers to execute arbitrary code.

The problem specifically exists in the parsing of .etd files used in 
eBook transactions. A .etd file containing a format string in the 
'title' or 'baseurl' fields can cause an invalid memory access:

<title>|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|</title>
<baseurl>|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|%p|</baseurl>

This may allow for the execution of arbitrary code.

III. ANALYSIS

Successful exploitation allows an attacker to execute arbitrary code 
under the privileges of the local user. Remote exploitation is possible 
by sending a specially crafted e-mail and attaching either the 
maliciously crafted PDF document or a link to it.

IV. DETECTION

iDEFENSE has confirmed that Adobe Reader version 6.0.2 is vulnerable. 
It is suspected that earlier versions of Adobe Reader 6 are also 
vulnerable. Adobe Acrobat may also be vulnerable.

V. WORKAROUND

Deleting the following file will prevent exploitation of this 
vulnerability:

"C:\Program Files\Adobe\Acrobat 6.0\Reader\plug_ins\eBook.api"

This will not impact reading .PDF files.

Removing this file prevents Adobe Reader from handling eBooks. When a 
file handled by this plugin is detected, an error dialog box will
appear, offering to take the user to Adobe's website for information.

VI. VENDOR RESPONSE

This vulnerability is addressed in Adobe Acrobat Reader 6.0.3. Downloads
for platform specific versions are available at the links shown below:

Reader/Win:
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2679

Reader/Mac:
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2680

Acrobat/Win:
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2677

Acrobat/Mac:
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2676

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
names CAN-2004-1153 to these issues. This is a candidate for inclusion
in the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

10/13/2004  Initial vendor notification
10/14/2004  Initial vendor response
12/14/2004  Coordinated public disclosure

IX. CREDIT

This vulnerability was discovered by Greg MacManus, iDEFENSE Labs.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

X. LEGAL NOTICES

Copyright (c) 2004 iDEFENSE, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.
    

- 漏洞信息

12384
Adobe Reader .etd File Multiple Field Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

Adobe Reader contains a flaw that may allow a malicious user to dislose sensitive information or compromise a system. The issue is triggered when a format string error occurs when parsing a .etd file of a specialy crafted ebook. It is possible that the flaw may allow arbritary code to be executed resulting in a loss of confidentiality and/or integrity.

- 时间线

2004-12-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 6.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站