CVE-2004-1146
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2016-10-17 22:51:43
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in (1) main.c and (2) login.c for CVSTrac before 1.1.5 allow remote attackers to inject arbitrary HTML and web script.


[CNNVD]CVSTrac未明和跨站脚本漏洞(CNNVD-200412-835)

        CVSTrac 1.1.5以前版本的(1)main.c和(2)login.c存在多个跨站脚本漏洞。远程攻击者可以利用该漏洞注入任意HTML和web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:cvstrac:cvstrac:1.1
cpe:/a:cvstrac:cvstrac:1.1.1
cpe:/a:cvstrac:cvstrac:1.1.4
cpe:/a:cvstrac:cvstrac:1.1.3
cpe:/a:cvstrac:cvstrac:1.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1146
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1146
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-835
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2004-December/030222.html
(UNKNOWN)  FULLDISC  20041223 Cross-Site Scripting - an industry-wide problem
http://marc.info/?l=bugtraq&m=110332469631253&w=2
(UNKNOWN)  OPENPKG  OpenPKG-SA-2004.056
http://www.cvstrac.org/cvstrac/chngview?cn=320
(PATCH)  CONFIRM  http://www.cvstrac.org/cvstrac/chngview?cn=320
http://www.cvstrac.org/cvstrac/chngview?cn=321
(PATCH)  CONFIRM  http://www.cvstrac.org/cvstrac/chngview?cn=321
http://www.mikx.de/index.php?p=6
(UNKNOWN)  MISC  http://www.mikx.de/index.php?p=6
http://www.securityfocus.com/bid/12017
(PATCH)  BID  12017
http://xforce.iss.net/xforce/xfdb/18726
(UNKNOWN)  XF  cvstrac-main-login-xss(18726)

- 漏洞信息

CVSTrac未明和跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        CVSTrac 1.1.5以前版本的(1)main.c和(2)login.c存在多个跨站脚本漏洞。远程攻击者可以利用该漏洞注入任意HTML和web脚本。

- 公告与补丁

        The vendor has released version 1.1.5 of the application to resolve this issue.
        OpenPKG has released advisory OpenPKG-SA-2004.056 to address this issue. Please see the referenced advisory for further information.
        CVSTrac CVSTrac 1.1
        
        CVSTrac CVSTrac 1.1.1
        
        CVSTrac CVSTrac 1.1.2
        
        CVSTrac CVSTrac 1.1.3
        
        CVSTrac CVSTrac 1.1.4
        

- 漏洞信息

12683
CVSTrac main.c XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CVSTrac Unspecified Cross-Site Scripting Vulnerability
Input Validation Error 12017
Yes No
2004-12-17 12:00:00 2009-07-12 09:26:00
Michael Krax disclosed this vulnerability.

- 受影响的程序版本

OpenPKG OpenPKG 2.2
OpenPKG OpenPKG 2.1
OpenPKG OpenPKG Current
CVSTrac CVSTrac 1.1.4
CVSTrac CVSTrac 1.1.3
CVSTrac CVSTrac 1.1.2
CVSTrac CVSTrac 1.1.1
CVSTrac CVSTrac 1.1
CVSTrac CVSTrac 1.1.5

- 不受影响的程序版本

CVSTrac CVSTrac 1.1.5

- 漏洞讨论

CVSTrac is reported susceptible to an unspecified cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI data prior to including it in dynamically generated web page content.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in versions prior to 1.1.5 of CVSTrac.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released version 1.1.5 of the application to resolve this issue.

OpenPKG has released advisory OpenPKG-SA-2004.056 to address this issue. Please see the referenced advisory for further information.


CVSTrac CVSTrac 1.1

CVSTrac CVSTrac 1.1.1

CVSTrac CVSTrac 1.1.2

CVSTrac CVSTrac 1.1.3

CVSTrac CVSTrac 1.1.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站