CVE-2004-1142
CVSS5.0
发布时间 :2004-12-15 00:00:00
修订时间 :2010-08-21 00:21:55
NMCOP    

[原文]Ethereal 0.9.0 through 0.10.7 allows remote attackers to cause a denial of service (CPU consumption) via a certain malformed SMB packet.


[CNNVD]Ethereal多个未明的服务拒绝和潜在的代码执行漏洞(CNNVD-200412-063)

        Ethereal 0.9.0至0.10.7版本存在漏洞。远程攻击者借助某些畸形SMB包导致服务拒绝(CPU的消耗)。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:redhat:enterprise_linux:2.1::workstation_ia64
cpe:/a:ethereal_group:ethereal:0.9
cpe:/a:ethereal_group:ethereal:0.9.11
cpe:/o:debian:debian_linux:3.0::mips
cpe:/a:ethereal_group:ethereal:0.9.16
cpe:/a:ethereal_group:ethereal:0.9.2
cpe:/o:redhat:enterprise_linux:2.1::advanced_server
cpe:/a:ethereal_group:ethereal:0.9.4
cpe:/o:debian:debian_linux:3.0::s-390
cpe:/a:sgi:propack:3.0SGI ProPack 3.0
cpe:/o:debian:debian_linux:3.0::alpha
cpe:/o:redhat:linux_advanced_workstation:2.1::itanium_processor
cpe:/o:redhat:enterprise_linux:3.0::workstation_server
cpe:/o:redhat:enterprise_linux:3.0::enterprise_server
cpe:/a:ethereal_group:ethereal:0.9.15
cpe:/o:debian:debian_linux:3.0::mipsel
cpe:/a:ethereal_group:ethereal:0.9.3
cpe:/o:redhat:enterprise_linux:2.1::enterprise_server
cpe:/a:ethereal_group:ethereal:0.10.3
cpe:/o:redhat:linux_advanced_workstation:2.1::ia64
cpe:/o:altlinux:alt_linux:2.3::junior
cpe:/o:debian:debian_linux:3.0::hppa
cpe:/o:redhat:enterprise_linux:2.1::advanced_server_ia64
cpe:/a:ethereal_group:ethereal:0.9.14
cpe:/a:ethereal_group:ethereal:0.10.6
cpe:/o:conectiva:linux:9.0Conectiva Linux 9.0
cpe:/o:suse:suse_linux:8.0::i386
cpe:/o:redhat:enterprise_linux:2.1::enterprise_server_ia64
cpe:/o:suse:suse_linux:9.0SuSE SuSE Linux 9.0
cpe:/o:suse:suse_linux:8.2SuSE SuSE Linux 8.2
cpe:/a:ethereal_group:ethereal:0.10
cpe:/a:ethereal_group:ethereal:0.9.8
cpe:/o:debian:debian_linux:3.0::ia-32
cpe:/o:redhat:enterprise_linux:3.0::advanced_server
cpe:/o:suse:suse_linux:8.1SuSE SuSE Linux 8.1
cpe:/a:ethereal_group:ethereal:0.9.5
cpe:/o:suse:suse_linux:9.2SuSE SuSE Linux 9.2
cpe:/o:debian:debian_linux:3.0::arm
cpe:/a:ethereal_group:ethereal:0.10.1
cpe:/a:ethereal_group:ethereal:0.9.12
cpe:/a:ethereal_group:ethereal:0.10.2
cpe:/a:ethereal_group:ethereal:0.10.7
cpe:/o:suse:suse_linux:9.1SuSE SuSE Linux 9.1
cpe:/a:ethereal_group:ethereal:0.10.4
cpe:/o:conectiva:linux:10.0Conectiva Linux 10.0
cpe:/a:ethereal_group:ethereal:0.10.5
cpe:/o:debian:debian_linux:3.0::ppc
cpe:/o:altlinux:alt_linux:2.3::compact
cpe:/a:ethereal_group:ethereal:0.9.7
cpe:/o:redhat:enterprise_linux:2.1::workstation
cpe:/a:ethereal_group:ethereal:0.9.9
cpe:/o:debian:debian_linux:3.0::m68k
cpe:/a:ethereal_group:ethereal:0.9.10
cpe:/o:suse:suse_linux:9.0::x86_64
cpe:/o:suse:suse_linux:8.0SuSE SuSE Linux 8.0
cpe:/a:ethereal_group:ethereal:0.9.13
cpe:/o:debian:debian_linux:3.0::ia-64
cpe:/o:redhat:enterprise_linux_desktop:3.0Red Hat Desktop 3.0
cpe:/a:ethereal_group:ethereal:0.9.1
cpe:/o:debian:debian_linux:3.0::sparc
cpe:/a:ethereal_group:ethereal:0.9.6

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:11278Ethereal 0.9.0 through 0.10.7 allows remote attackers to cause a denial of service (CPU consumption) via a certain malformed SMB packet.
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1142
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1142
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-063
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18488
(VENDOR_ADVISORY)  XF  ethereal-smb-dos(18488)
http://www.securityfocus.com/bid/11943
(VENDOR_ADVISORY)  BID  11943
http://www.redhat.com/support/errata/RHSA-2005-037.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:037
http://www.gentoo.org/security/en/glsa/glsa-200412-15.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200412-15
http://www.ethereal.com/appnotes/enpa-sa-00016.html
(VENDOR_ADVISORY)  CONFIRM  http://www.ethereal.com/appnotes/enpa-sa-00016.html
http://www.debian.org/security/2004/dsa-613
(VENDOR_ADVISORY)  DEBIAN  DSA-613
http://www.ciac.org/ciac/bulletins/p-061.shtml
(VENDOR_ADVISORY)  CIAC  P-061
http://secunia.com/advisories/13468/
(VENDOR_ADVISORY)  SECUNIA  13468
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000916
(VENDOR_ADVISORY)  CONECTIVA  CLA-2005:916
http://www.redhat.com/archives/fedora-legacy-announce/2006-January/msg00003.html
(UNKNOWN)  FEDORA  FLSA-2006:152922
http://www.mandriva.com/security/advisories?name=MDKSA-2004:152
(UNKNOWN)  MANDRAKE  MDKSA-2004:152

- 漏洞信息

Ethereal多个未明的服务拒绝和潜在的代码执行漏洞
中危 其他
2004-12-15 00:00:00 2005-10-20 00:00:00
远程  
        Ethereal 0.9.0至0.10.7版本存在漏洞。远程攻击者借助某些畸形SMB包导致服务拒绝(CPU的消耗)。
        

- 公告与补丁

        Please see the reference section for more information.
        Ethereal Group Ethereal 0.10
        
        Ethereal Group Ethereal 0.10.1
        
        Ethereal Group Ethereal 0.10.2
        
        Ethereal Group Ethereal 0.10.3
        
        Ethereal Group Ethereal 0.10.4
        
        Ethereal Group Ethereal 0.10.5
        
        Ethereal Group Ethereal 0.10.6
        
        Ethereal Group Ethereal 0.10.7
        
        Ethereal Group Ethereal 0.9
        
    <

- 漏洞信息 (F35461)

Ethereal Security Advisory 16 (PacketStormID:F35461)
2004-12-31 00:00:00
Ethereal  ethereal.com
advisory,denial of service,vulnerability
CVE-2004-1139,CVE-2004-1140,CVE-2004-1141,CVE-2004-1142
[点击下载]

Ethereal Security Advisory Enpa-sa-00016 - Multiple vulnerabilities in Ethereal versions 0.9.0 to 0.10.7 have been discovered that all result in denial of service outcomes.

*Name:* Multiple problems in Ethereal versions 0.9.0 to 0.10.7

*Docid:* enpa-sa-00016

*Date:* December 15, 2004

*Versions affected:* 0.9.0 up to and including 0.10.7

*Severity:* *High*


    Details

*Description:*

Issues have been discovered in the following protocol dissectors:

    * Matthew Bing discovered a bug in DICOM dissection that could make
      Ethereal crash.
      Versions affected: 0.10.4 - 0.10.7
      CVE: CAN-2004-1139
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1139>

    * An invalid RTP timestamp could make Ethereal hang and create a
      large temporary file, possibly filling available disk space.
      Versions affected: 0.9.16 - 0.10.7
      CVE: CAN-2004-1140
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1140>

    * The HTTP dissector could access previously-freed memory, causing a
      crash.
      Versions affected: 0.10.1 - 0.10.7
      CVE: CAN-2004-1141
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1141>

    * Brian Caswell discovered that an improperly formatted SMB packet
      could make Ethereal hang, maximizing CPU utilization.
      Versions affected: 0.9.0 - 0.10.7
      CVE: CAN-2004-1142
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1142>

*Impact:*

It may be possible to make Ethereal crash or run arbitrary code by
injecting a purposefully malformed packet onto the wire or by convincing
someone to read a malformed packet trace file.

*Resolution:*

Upgrade to 0.10.8.

If you are running a version prior to 0.10.8 and you cannot upgrade, you
can disable the HTTP, DICOM, and SMB protocol dissectors by selecting
/Analyze->Enabled Protocols.../ and deselecting them from the list.
However, it is strongly recommended that you upgrade to 0.10.8.

Please send support questions about Ethereal to the
ethereal-users[AT]ethereal.com <mailto:ethereal-users[AT]ethereal.com>
mailing list.
For corrections/additions/suggestions for this web page (and *not*
Ethereal support questions), please send email to
ethereal-web[AT]ethereal.com <mailto:ethereal-web[AT]ethereal.com> .
Last modified: Wed, December 15 2004.
    

- 漏洞信息

12383
Ethereal Malformed SMB Packet DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

Ethereal contains a flaw that may allow a remote denial of service. The issue is triggered when Ethereal receives a malformed SMB packet that can maximize the CPU utilization and result in loss of availability for the service.

- 时间线

2004-12-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.10.8 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Disable the SMB protocol dissectors by selecting Analyze->Enabled Protocols... and deselecting SMB protocol from the list.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站