CVE-2004-1106
CVSS6.8
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-05 16:40:24
NMCOPS    

[原文]Cross-site scripting (XSS) vulnerability in Gallery 1.4.4-pl3 and earlier allows remote attackers to execute arbitrary web script or HTML via "specially formed URLs," possibly via the include parameter in index.php.


[CNNVD]Gallery index.php 跨站脚本攻击漏洞(CNNVD-200501-196)

        Gallery是一款基于Web的图片相册管理系统。
        Gallery 1.4.4-pl3及之前版本中存在跨站点脚本攻击漏洞。
        远程攻击者可利用index.php中的include参数,注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linuxGentoo Linux
cpe:/a:gallery_project:gallery:1.4_pl2
cpe:/a:gallery_project:gallery:1.4.2
cpe:/a:gallery_project:gallery:1.4.3_pl2
cpe:/a:gallery_project:gallery:1.4_pl1
cpe:/a:gallery_project:gallery:1.4.1
cpe:/a:gallery_project:gallery:1.4.3_pl1
cpe:/a:gallery_project:gallery:1.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1106
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1106
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-196
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17948
(PATCH)  XF  gallery-script-xss(17948)
http://www.securityfocus.com/bid/11602
(VENDOR_ADVISORY)  BID  11602
http://www.gentoo.org/security/en/glsa/glsa-200411-10.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200411-10
http://www.debian.org/security/2005/dsa-642
(PATCH)  DEBIAN  DSA-642
http://gallery.menalto.com/modules.php?op=modload&name=News&file=article&sid=142&mode=thread&order=0&thold=0
(UNKNOWN)  CONFIRM  http://gallery.menalto.com/modules.php?op=modload&name=News&file=article&sid=142&mode=thread&order=0&thold=0
http://g3cko.info/gallery2-4.patch
(UNKNOWN)  MISC  http://g3cko.info/gallery2-4.patch

- 漏洞信息

Gallery index.php 跨站脚本攻击漏洞
中危 跨站脚本
2005-01-10 00:00:00 2006-12-27 00:00:00
远程  
        Gallery是一款基于Web的图片相册管理系统。
        Gallery 1.4.4-pl3及之前版本中存在跨站点脚本攻击漏洞。
        远程攻击者可利用index.php中的include参数,注入任意web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://codex.gallery2.org/Downloads

- 漏洞信息 (F35788)

dsa-642.txt (PacketStormID:F35788)
2005-01-18 00:00:00
 
advisory,web,vulnerability
linux,debian
CVE-2004-1106
[点击下载]

Debian Security Advisory 642-1 - Several vulnerabilities have been discovered in gallery, a web-based photo album written in PHP4.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 642-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 17th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : gallery
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-1106
BugTraq ID     : 11602

Several vulnerabilities have been discovered in gallery, a web-based
photo album written in PHP4.  The Common Vulnerabilities and Exposures
project identifies the following vulnerabilities:

CAN-2004-1106

    Jim Paris discovered a cross site scripting vulnerability which
    allows code to be inserted by using specially formed URLs.

CVE-NOMATCH

    The upstream developers of gallery have fixed several cases of
    possible variable injection that could trick gallery to unintended
    actions, e.g. leaking database passwords.

For the stable distribution (woody) these problems have been fixed in
version 1.2.5-8woody3.

For the unstable distribution (sid) these problems have been fixed in
version 1.4.4-pl4-1.

We recommend that you upgrade your gallery package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3.dsc
      Size/MD5 checksum:      573 f789c8198ba2b859cfb5cca31aaf6dcd
    http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3.diff.gz
      Size/MD5 checksum:     7908 6acd9ee257ddad8c2ffa568b5540e9fe
    http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
      Size/MD5 checksum:   132099 1a32e57b36ca06d22475938e1e1b19f9

  Architecture independent components:

    http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3_all.deb
      Size/MD5 checksum:   133126 3527d050800873dc990c1d002478aa7e


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFB69gDW5ql+IAeqTIRAqipAJ4kVB7T6gwzriUDEb3qA2EnRETlUACeOHkX
/DKy8tkBgh/oV4V4kynNjEk=
=LtRv
-----END PGP SIGNATURE-----

    

- 漏洞信息

11340
Gallery Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Gallery contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables upon submission. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-11-02 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4.4-pl3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Gallery Unspecified Remote HTML Injection Vulnerability
Input Validation Error 11602
Yes No
2004-11-03 12:00:00 2009-07-12 08:06:00
The individual responsible for the discovery of this issue is currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

Gentoo Linux
Gallery Gallery 1.4.4 -pl2
Gallery Gallery 1.4.3 -pl2
Gallery Gallery 1.4.3 -pl1
Gallery Gallery 1.4.2
Gallery Gallery 1.4.1
Gallery Gallery 1.4 -pl2
Gallery Gallery 1.4 -pl1
Gallery Gallery 1.4
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Gallery Gallery 1.4.4 -pl2

- 不受影响的程序版本

Gallery Gallery 1.4.4 -pl2

- 漏洞讨论

An unspecified HTML injection vulnerability reportedly affects Gallery. This issue is due to a failure of the application to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

Update: It is reported that the fixes released by the vendor to address this issue are ineffective. Gallery 1.4.4-pl2 is still considered vulnerable to cross-site scripting attacks. Gallery 1.4.4-pl2 is being added to affected packages and the fixes are being removed as well.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

The vendor has released an upgrade dealing with this issue.

Debian has released an advisory (DSA 642-1) and fixes that address this and other issues in gallery. Please see the referenced advisory for further information regarding obtaining and applying appropriate updates.

Gentoo Linux has released advisory GLSA 200411-10:01 to address this issue in Gallery. Users of the affected package are urged to execute the following commands with superuser privileges to install the updates:

emerge --sync
emerge --ask --oneshot --verbose ">=www-apps/gallery-1.4.4_p4"

It is reported that the fixes released by the vendor to address this issue are ineffective. Gallery 1.4.4-pl2 is still considered vulnerable to cross-site scripting attacks. The fixes are being removed.


Gallery Gallery 1.4 -pl2

Gallery Gallery 1.4 -pl1

Gallery Gallery 1.4

Gallery Gallery 1.4.1

Gallery Gallery 1.4.2

Gallery Gallery 1.4.3 -pl2

Gallery Gallery 1.4.3 -pl1

Debian Linux 3.0 s/390

Debian Linux 3.0 arm

Debian Linux 3.0 alpha

Debian Linux 3.0 mips

Debian Linux 3.0 mipsel

Debian Linux 3.0 m68k

Debian Linux 3.0 sparc

Debian Linux 3.0 ia-64

Debian Linux 3.0 hppa

Debian Linux 3.0 ppc

Debian Linux 3.0 ia-32

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站