CVE-2004-1061
CVSS4.3
发布时间 :2005-01-04 00:00:00
修订时间 :2008-09-05 16:40:13
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in Bugzilla before 2.18, including 2.16.x before 2.16.11, allows remote attackers to inject arbitrary HTML and web script via forced error messages, as demonstrated using the action parameter.


[CNNVD]Bugzilla ErrorMessage 跨站脚本攻击漏洞(CNNVD-200501-007)

        Bugzilla是一套Web界面的Bug管理系统。
        Bugzilla 2.18之前的版本,包括低于2.16.11的2.16.x版本,存在多个跨站点脚本攻击漏洞。
        远程攻击者可以借助强制产生出错信息(比如使用action参数),注入任意的 HTML和web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:bugzilla:2.16.1Mozilla Bugzilla 2.16.1
cpe:/a:mozilla:bugzilla:2.17.3Mozilla Bugzilla 2.17.3
cpe:/a:mozilla:bugzilla:2.16.10Mozilla Bugzilla 2.16.10
cpe:/a:mozilla:bugzilla:2.16.8Mozilla Bugzilla 2.16.8
cpe:/a:mozilla:bugzilla:2.16.11Mozilla Bugzilla 2.16.11
cpe:/a:mozilla:bugzilla:2.16.2Mozilla Bugzilla 2.16.2
cpe:/a:mozilla:bugzilla:2.17.4Mozilla Bugzilla 2.17.4
cpe:/a:mozilla:bugzilla:2.16.9Mozilla Bugzilla 2.16.9
cpe:/a:mozilla:bugzilla:2.17.7Mozilla Bugzilla 2.17.7
cpe:/a:mozilla:bugzilla:2.16.5Mozilla Bugzilla 2.16.5
cpe:/a:mozilla:bugzilla:2.16.3Mozilla Bugzilla 2.16.3
cpe:/a:mozilla:bugzilla:2.17Mozilla Bugzilla 2.17
cpe:/a:mozilla:bugzilla:2.16.6Mozilla Bugzilla 2.16.6
cpe:/a:mozilla:bugzilla:2.17.6Mozilla Bugzilla 2.17.6
cpe:/a:mozilla:bugzilla:2.17.1Mozilla Bugzilla 2.17.1
cpe:/a:mozilla:bugzilla:2.16.7Mozilla Bugzilla 2.16.7
cpe:/a:mozilla:bugzilla:2.16.4Mozilla Bugzilla 2.16.4
cpe:/a:mozilla:bugzilla:2.17.5Mozilla Bugzilla 2.17.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1061
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1061
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-007
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18728
(VENDOR_ADVISORY)  XF  bugzilla-xss(18728)
https://bugzilla.mozilla.org/show_bug.cgi?id=272620
(UNKNOWN)  CONFIRM  https://bugzilla.mozilla.org/show_bug.cgi?id=272620
http://www.securityfocus.com/bid/12154
(UNKNOWN)  BID  12154
http://www.mikx.de/index.php?p=6
(VENDOR_ADVISORY)  MISC  http://www.mikx.de/index.php?p=6
http://lists.grok.org.uk/pipermail/full-disclosure/2004-December/030222.html
(VENDOR_ADVISORY)  FULLDISC  20041223 Cross-Site Scripting - an industry-wide problem
http://distro.conectiva.com.br/atualizacoes/index.php?id=a&anuncio=001040
(UNKNOWN)  CONECTIVA  CLSA-2005:1040

- 漏洞信息

Bugzilla ErrorMessage 跨站脚本攻击漏洞
中危 跨站脚本
2005-01-04 00:00:00 2006-06-15 00:00:00
远程  
        Bugzilla是一套Web界面的Bug管理系统。
        Bugzilla 2.18之前的版本,包括低于2.16.11的2.16.x版本,存在多个跨站点脚本攻击漏洞。
        远程攻击者可以借助强制产生出错信息(比如使用action参数),注入任意的 HTML和web脚本。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.bugzilla.org/download/

- 漏洞信息

12699
Bugzilla Internal Error Response XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-01 Unknow
2004-12-01 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Bugzilla Internal Error Cross-Site Scripting Vulnerability
Input Validation Error 12154
Yes No
2005-01-04 12:00:00 2009-07-12 09:26:00
Discovery is credited to Michael Krax.

- 受影响的程序版本

Mozilla Bugzilla 2.18 rc3
Mozilla Bugzilla 2.18 rc2
Mozilla Bugzilla 2.18 rc1
Mozilla Bugzilla 2.17.7
Mozilla Bugzilla 2.17.6
Mozilla Bugzilla 2.17.5
Mozilla Bugzilla 2.17.4
Mozilla Bugzilla 2.17.3
Mozilla Bugzilla 2.17.1
Mozilla Bugzilla 2.17
Mozilla Bugzilla 2.16.7
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Conectiva Linux 9.0
+ Conectiva Linux 9.0
+ Conectiva Linux 9.0
Mozilla Bugzilla 2.16.6
Mozilla Bugzilla 2.16.5
Mozilla Bugzilla 2.16.4
Mozilla Bugzilla 2.16.3
Mozilla Bugzilla 2.16.2
+ Conectiva Linux 9.0
+ Conectiva Linux 9.0
Mozilla Bugzilla 2.16.1
Mozilla Bugzilla 2.16
- Mandriva Linux Mandrake 9.0
- Mandriva Linux Mandrake 9.0
Mozilla Bugzilla 2.14.5
Mozilla Bugzilla 2.14.4
Mozilla Bugzilla 2.14.3
Mozilla Bugzilla 2.14.2
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Debian Linux 3.0
+ Debian Linux 3.0
+ Debian Linux 3.0
+ Debian Linux 3.0
Mozilla Bugzilla 2.14.1
Mozilla Bugzilla 2.14
- RedHat Linux 7.1
- RedHat Linux 7.1
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
Mozilla Bugzilla 2.12
Mozilla Bugzilla 2.10
Mozilla Bugzilla 2.8
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows NT 3.5.1
- Microsoft Windows NT 3.5.1
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Mozilla Bugzilla 2.6
Mozilla Bugzilla 2.4
Conectiva Linux 10.0

- 漏洞讨论

Bugzilla is prone to a cross-site scripting vulnerability. The issue is exposed when the software renders internal errors that include user-supplied input.

An attacker may exploit this issue by enticing a user to follow a link that will cause hostile HTML and script code to be rendered in an internal error page. Exploitation may allow an attacker to steal cookie-based authentication credentials or to mount other attacks.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has addressed this issue in CVS in the 2.18 and 2.16 branches. Additionally a patch is available from the following bug report:
https://bugzilla.mozilla.org/show_bug.cgi?id=272620

Conectiva Linux has released security advisory CLSA-2005:1040 addressing this issue. Users are advised to see the referenced advisory for details on obtaining and applying the appropriate updates.


Conectiva Linux 10.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站