CVE-2004-1020
CVSS5.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:28:38
NMCOS    

[原文]The addslashes function in PHP 4.3.9 does not properly escape a NULL (/0) character, which may allow remote attackers to read arbitrary files in PHP applications that contain a directory traversal vulnerability in require or include statements, but are otherwise protected by the magic_quotes_gpc mechanism. NOTE: this issue was originally REJECTed by its CNA before publication, but that decision is in active dispute. This candidate may change significantly in the future as a result of further discussion.


[CNNVD]PHP addslahes() 信息泄露漏洞(CNNVD-200501-042)

        PHP是应用较广的Web脚本语言。
        PHP 4.3.9中的addslashes函数不能正常转义NULL字符,这使得远程攻击者可能读取任意文件。但另一方面,magic_quotes_gpc又提供了对应的保护机制。该漏洞存在激励讨论,可能会在将来出现重大改动。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:4.3.7PHP PHP 4.3.7
cpe:/a:php:php:5.0.0PHP PHP 5.0.0
cpe:/a:php:php:5.0.1PHP PHP 5.0.1
cpe:/a:php:php:4.3.8PHP PHP 4.3.8
cpe:/a:php:php:5.0:rc1
cpe:/a:php:php:5.0.2PHP PHP 5.0.2
cpe:/a:php:php:4.3.9PHP PHP 4.3.9
cpe:/a:php:php:5.0:rc3
cpe:/a:php:php:4.3.6PHP PHP 4.3.6
cpe:/a:php:php:5.0:rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1020
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1020
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-042
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11981
(PATCH)  BID  11981
http://xforce.iss.net/xforce/xfdb/18516
(UNKNOWN)  XF  php-addslashes-view-files(18516)
http://www.securityfocus.com/archive/1/384663
(VENDOR_ADVISORY)  BUGTRAQ  20041216 PHP Input Validation Vulnerabilities
http://www.securityfocus.com/advisories/9028
(UNKNOWN)  HP  HPSBMA01212
http://www.php.net/release_4_3_10.php
(VENDOR_ADVISORY)  CONFIRM  http://www.php.net/release_4_3_10.php
http://www.gentoo.org/security/en/glsa/glsa-200412-14.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200412-14
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000915
(UNKNOWN)  CONECTIVA  CLA-2005:915
http://www.mandriva.com/security/advisories?name=MDKSA-2004:151
(UNKNOWN)  MANDRAKE  MDKSA-2004:151

- 漏洞信息

PHP addslahes() 信息泄露漏洞
中危 路径遍历
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        PHP是应用较广的Web脚本语言。
        PHP 4.3.9中的addslashes函数不能正常转义NULL字符,这使得远程攻击者可能读取任意文件。但另一方面,magic_quotes_gpc又提供了对应的保护机制。该漏洞存在激励讨论,可能会在将来出现重大改动。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.php.net/downloads.php

- 漏洞信息

12600
PHP addslashes() NULL Byte Bypass
Vendor Verified

- 漏洞描述

PHP contains a flaw that may allow remote attackers to gain access to privileged files. The issue is due to the addslashes function not properly escaping NULL characters. By supplying crafted input, an attacker can use require or include statements to traverse the filesystem and access arbitrary files.

- 时间线

2004-12-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.3.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP Multiple Remote Vulnerabilities
Input Validation Error 11981
Yes No
2004-12-16 12:00:00 2009-07-12 09:26:00
Discovery is credited to Daniel Fabian <research@sec-consult.com>.

- 受影响的程序版本

PHP PHP 5.0.2
PHP PHP 5.0.1
PHP PHP 5.0 candidate 3
PHP PHP 5.0 candidate 2
PHP PHP 5.0 candidate 1
PHP PHP 5.0 .0
PHP PHP 4.3.9
PHP PHP 4.3.8
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ S.u.S.E. Linux Personal 9.2
+ Turbolinux Turbolinux Server 10.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
PHP PHP 4.3.7
PHP PHP 4.3.6
HP System Management Homepage 2.0.2
HP System Management Homepage 2.0.1
HP System Management Homepage 2.0
Conectiva Linux 10.0
Conectiva Linux 9.0
PHP PHP 5.0.3
+ Trustix Secure Linux 2.2
PHP PHP 4.3.10
+ Gentoo Linux
+ Red Hat Fedora Core3
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
+ Trustix Secure Linux 1.5
HP System Management Homepage 2.1

- 不受影响的程序版本

PHP PHP 5.0.3
+ Trustix Secure Linux 2.2
PHP PHP 4.3.10
+ Gentoo Linux
+ Red Hat Fedora Core3
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
+ Trustix Secure Linux 1.5
HP System Management Homepage 2.1

- 漏洞讨论

PHP4 and PHP5 are reported prone to multiple remotely exploitable vulnerabilities. These issue result from insufficient sanitization of user-supplied data. A remote attacker may carry out directory traversal attacks to disclose arbitrary files and upload files to arbitrary locations.

It is reported that these vulnerabilities may only be exploited on Windows.

- 漏洞利用

An exploit is not required.

The following proof of concept examples are available:
http://www.example.com/phpscript.php?whatever=../../../../boot.ini%00
http://www.example.com/phpscript.php?whatever=..\'file.ext

- 解决方案

Conectiva has released advisory CLA-2005:915 along with fixes dealing with these and other issues. Please see the referenced advisory for more information.

Mandrake has released advisory MDKSA-2004:151 to address this issue. Please see the attached advisory for details on obtaining and applying fixes.

HP has released advisory HPSBMA01212 to address various issue affecting System Management Homepage. Please see the referenced advisory for more information.

HP has released revision 1 of advisory HPSBMA01212 to address various issue affecting System Management Homepage. Please see the referenced advisory for more information.

Revised HP advisory HPSBMA01212 (SSRT5998 Rev.2 HP System Management Homepage(v2.0.x) Denial of Service (DoS) and XSS) including updated resolutions is available. Please see the referenced advisory for more information.

The vendor has released updated packages to address these issues:


PHP PHP 4.3.6

PHP PHP 4.3.7

PHP PHP 4.3.8

PHP PHP 4.3.9

PHP PHP 5.0 .0

PHP PHP 5.0 candidate 2

PHP PHP 5.0 candidate 3

PHP PHP 5.0 candidate 1

PHP PHP 5.0.1

PHP PHP 5.0.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站