CVE-2004-1015
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:28:37
NMCOS    

[原文]Buffer overflow in proxyd for Cyrus IMAP Server 2.2.9 and earlier, with the imapmagicplus option enabled, may allow remote attackers to execute arbitrary code, a different vulnerability than CVE-2004-1011.


[CNNVD] CyrusIMAPServer imapmagicplus 缓冲区溢出漏洞(CNNVD-200501-200)

        Cyrus IMAPD是一款开源的IMAP协议实现软件。
        Cyrus IMAP Server 2.2.9及之前版本中存在缓冲区溢出漏洞。
        当启用imapmagicplus选项时,远程攻击者可利用此漏洞执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.0.16
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.1.16
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.3
cpe:/a:carnegie_mellon_university:cyrus_imap_server:1.5.19
cpe:/o:redhat:fedora_core:core_3.0
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.7
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.1.10
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.9
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.2_beta
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.1.7
cpe:/a:carnegie_mellon_university:cyrus_imap_server:1.4
cpe:/o:redhat:fedora_core:core_2.0
cpe:/o:ubuntu:ubuntu_linux:4.1::ia64
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.0.12
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.1.9
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.1_beta
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.6
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.5
cpe:/o:ubuntu:ubuntu_linux:4.1::ppc
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.8
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.4
cpe:/a:carnegie_mellon_university:cyrus_imap_server:2.2.0_alpha

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1015
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1015
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-200
(官方数据源) CNNVD

- 其它链接及资源

http://security.gentoo.org/glsa/glsa-200411-34.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200411-34
http://xforce.iss.net/xforce/xfdb/18274
(VENDOR_ADVISORY)  XF  cyrus-magic-plus-bo(18274)
http://asg.web.cmu.edu/cyrus/download/imapd/changes.html
(UNKNOWN)  CONFIRM  http://asg.web.cmu.edu/cyrus/download/imapd/changes.html
http://www.mandriva.com/security/advisories?name=MDKSA-2004:139
(UNKNOWN)  MANDRAKE  MDKSA-2004:139
http://asg.web.cmu.edu/archive/message.php?mailbox=archive.cyrus-announce&msg=145
(UNKNOWN)  MLIST  [cyrus-announce] 20041123 Cyrus IMAPd 2.2.10 Released

- 漏洞信息

CyrusIMAPServer imapmagicplus 缓冲区溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-28 00:00:00
远程  
        Cyrus IMAPD是一款开源的IMAP协议实现软件。
        Cyrus IMAP Server 2.2.9及之前版本中存在缓冲区溢出漏洞。
        当启用imapmagicplus选项时,远程攻击者可利用此漏洞执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://cyrusimap.web.cmu.edu/downloads.html

- 漏洞信息

12290
Cyrus IMAP Server imapmagicplus proxyd Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2004-11-25 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Cyrus IMAPD Multiple Remote Unspecified Vulnerabilities
Boundary Condition Error 11738
Yes No
2004-11-24 12:00:00 2009-07-12 08:06:00
Sebastian Krahmer is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
Red Hat Fedora Core3
Red Hat Fedora Core2
Carnegie Mellon University Cyrus IMAP Server 2.2.9
Carnegie Mellon University Cyrus IMAP Server 2.2.8
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
Carnegie Mellon University Cyrus IMAP Server 2.2.7
Carnegie Mellon University Cyrus IMAP Server 2.2.6
Carnegie Mellon University Cyrus IMAP Server 2.2.5
Carnegie Mellon University Cyrus IMAP Server 2.2.4
Carnegie Mellon University Cyrus IMAP Server 2.2.3
Carnegie Mellon University Cyrus IMAP Server 2.2.2 BETA
Carnegie Mellon University Cyrus IMAP Server 2.2.1 BETA
Carnegie Mellon University Cyrus IMAP Server 2.2 .0 ALPHA
Carnegie Mellon University Cyrus IMAP Server 2.1.16
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
Carnegie Mellon University Cyrus IMAP Server 2.1.10
Carnegie Mellon University Cyrus IMAP Server 2.1.9
+ S.u.S.E. Linux 8.1
Carnegie Mellon University Cyrus IMAP Server 2.1.7
Carnegie Mellon University Cyrus IMAP Server 2.0.16
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3 i386
Carnegie Mellon University Cyrus IMAP Server 2.0.12
+ S.u.S.E. Linux 7.1 x86
+ S.u.S.E. Linux 7.1 ppc
+ S.u.S.E. Linux 7.1 alpha
Carnegie Mellon University Cyrus IMAP Server 1.5.19
+ Debian Linux 3.0
+ Debian Linux 2.2
Carnegie Mellon University Cyrus IMAP Server 1.4
Apple Mac OS X Server 10.3.8
Apple Mac OS X Server 10.3.7
Apple Mac OS X Server 10.3.6
Apple Mac OS X Server 10.3.5
Apple Mac OS X Server 10.3.4
Apple Mac OS X Server 10.3.3
Apple Mac OS X Server 10.3.2
Apple Mac OS X Server 10.3.1
Apple Mac OS X Server 10.3
Apple Mac OS X Server 10.2.8
Apple Mac OS X Server 10.2.7
Apple Mac OS X Server 10.2.6
Apple Mac OS X Server 10.2.5
Apple Mac OS X Server 10.2.4
Apple Mac OS X Server 10.2.3
Apple Mac OS X Server 10.2.2
Apple Mac OS X Server 10.2.1
Apple Mac OS X Server 10.2
Apple Mac OS X Server 10.1.5
Apple Mac OS X Server 10.1.4
Apple Mac OS X Server 10.1.3
Apple Mac OS X Server 10.1.2
Apple Mac OS X Server 10.1.1
Apple Mac OS X Server 10.1
Apple Mac OS X Server 10.0
Carnegie Mellon University Cyrus IMAP Server 2.2.10
+ Conectiva Linux 10.0
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
Carnegie Mellon University Cyrus IMAP Server 2.1.17
+ Conectiva Linux 9.0
Carnegie Mellon University Cyrus IMAP Server 2.1.7

- 不受影响的程序版本

Carnegie Mellon University Cyrus IMAP Server 2.2.10
+ Conectiva Linux 10.0
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
Carnegie Mellon University Cyrus IMAP Server 2.1.17
+ Conectiva Linux 9.0
Carnegie Mellon University Cyrus IMAP Server 2.1.7

- 漏洞讨论

Cyrus IMAPD is reported prone to multiple remote unspecified buffer overflow vulnerabilities. The following issues are reported:

It is reported that the first issue exists in the 'IMAPMAGICPLUS' functionality provided by Cyrus IMAPD. This vulnerability exists prior to authentication, and is therefore reportedly exploitable by anonymous remote attackers.

Additionally a buffer overflow vulnerability is reported to exist in the 'mysasl_canon_user' Cyrus IMAPD function.

These vulnerabilities reportedly may allow remote, attacker-supplied machine code to be executed in the context of the affected server process.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Ubuntu Linux has released advisory (USN-37-1) to address one of the vulnerabilities that is described in this BID. Please see the referenced advisory for further information.

Gentoo has released advisory GLSA 200411-34 to address these issues. Gentoo updates may be applied by running the following commands as the superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=net-mail/cyrus-imapd-2.2.10"

Mandrake has released advisory MDKSA-2004:139 to address these issues. Please see the attached advisory for details on obtaining and applying fixes.

The vendor has released version 2.2.10 and 2.1.17 of the affected package to resolve these issues:

RedHat Fedora Linux has released advisory FEDORA-2004-487 for their Core 2 product and advisory FEDORA-2004-489 for their Core 3 product. Please see the referenced advisories for more information.

Apple has released advisory (Security Update 2005-003) to address various issues. Please see the referenced advisory for more information. An update for Mac OS X Server v10.3.8 is available.


Apple Mac OS X Server 10.3.8

Carnegie Mellon University Cyrus IMAP Server 2.1.10

Carnegie Mellon University Cyrus IMAP Server 2.1.16

Carnegie Mellon University Cyrus IMAP Server 2.1.7

Carnegie Mellon University Cyrus IMAP Server 2.1.9

Carnegie Mellon University Cyrus IMAP Server 2.2 .0 ALPHA

Carnegie Mellon University Cyrus IMAP Server 2.2.1 BETA

Carnegie Mellon University Cyrus IMAP Server 2.2.2 BETA

Carnegie Mellon University Cyrus IMAP Server 2.2.3

Carnegie Mellon University Cyrus IMAP Server 2.2.4

Carnegie Mellon University Cyrus IMAP Server 2.2.5

Carnegie Mellon University Cyrus IMAP Server 2.2.6

Carnegie Mellon University Cyrus IMAP Server 2.2.7

Carnegie Mellon University Cyrus IMAP Server 2.2.8

Carnegie Mellon University Cyrus IMAP Server 2.2.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站