CVE-2004-1014
CVSS5.0
发布时间 :2005-01-10 00:00:00
修订时间 :2017-07-10 21:30:39
NMCOS    

[原文]statd in nfs-utils 1.257 and earlier does not ignore the SIGPIPE signal, which allows remote attackers to cause a denial of service (server process crash) via a TCP connection that is prematurely terminated.


[CNNVD]nfs-untils statd 拒绝服务漏洞(CNNVD-200501-073)

        statd是一种用于监视并控制NFS的RPC守护进程,广泛运行于种Unix/Linux类操作系统上。
        Nfs-utils 1.257及之前版本中statd程序存在拒绝服务漏洞。
        由于statd没有忽略SIGPIPE信号,远程攻击者可通过一个非正常的TCP连接中断触发SIGPIPE,导致服务程序崩溃,引发拒绝服务。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/o:redhat:enterprise_linux:3.0::workstation_server
cpe:/o:debian:debian_linux:3.0::s-390
cpe:/o:debian:debian_linux:3.0::sparc
cpe:/o:debian:debian_linux:3.0::mipsel
cpe:/a:nfs:nfs-utils:1.0.6
cpe:/o:debian:debian_linux:3.0::mips
cpe:/o:debian:debian_linux:3.0::m68k
cpe:/o:mandrakesoft:mandrake_linux:10.0MandrakeSoft Mandrake Linux 10.0
cpe:/o:mandrakesoft:mandrake_linux:10.1MandrakeSoft Mandrake Linux 10.1
cpe:/o:debian:debian_linux:3.0::ia-64
cpe:/o:debian:debian_linux:3.0::alpha
cpe:/o:mandrakesoft:mandrake_linux:9.2MandrakeSoft Mandrake Linux 9.2
cpe:/o:mandrakesoft:mandrake_linux_corporate_server:2.1MandrakeSoft Mandrake Linux Corporate Server 2.1
cpe:/o:redhat:enterprise_linux:3.0::advanced_server
cpe:/o:debian:debian_linux:3.0::arm
cpe:/o:mandrakesoft:mandrake_linux:9.2::amd64
cpe:/o:mandrakesoft:mandrake_linux:10.1::x86_64
cpe:/o:redhat:enterprise_linux:3.0::enterprise_server
cpe:/o:mandrakesoft:mandrake_linux:10.0::amd64
cpe:/o:debian:debian_linux:3.0Debian Debian Linux 3.0
cpe:/o:debian:debian_linux:3.0::ppc
cpe:/o:debian:debian_linux:3.0::hppa
cpe:/o:debian:debian_linux:3.0::ia-32
cpe:/o:redhat:enterprise_linux_desktop:3.0Red Hat Desktop 3.0
cpe:/o:mandrakesoft:mandrake_linux_corporate_server:2.1::x86_64

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10899statd in nfs-utils 1.257 and earlier does not ignore the SIGPIPE signal, which allows remote attackers to cause a denial of service (server ...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1014
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1014
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-073
(官方数据源) CNNVD

- 其它链接及资源

http://cvs.sourceforge.net/viewcvs.py/nfs/nfs-utils/ChangeLog?rev=1.258&view=markup
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/nfs/nfs-utils/ChangeLog?rev=1.258&view=markup
http://www.debian.org/security/2004/dsa-606
(UNKNOWN)  DEBIAN  DSA-606
http://www.redhat.com/support/errata/RHSA-2004-583.html
(UNKNOWN)  REDHAT  RHSA-2004:583
http://www.redhat.com/support/errata/RHSA-2005-014.html
(UNKNOWN)  REDHAT  RHSA-2005:014
http://www.securityfocus.com/archive/1/archive/1/426072/30/6740/threaded
(UNKNOWN)  FEDORA  FLSA-2006:138098
http://www.securityfocus.com/bid/11785
(VENDOR_ADVISORY)  BID  11785
http://www.trustix.org/errata/2004/0065/
(UNKNOWN)  TRUSTIX  2004-0065
https://exchange.xforce.ibmcloud.com/vulnerabilities/18332
(UNKNOWN)  XF  nfs-utils-statd-dos(18332)
https://www.ubuntu.com/usn/usn-36-1/
(UNKNOWN)  UBUNTU  USN-36-1

- 漏洞信息

nfs-untils statd 拒绝服务漏洞
中危 其他
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        statd是一种用于监视并控制NFS的RPC守护进程,广泛运行于种Unix/Linux类操作系统上。
        Nfs-utils 1.257及之前版本中statd程序存在拒绝服务漏洞。
        由于statd没有忽略SIGPIPE信号,远程攻击者可通过一个非正常的TCP连接中断触发SIGPIPE,导致服务程序崩溃,引发拒绝服务。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://sourceforge.net/projects/nfs/files/

- 漏洞信息

12240
nfs-utils rpc.statd SIGPIPE TCP Connection DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

nfs-utils rpc.statd contains a flaw that may allow a remote denial of service. The issue is triggered when a TCP connection is closed early, and will result in a loss of availability.

- 时间线

2004-12-07 Unknow
2004-12-07 Unknow

- 解决方案

Upgrade to version 1.0.6-r6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Linux NFS RPC.STATD Remote Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 11785
Yes No
2004-12-01 12:00:00 2006-12-14 06:44:00
This vulnerability was disclosed by SGI.

- 受影响的程序版本

Turbolinux Turbolinux Workstation 8.0
Turbolinux Turbolinux Workstation 7.0
Turbolinux Turbolinux Server 10.0
Turbolinux Turbolinux Server 8.0
Turbolinux Turbolinux Server 7.0
Turbolinux Turbolinux Desktop 10.0
Turbolinux Home
Turbolinux Appliance Server 1.0 Workgroup Edition
Turbolinux Appliance Server 1.0 Hosting Edition
RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 3
RedHat Desktop 3.0
Red Hat Fedora Core2
Red Hat Fedora Core1
Red Hat Enterprise Linux AS 3
nfs nfs-utils 1.0.6
+ Gentoo Linux
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.2
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
Mandriva Linux Mandrake 9.2 amd64
Mandriva Linux Mandrake 9.2
MandrakeSoft Corporate Server 2.1 x86_64
MandrakeSoft Corporate Server 2.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0

- 漏洞讨论

It is reported that 'rpc.statd' is vulnerable to a remote denial-of-service vulnerability.

This vulnerability allows remote attackers to crash the affected application. This may result in the failure to clean up NFS network locks, possibly resulting in denied access to files, because they may be considered permanently locked.

Version 1.0.6 of nfs-utils is reported vulnerable to this issue. Other versions may also be affected.

- 漏洞利用

An exploit is not required.

- 解决方案

Please see the referenced vendor advisories for further information.


nfs nfs-utils 1.0.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站