CVE-2004-1008
CVSS10.0
发布时间 :2005-01-10 00:00:00
修订时间 :2016-10-17 22:50:36
NMCO    

[原文]Integer signedness error in the ssh2_rdpkt function in PuTTY before 0.56 allows remote attackers to execute arbitrary code via a SSH2_MSG_DEBUG packet with a modified stringlen parameter, which leads to a buffer overflow.


[CNNVD]PuTTY SSH2_MSG_DEBUG 缓冲区溢出漏洞(CNNVD-200501-033)

        PuTTY是一款免费的Telnet和SSH客户端软件。
        PuTTY 0.56之前的版本中ssh2_rdpkt函数存在无符号整型错误,使得远程攻击者可通过构造特殊的SSH2_MSG_DEBUG包,修改其中的stringlen参数,引起缓冲区溢出,从而执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:putty:putty:0.54
cpe:/a:putty:putty:0.53
cpe:/a:putty:putty:0.55
cpe:/a:putty:putty:0.49
cpe:/a:putty:putty:0.48
cpe:/a:putty:putty:0.53b
cpe:/a:putty:putty:0.50
cpe:/a:tortoisecvs:tortoisecvs:1.8
cpe:/a:putty:putty:0.52
cpe:/a:putty:putty:0.51

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1008
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-1008
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-033
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109889312917613&w=2
(UNKNOWN)  BUGTRAQ  20041027 PuTTY SSH client vulnerability
http://www-1.ibm.com/support/docview.wss?uid=ssg1S1002414
(UNKNOWN)  CONFIRM  http://www-1.ibm.com/support/docview.wss?uid=ssg1S1002414
http://www-1.ibm.com/support/docview.wss?uid=ssg1S1002416
(UNKNOWN)  CONFIRM  http://www-1.ibm.com/support/docview.wss?uid=ssg1S1002416
http://www.chiark.greenend.org.uk/~sgtatham/putty/
(UNKNOWN)  CONFIRM  http://www.chiark.greenend.org.uk/~sgtatham/putty/
http://www.gentoo.org/security/en/glsa/glsa-200410-29.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200410-29
http://www.idefense.com/application/poi/display?id=155&type=vulnerabilities&flashstatus=true
(UNKNOWN)  IDEFENSE  20041027 PuTTY SSH2_MSG_DEBUG Buffer Overflow Vulnerability
http://www.securityfocus.com/bid/11549
(VENDOR_ADVISORY)  BID  11549
http://xforce.iss.net/xforce/xfdb/17886
(VENDOR_ADVISORY)  XF  putty-ssh2msgdebug-bo(17886)

- 漏洞信息

PuTTY SSH2_MSG_DEBUG 缓冲区溢出漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
远程  
        PuTTY是一款免费的Telnet和SSH客户端软件。
        PuTTY 0.56之前的版本中ssh2_rdpkt函数存在无符号整型错误,使得远程攻击者可通过构造特殊的SSH2_MSG_DEBUG包,修改其中的stringlen参数,引起缓冲区溢出,从而执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

- 漏洞信息

11165
PuTTY SSH2_MSG_DEBUG Packet Handling Overflow
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

A remote overflow exists in PuTTY. PuTTY fails to perform bounds checking on SSH2_MSG_DEBUG packets resulting in a buffer overflow via the 'stringlen' parameter. With the aid of a malicious SSH2 server, an attacker can execute arbitrary code resulting in a loss of confidentiality and integrity.

- 时间线

2004-10-27 Unknow
Unknow 2004-10-26

- 解决方案

Upgrade to version 0.56 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站