发布时间 :2004-12-23 00:00:00
修订时间 :2008-09-05 16:40:02

[原文]Format string vulnerability in telnetd-ssl 0.17 and earlier allows remote attackers to execute arbitrary code.


        telnetd-ssl 0.17及其以前的版本存在格式串漏洞。远程攻击者利用该漏洞执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  netkit-telnetssl-format-string(18654)

- 漏洞信息

高危 格式化字符串
2004-12-23 00:00:00 2006-09-22 00:00:00
        telnetd-ssl 0.17及其以前的版本存在格式串漏洞。远程攻击者利用该漏洞执行任意代码。

- 公告与补丁

        Debian has released an advisory DSA 616-1 to address this issue. Please see the referenced advisory for more information.
        Netkit Linux Netkit 0.17.17

- 漏洞信息

SSLtelnet SSL_accept error Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-12-23 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SSLTelnetd Unspecified Format String Vulnerability
Input Validation Error 12085
Yes No
2004-12-23 12:00:00 2009-07-12 09:26:00
Discovery is credited to Joel Eriksson.

- 受影响的程序版本

Netkit Linux Netkit 0.17.17
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha

- 漏洞讨论

Reportedly SSLTelnetd is affected by an unspecified format string vulnerability. This issue is due to an improper implementation of a formatted string function.

Specific technical details about this issue were not disclosed. It is conjectured that due to the nature of the affected application, this issue is remotely exploitable.

This vulnerability is reported to affect Linux Netkit netkit-telnet-ssl 0.17.17, however, it is likely that other versions are affected as well.

This BID will be updated when more information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

Debian has released an advisory DSA 616-1 to address this issue. Please see the referenced advisory for more information.

Netkit Linux Netkit 0.17.17

- 相关参考