发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-05 16:40:01

[原文]Buffer overflow in hpsockd before 0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code.

[CNNVD]HP hpsockd 拒绝服务漏洞(CNNVD-200501-211)

        Hpsockd 0.6之前版本存在缓冲区溢出漏洞。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:hp:sockd:0.5HP hpsockd 0.5
cpe:/a:hp:sockd:0.4HP hpsockd 0.4

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  hpsockd-bo(18359)

- 漏洞信息

HP hpsockd 拒绝服务漏洞
危急 缓冲区溢出
2005-01-10 00:00:00 2005-10-20 00:00:00
        Hpsockd 0.6之前版本存在缓冲区溢出漏洞。

- 公告与补丁


- 漏洞信息 (F35235)

dsa-604.txt (PacketStormID:F35235)
2004-12-12 00:00:00

Debian Security Advisory 604-1 - infamous41md discovered a buffer overflow condition in hpsockd, the socks server written at Hewlett-Packard. An exploit could cause the program to crash or may have worse effect.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 604-1                                        Martin Schulze
December 3rd, 2004            
- --------------------------------------------------------------------------

Package        : hpsockd
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0993

"infamous41md" discovered a buffer overflow condition in hpsockd, the
socks server written at Hewlett-Packard.  An exploit could cause the
program to crash or may have worse effect.

For the stable distribution (woody) this problem has been fixed in
version 0.6.woody1.

For the unstable distribution (sid) this problem has been fixed in
version 0.14.

We recommend that you upgrade your hpsockd package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:
      Size/MD5 checksum:      526 d5ac263f8a527e97c8d707977351805a
      Size/MD5 checksum:   127019 2de411d806f925658b771ffb1c974c41

  Alpha architecture:
      Size/MD5 checksum:   115444 65338a0efb88db831b690a4c76d70997

  ARM architecture:
      Size/MD5 checksum:   104214 fdd81a813a8023b9585603cf53610616

  Intel IA-32 architecture:
      Size/MD5 checksum:    98588 805aef90031fa41a3cca9fa28b26d508

  Intel IA-64 architecture:
      Size/MD5 checksum:   140132 0f8a29392e10ae44652f76534a420b0a

  HP Precision architecture:
      Size/MD5 checksum:   111672 b643ff9b7e5964592b3c194b8fe7203b

  Motorola 680x0 architecture:
      Size/MD5 checksum:    94430 911addc14236228693687c303788ad3a

  Big endian MIPS architecture:
      Size/MD5 checksum:   110742 63e55da32013613da6e69b7f9a84b97d

  Little endian MIPS architecture:
      Size/MD5 checksum:   111172 7c82b76671b118ca734f48c5e22e3245

  PowerPC architecture:
      Size/MD5 checksum:   101516 7447d074ff41cc3ad6873d2f423cc4fd

  IBM S/390 architecture:
      Size/MD5 checksum:   101594 add45d166bf0c926e143fd70c5a09ab1

  Sun Sparc architecture:
      Size/MD5 checksum:   114216 510aca051ce938553e20af4f53104f46

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.2.5 (GNU/Linux)



- 漏洞信息

hpsockd Unspecified Overflow
Location Unknown Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown

- 漏洞描述

An overflow exists in hpsockd. The issue is caused by an unspecified boundary error. With a specially crafted request, an attacker can cause a Denial of Service resulting in a loss of availability.

- 时间线

2004-12-03 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.woody1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

HP HPSOCKD Unspecified Remote Buffer Overflow Vulnerability
Boundary Condition Error 11800
Yes No
2004-12-03 12:00:00 2009-07-12 08:07:00
Discovery is credited to infamous41md.

- 受影响的程序版本

HP hpsockd 0.5
HP hpsockd 0.4
HP hpsockd 0.6

- 不受影响的程序版本

HP hpsockd 0.6

- 漏洞讨论

hpsockd is reported prone to an unspecified remote buffer overflow vulnerability. This issue exists due to improper boundary checks performed by the application when handling user-supplied data. It is reported that this vulnerability can be exploited to cause a denial of service condition in the application.

It may be possible to leverage this issue to execute arbitrary code on a vulnerable computer, however, this has not been confirmed.

hpsockd versions 0.5 and prior are reported prone to this vulnerability.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

Debian has released an advisory DSA 604-1 to address this issue. Please see the referenced advisory for more information.

- 相关参考