发布时间 :2005-02-09 00:00:00
修订时间 :2008-09-10 15:28:26

[原文]Format string vulnerability in ez-ipupdate.c for ez-ipupdate 3.0.10 through 3.0.11b8, when running in daemon mode with certain service types in use, allows remote servers to execute arbitrary code.


        ez-ipupdate 3.0.10至3.0.11b8的ez-ipupdate.c中的格式化字符串漏洞,在以守护程序模式运行并使用特定的服务类型时,可让远程服务器执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linuxGentoo Linux
cpe:/o:debian:debian_linux:3.0Debian Debian Linux 3.0

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  eziupdate-showmessage-format-string(18032)
(UNKNOWN)  FULLDISC  20041111 ez-ipupdate format string bug

- 漏洞信息

危急 格式化字符串
2005-02-09 00:00:00 2005-10-20 00:00:00
        ez-ipupdate 3.0.10至3.0.11b8的ez-ipupdate.c中的格式化字符串漏洞,在以守护程序模式运行并使用特定的服务类型时,可让远程服务器执行任意代码。

- 公告与补丁

        Angus Mackay ez-ipupdate 3.0.11 b5
        Debian ez-ipupdate_3.0.11b5-1woody2_alpha.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_alpha.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_arm.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_arm.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_hppa.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_hppa.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_i386.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_i386.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_ia64.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_ia64.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_m68k.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_m68k.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_mips.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_mips.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_mipsel.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_mipsel.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_powerpc.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_powerpc.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_s390.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_s390.deb
        Debian ez-ipupdate_3.0.11b5-1woody2_sparc.deb
        Debian GNU/Linux 3.0 (woody) _3.0.11b5-1woody2_sparc.deb
        Angus Mackay ez-ipupdate 3.0.11 b8
        Mandrake ez-ipupdate-3.0.11b8-2.1.100mdk.amd64.rpm
        Mandrake Linux 10.0/AMD64
        Mandrake ez-ipupdate-3.0.11b8-2.1.100mdk.i586.rpm
        Mandrake Linux 10.0
        Mandrake ez-ipupdate-3.0.11b8-2.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        Mandrake ez-ipupdate-3.0.11b8-2.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        Mandrake ez-ipupdate-3.0.11b8-2.1.92mdk.amd64.rpm
        Mandrake Linux 9.2/AMD64
        Mandrake ez-ipupdate-3.0.11b8-2.1.92mdk.i586.rpm
        Mandrake Linux 9.2
        Mandrake ez-ipupdate-3.0.11b8-2.1.C21mdk.i586.rpm
        Mandrake Corporate Server 2.1
        Mandrake ez-ipupdate-3.0.11b8-2.1.C21mdk.x86_64.rpm
        Mandrake Corporate Server 2.1/x86_64
        Mandrake ez-ipupdate-3.0.11b8-2.1.M82mdk.i586.rpm
        Mandrake Multi Network Firewall 8.2

- 漏洞信息

ez-ipupdate show_message() Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public Vendor Verified

- 漏洞描述

ez-ipupdate contains a flaw that may allow a malicious user to execute arbitrary commands on the vulnerable host. The issue is triggered when an attacker sends a request which contains format string characters (i.e. %s, %d). It is possible that the flaw may allow a denial of service or arbitrary code execution, resulting in a loss of availability.

- 时间线

2004-11-11 Unknow
2004-11-11 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Mandrake and SuSE Linux have released a patch to address this vulnerability in the versions of this product which they distribute.

- 相关参考

- 漏洞作者

- 漏洞信息

EZ-IPupdate Remote Format String Vulnerability
Input Validation Error 11657
Yes No
2004-11-11 12:00:00 2009-07-12 08:06:00
Discovery credited to Ulf Harnhammar.

- 受影响的程序版本

Gentoo Linux
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Angus Mackay ez-ipupdate 3.0.11 b8
+ MandrakeSoft Corporate Server 2.1 x86_64
+ MandrakeSoft Corporate Server 2.1
+ MandrakeSoft Multi Network Firewall 2.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
+ Mandriva Linux Mandrake 9.2 amd64
+ Mandriva Linux Mandrake 9.2
+ Mandriva Linux Mandrake 9.1 ppc
+ Mandriva Linux Mandrake 9.1
+ Mandriva Linux Mandrake 9.0
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0
Angus Mackay ez-ipupdate 3.0.11 b5

- 漏洞讨论

EZ-IPupdate is vulnerable to a remotely exploitable format string vulnerability when running in daemon-mode. The vulnerability is present even if "quiet" mode is enabled.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

Mandrake has issued fixes in advisory MDKSA-2004:129. See the reference section for the advisory. SuSE fixes for SuSE Linux 9.2 i386 are available at:

Gentoo Linux has released advisory GLSA 200411-20 to address this issue. Users of affected packages are urged to execute the following with superuser privileges:
emerge --sync
emerge --ask --oneshot --verbose ">=net-dns/ez-ipupdate-3.0.11_beta8-r1"
Please see the referenced advisory for further information.

Debian has released an advisory (DSA 592-1) and fixes for this issue. Please see the referenced advisory for information on obtaining fixes.

Angus Mackay ez-ipupdate 3.0.11 b5

Angus Mackay ez-ipupdate 3.0.11 b8

- 相关参考