发布时间 :2005-02-09 00:00:00
修订时间 :2016-10-17 22:50:20

[原文]Multiple scripts in the perl package in Trustix Secure Linux 1.5 through 2.1 and other operating systems allows local users to overwrite files via a symlink attack on temporary files.



- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9752Multiple scripts in the perl package in Trustix Secure Linux 1.5 through 2.1 and other operating systems allows local users to overwrite fil...

- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  FEDORA  FLSA-2006:152845
(UNKNOWN)  TRUSTIX  2004-0050
(VENDOR_ADVISORY)  XF  script-temporary-file-overwrite(17583)

- 漏洞信息

低危 设计错误
2005-02-09 00:00:00 2005-10-20 00:00:00

- 公告与补丁


- 漏洞信息

Perl on Trustix Secure Linux Multiple Script Insecure Temporary File Creation
Local Access Required Race Condition
Loss of Integrity
Exploit Public

- 漏洞描述

Multiple scripts within Perl contain a flaw that may allow a malicious user to overwrite arbitrary files with the permissions of the user running the script. The is due to the scripts' creation of world-writeable symbolic links, which an attacker can make point to any file in the filesystem. When the script uses the symlink to write data later, the newly specified file is overwritten, causing a loss of integrity.

- 时间线

2004-09-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.8.5 or higher, as it has been reported to fix the majority of these vulnerabilities. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Perl Unspecified Insecure Temporary File Creation Vulnerability
Design Error 11294
No Yes
2004-09-30 12:00:00 2006-08-17 04:15:00
The individual or individuals responsible for the discovery of this issue is currently unknown; Trustix security engineers are credited with these discoveries.

- 受影响的程序版本

RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
Red Hat Fedora Core2
Red Hat Fedora Core1
OpenPKG OpenPKG 2.2
OpenPKG OpenPKG 2.1
OpenPKG OpenPKG Current
Larry Wall Perl 5.8.3
+ Gentoo Linux
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
Larry Wall Perl 5.8.1
Larry Wall Perl 5.8
+ Turbolinux Home
+ Turbolinux Turbolinux Desktop 10.0
Larry Wall Perl 5.6.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Turbolinux Turbolinux Server 8.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
+ Turbolinux Turbolinux Workstation 7.0
Larry Wall Perl 5.6
+ Mandriva Linux Mandrake 7.1

- 漏洞讨论

Perl is affected by an unspecified vulnerability -- it creates temporary files in an insecure manor. This issue is likely due to a design error whereby the application fails to verify the existence of a file before writing to it.

An attacker may leverage this issue to overwrite arbitrary files with the privileges of an unsuspecting user that activates the vulnerable application. Reportedly, this issue is unlikely to facilitate privilege escalation.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Please see the referenced advisories for more information.

Larry Wall Perl 5.6.1

Larry Wall Perl 5.8

Larry Wall Perl 5.8.1

Larry Wall Perl 5.8.3

- 相关参考