CVE-2004-0972
CVSS2.1
发布时间 :2005-02-09 00:00:00
修订时间 :2010-08-21 00:21:34
NMCOS    

[原文]The lvmcreate_initrd script in the lvm package in Trustix Secure Linux 1.5 through 2.1, and possibly other operating systems, allows local users to overwrite files via a symlink attack on temporary files.


[CNNVD]Trustix LVM实用程序未指定的不安全临时文件创建漏洞(CNNVD-200502-030)

        LVM (Logic Volume Management,逻辑卷管理),是传统商业Unix就带有的一项高级磁盘管理工具。
        Trustix Secure Linux 1.5至2.1以及其他可能操作系统中的lvm程序包内的 lvmcreate_initrd脚本,可让本地用户通过象征性的链接攻击临时文件,从而覆盖这些文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linuxGentoo Linux
cpe:/a:lvm:logical_volume_management_utilities:1.0.4
cpe:/a:lvm:logical_volume_management_utilities:1.0.7
cpe:/a:lvm:logical_volume_management_utilities:1.0.8
cpe:/a:lvm:logical_volume_management_utilities:1.0.1

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10632The lvmcreate_initrd script in the lvm package in Trustix Secure Linux 1.5 through 2.1, and possibly other operating systems, allows local u...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0972
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0972
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-030
(官方数据源) CNNVD

- 其它链接及资源

http://www.trustix.org/errata/2004/0050
(VENDOR_ADVISORY)  TRUSTIX  2004-0050
http://www.securityfocus.com/bid/11290
(VENDOR_ADVISORY)  BID  11290
http://xforce.iss.net/xforce/xfdb/17583
(VENDOR_ADVISORY)  XF  script-temporary-file-overwrite(17583)
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136308
(UNKNOWN)  CONFIRM  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136308
http://rhn.redhat.com/errata/RHBA-2004-232.html
(UNKNOWN)  REDHAT  RHBA-2004:232

- 漏洞信息

Trustix LVM实用程序未指定的不安全临时文件创建漏洞
低危 设计错误
2005-02-09 00:00:00 2005-10-20 00:00:00
本地  
        LVM (Logic Volume Management,逻辑卷管理),是传统商业Unix就带有的一项高级磁盘管理工具。
        Trustix Secure Linux 1.5至2.1以及其他可能操作系统中的lvm程序包内的 lvmcreate_initrd脚本,可让本地用户通过象征性的链接攻击临时文件,从而覆盖这些文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        LVM Logical Volume Management Utilities 1.0.1
        Mandrake lvm-1.0.1-2.1.C21mdk.i586.rpm
        Mandrake Corporate Server 2.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lvm-1.0.1-2.1.C21mdk.x86_64.rpm
        Mandrake Corporate Server 2.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        LVM Logical Volume Management Utilities 1.0.4
        Debian lvm10_1.0.4-5woody2_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_alpha.deb
        Debian lvm10_1.0.4-5woody2_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_arm.deb
        Debian lvm10_1.0.4-5woody2_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_hppa.deb
        Debian lvm10_1.0.4-5woody2_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_i386.deb
        Debian lvm10_1.0.4-5woody2_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_ia64.deb
        Debian lvm10_1.0.4-5woody2_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_m68k.deb
        Debian lvm10_1.0.4-5woody2_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_mips.deb
        Debian lvm10_1.0.4-5woody2_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_mipsel.deb
        Debian lvm10_1.0.4-5woody2_powerpc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_powerpc.deb
        Debian lvm10_1.0.4-5woody2_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_s390.deb
        Debian lvm10_1.0.4-5woody2_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lvm10/lvm10_1.0.4-5wood y2_sparc.deb
        LVM Logical Volume Management Utilities 1.0.7
        Mandrake lvm-1.0.7-2.1.92mdk.amd64.rpm
        Mandrake Linux 9.2/AMD64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lvm-1.0.7-2.1.92mdk.i586.rpm
        Mandrake Linux 9.2
        http://www.mandrakesecure.net/en/ftp.php
        Trustix lvm-1.0.7-6tr.i586.rpm
        Trustix Secure Linux 2.0
        ftp://ftp.trustix.org/pub/trustix/updates/
        Trustix lvm-1.0.8-5tr.i586.rpm
        Trustix Secure Linux 2.1 & Enterprise Server 2
        ftp://ftp.trustix.org/pub/trustix/updates/
        Trustix lvm-devel-1.0.7-6tr.i586.rpm
        Trustix Secure Linux 2.0
        ftp://ftp.trustix.org/pub/trustix/updates/
        Trustix lvm-devel-1.0.8-5tr.i586.rpm
        Trustix Secure Linux 2.1 & Enterprise Server 2
        ftp://ftp.trustix.org/pub/trustix/updates/
        LVM Logical Volume Management Utilities 1.0.8
        Mandrake lvm1-1.0.8-3.1.100mdk.amd64.rpm
        Mandrake Linux 10.0/AMD64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lvm1-1.0.8-3.1.100mdk.i586.rpm
        Mandrake Linux 10.0
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lvm1-1.0.8-3.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lvm1-1.0.8-3.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Ubuntu lvm10-udeb_1.0.8-4ubuntu1.1_amd64.udeb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/l/lvm10/lvm10-udeb_1.0.8-4 ubuntu1.1_amd64.udeb
        Ubuntu lvm10-udeb_1.0.8-4ubuntu1.1_i386.udeb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/l/lvm10/lvm10-udeb_1.0.8-4 ubuntu1.1_i386.udeb
        Ubuntu lvm10-udeb_1.0.8-4ubuntu1.1_powerpc.udeb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/l/lvm10/lvm10-udeb_1.0.8-4 ubuntu1.1_powerpc.udeb
        Ubuntu lvm10_1.0.8-4ubuntu1.1_amd64.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/l/lvm10/lvm10_1.0.8-4ubunt u1.1_amd64.deb
        Ubuntu lvm10_1.0.8-4ubuntu1.1_i386.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/l/lvm10/lvm10_1.0.8-4ubunt u1.1_i386.deb
        Ubuntu lvm10_1.0.8-4ubuntu1.1_powerpc.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/l/lvm10/lvm10_1.0.8-4ubunt u1.1_powerpc.deb
        

- 漏洞信息

11392
LVM lvmcreate_initrd Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-11-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Trustix LVM Utilities Unspecified Insecure Temporary File Creation Vulnerability
Design Error 11290
No Yes
2004-09-30 12:00:00 2009-07-12 07:06:00
Trustix security engineers are credited with these discoveries.

- 受影响的程序版本

RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
Red Hat Fedora Core1
LVM Logical Volume Management Utilities 1.0.8
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
LVM Logical Volume Management Utilities 1.0.7
+ Mandriva Linux Mandrake 9.2 amd64
+ Mandriva Linux Mandrake 9.2
+ Mandriva Linux Mandrake 9.2
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Enterprise Linux 2.0
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.1
+ Trustix Secure Linux 2.0
+ Trustix Secure Linux 2.0
+ Trustix Secure Linux 1.5
+ Trustix Secure Linux 1.5
LVM Logical Volume Management Utilities 1.0.4
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
LVM Logical Volume Management Utilities 1.0.1
+ MandrakeSoft Corporate Server 2.1 x86_64
+ MandrakeSoft Corporate Server 2.1
+ MandrakeSoft Corporate Server 2.1
Gentoo Linux

- 漏洞讨论

Trustix LVM Utilities are affected by an unspecified insecure temporary file creation vulnerability. This issue is likely due to a design error that causes the application to fail to verify a files existence before writing to it.

An attacker may leverage this issue to overwrite arbitrary files with the privileges of an unsuspecting user that activates the vulnerable application. Reportedly this issue is unlikely to facilitate privilege escalation.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Trustix Linux has released an advisory (TSL-2004-0050) along with fixes dealing with this issue. Please see the referenced advisory for more information.

Ubuntu has released an advisory (USN-15-1) to address this issue. Please see the referenced advisory for more information.

Debian has released advisory DSA 583-1 to address this issue. Please see the attached advisory for further details on obtaining and applying fixes.

Gentoo Linux has released advisory GLSA 200411-22 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
emerge --sync
emerge --ask --oneshot --verbose ">=sys-fs/lvm-user-1.0.7-r2"
Please see the referenced advisory for further information.

MandrakeSoft has issued an advisory (MDKSA-2004:144) along with patched upgrades. Please see the referenced advisory for more information.

Fedora Legacy has released security advisory FLSA:152842 addressing this issue for RedHat Linux 7.3 and 9, and for Fedora Core 1. Please see the referenced advisory for details on obtaining and applying the appropriate updates.


LVM Logical Volume Management Utilities 1.0.1

LVM Logical Volume Management Utilities 1.0.4

LVM Logical Volume Management Utilities 1.0.7

LVM Logical Volume Management Utilities 1.0.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站