CVE-2004-0971
CVSS2.1
发布时间 :2005-02-09 00:00:00
修订时间 :2010-08-21 00:21:34
NMCOS    

[原文]The krb5-send-pr script in the kerberos5 (krb5) package in Trustix Secure Linux 1.5 through 2.1, and possibly other operating systems, allows local users to overwrite files via a symlink attack on temporary files.


[CNNVD]MIT Kerberos 5 SEND-PR.SH不安全临时文件创建漏洞(CNNVD-200502-016)

        Kerberos 是一种网络认证协议,其设计目标是通过密钥系统为客户机/ 服务器应用程序提供强大的认证服务。
        Trustix Secure Linux 1.5至2.1以及其他可能操作系统中的kerberos5 (krb5)程序包内的krb5-send-pr脚本,可让本地用户通过象征性的链接攻击临时文件,从而覆盖这些文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10497The krb5-send-pr script in the kerberos5 (krb5) package in Trustix Secure Linux 1.5 through 2.1, and possibly other operating systems, allow...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0971
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0971
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-016
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11289
(VENDOR_ADVISORY)  BID  11289
http://www.gentoo.org/security/en/glsa/glsa-200410-24.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200410-24
http://xforce.iss.net/xforce/xfdb/17583
(VENDOR_ADVISORY)  XF  script-temporary-file-overwrite(17583)
http://www.trustix.org/errata/2004/0050
(UNKNOWN)  TRUSTIX  2004-0050
http://www.redhat.com/support/errata/RHSA-2005-012.html
(UNKNOWN)  REDHAT  RHSA-2005:012
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136304
(UNKNOWN)  CONFIRM  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136304

- 漏洞信息

MIT Kerberos 5 SEND-PR.SH不安全临时文件创建漏洞
低危 设计错误
2005-02-09 00:00:00 2005-10-20 00:00:00
本地  
        Kerberos 是一种网络认证协议,其设计目标是通过密钥系统为客户机/ 服务器应用程序提供强大的认证服务。
        Trustix Secure Linux 1.5至2.1以及其他可能操作系统中的kerberos5 (krb5)程序包内的krb5-send-pr脚本,可让本地用户通过象征性的链接攻击临时文件,从而覆盖这些文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
         MIT Kerberos 5 1.3.4
        Fedora krb5-debuginfo-1.3.6-2.i386.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-debuginfo-1.3.6-2.x86_64.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-devel-1.3.6-2.i386.rpmRedHat Fedora Core 3
        ttp://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-devel-1.3.6-2.x86_64.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-libs-1.3.6-2.i386.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-libs-1.3.6-2.x86_64.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-server-1.3.6-2.i386.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-server-1.3.6-2.x86_64.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-workstation-1.3.6-2.i386.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora krb5-workstation-1.3.6-2.x86_64.rpmRedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Trustix kerberos5-1.3.4-3tr.i586.rpmTrustix Secure Linux 2.1 & Enterprise Server 2
        ftp://ftp.trustix.org/pub/trustix/updates/
        Trustix kerberos5-devel-1.3.4-3tr.i586.rpmTrustix Secure Linux 2.1 & Enterprise Server 2
        ftp://ftp.trustix.org/pub/trustix/updates/
        Trustix kerberos5-libs-1.3.4-3tr.i586.rpmTrustix Secure Linux 2.1 & Enterprise Server 2
        ftp://ftp.trustix.org/pub/trustix/updates/
        SGI ProPack 3.0
        SGI patch10139.tar.gz
        ftp://patches.sgi.com/support/free/security/patches/ProPack/3/patch101
        39.tar.gz

- 漏洞信息

11117
MIT Kerberos 5 send-pr.sh Symlink Arbitrary File Manipulation
Local Access Required Race Condition
Loss of Integrity
Exploit Public

- 漏洞描述

MIT Kerberos contains a flaw that may allow a malicious user to overwrite arbitrary files on the system with the permissions of the user running Kerberos, which is potentially root. The issue is due to the program creating world-writeagble symlinks with predictable filenames -- users may overwrite those links to point to any file on the filesystem. This may allow files to be overwritten with the contents of the newly created target, resulting in a loss of integrity.

- 时间线

2004-09-30 Unknow
2004-09-30 Unknow

- 解决方案

Upgrade to version 1.3.4-r1 or higher, as it has been reported to fix this vulnerability. To do this under Gentoo Linux, run these commands: # emerge sync # emerge -pv ">=app-crypt/mit-krb5-1.3.4-r1" # emerge ">=app-crypt/mit-krb5-1.3.4-r1" An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MIT Kerberos 5 SEND-PR.SH Insecure Temporary File Creation Vulnerability
Design Error 11289
No Yes
2004-09-30 12:00:00 2009-07-12 07:06:00
The individual or individuals responsible for the discovery of this issue is currently unknown; Trustix security engineers are credited with these discoveries.

- 受影响的程序版本

SGI ProPack 3.0
RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
Red Hat Fedora Core1
MIT Kerberos 5 1.3.4
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Turbolinux Turbolinux Server 10.0

- 漏洞讨论

MIT Kerberos 5 is affected by an insecure temporary file creation vulnerability. This issue is likely due to a design error that causes the application to fail to verify the existence of a file before writing to it.

An attacker may leverage this issue to overwrite arbitrary files with the privileges of an unsuspecting user that activates the vulnerable application. Reportedly this issue is unlikely to facilitate privilege escalation.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

SGI has released advisory 20050104-01-U (SGI Advanced Linux Environment 3 Security Update #24) to address various issues in SGI Advanced Linux Environment 3. This advisory includes updated SGI ProPack 3 Service Pack 3 packages and patch 10139. Please see the referenced advisory for more information.

Trustix Linux has released an advisory (TSL-2004-0050) along with fixes dealing with this issue. Please see the referenced advisory for more information.

Gentoo has released an advisory (GLSA 200410-24) to address this issue. Please see the referenced advisory for more information. Gentoo users may carry out the following actions to update their computers:

emerge sync
emerge -pv ">=app-crypt/mit-krb5-1.3.4-r1"
emerge ">=app-crypt/mit-krb5-1.3.4-r1"

Fedora advisories FEDORA-2004-563 and FEDORA-2004-564 are available to address these issues in Fedora Core 2 and Fedora Core 3. Please see the referenced advisories for more information.

Fedora Legacy has released security advisory FLSA:154276 addressing this issue for RedHat Linux 7.3 and 9, and for Fedora Core 1. Please see the referenced advisory for details on obtaining and applying the appropriate updates.


MIT Kerberos 5 1.3.4

SGI ProPack 3.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站