CVE-2004-0956
CVSS5.0
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-10 15:28:22
NMCOS    

[原文]MySQL before 4.0.20 allows remote attackers to cause a denial of service (application crash) via a MATCH AGAINST query with an opening double quote but no closing double quote.


[CNNVD]MySQL MATCH AGAINST 拒绝服务漏洞(CNNVD-200501-045)

        MySQL是一个开源的关系型数据库管理系统。
        MySQL 4.0.20之前版本存在拒绝服务漏洞。
        远程攻击者可借助一个开头带双引号,但结尾没有双引号的MATCH AGAINST查询,造成应用程序崩溃,导致拒绝服务。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mysql:mysql:4.0.15MySQL MySQL 4.0.15
cpe:/a:mysql:mysql:4.0.8:gammaMySQL MySQL 4.0.8 gamma
cpe:/a:mysql:mysql:4.0.10MySQL MySQL 4.0.10
cpe:/o:suse:suse_linux:8.1SuSE SuSE Linux 8.1
cpe:/a:mysql:mysql:4.0.11:gammaMySQL MySQL 4.0.11 gamma
cpe:/o:suse:suse_linux:9.2SuSE SuSE Linux 9.2
cpe:/a:mysql:mysql:4.0.9MySQL MySQL 4.0.9
cpe:/a:mysql:mysql:4.0.12MySQL MySQL 4.0.12
cpe:/o:suse:suse_linux:9.1SuSE SuSE Linux 9.1
cpe:/a:mysql:mysql:4.0.3MySQL MySQL 4.0.3
cpe:/a:mysql:mysql:4.0.2MySQL MySQL 4.0.2
cpe:/a:mysql:mysql:4.0.9:gammaMySQL MySQL 4.0.9 gamma
cpe:/a:mysql:mysql:4.0.4MySQL MySQL 4.0.4
cpe:/a:mysql:mysql:4.0.11MySQL MySQL 4.0.11
cpe:/a:mysql:mysql:4.0.7MySQL MySQL 4.0.7
cpe:/a:mysql:mysql:4.0.6MySQL MySQL 4.0.6
cpe:/o:suse:suse_linux:9.0::x86_64
cpe:/o:suse:suse_linux:8.0SuSE SuSE Linux 8.0
cpe:/a:mysql:mysql:4.0.0MySQL MySQL 4.0.0
cpe:/a:mysql:mysql:4.0.5aMySQL MySQL 4.0.5a
cpe:/a:mysql:mysql:4.0.18MySQL MySQL 4.0.18
cpe:/a:mysql:mysql:4.0.7:gammaMySQL MySQL 4.0.7 gamma
cpe:/a:mysql:mysql:4.0.20MySQL MySQL 4.0.20
cpe:/a:mysql:mysql:4.0.5MySQL MySQL 4.0.5
cpe:/a:mysql:mysql:4.0.14MySQL MySQL 4.0.14
cpe:/o:suse:suse_linux:9.0SuSE SuSE Linux 9.0
cpe:/o:suse:suse_linux:8.2SuSE SuSE Linux 8.2
cpe:/o:ubuntu:ubuntu_linux:4.1::ia64
cpe:/a:mysql:mysql:4.0.1MySQL MySQL 4.0.1
cpe:/o:ubuntu:ubuntu_linux:4.1::ppc
cpe:/a:mysql:mysql:4.0.8MySQL MySQL 4.0.8
cpe:/a:mysql:mysql:4.0.13MySQL MySQL 4.0.13

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0956
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0956
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-045
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200410-22.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200410-22
http://xforce.iss.net/xforce/xfdb/17768
(VENDOR_ADVISORY)  XF  mysql-match-against-dos(17768)
http://www.trustix.net/errata/2004/0054/
(UNKNOWN)  TRUSTIX  2004-0054
http://www.novell.com/linux/security/advisories/2004_01_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2004:001
http://lists.mysql.com/packagers/202
(UNKNOWN)  CONFIRM  http://lists.mysql.com/packagers/202
http://bugs.mysql.com/bug.php?id=3870
(UNKNOWN)  CONFIRM  http://bugs.mysql.com/bug.php?id=3870

- 漏洞信息

MySQL MATCH AGAINST 拒绝服务漏洞
中危 其他
2005-01-10 00:00:00 2006-03-28 00:00:00
远程  
        MySQL是一个开源的关系型数据库管理系统。
        MySQL 4.0.20之前版本存在拒绝服务漏洞。
        远程攻击者可借助一个开头带双引号,但结尾没有双引号的MATCH AGAINST查询,造成应用程序崩溃,导致拒绝服务。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://dev.mysql.com/downloads/

- 漏洞信息

10985
MySQL MATCH..AGAINST Query DoS
Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2004-10-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.0.20 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MySQL Remote FULLTEXT Search Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 11432
Yes No
2004-05-23 12:00:00 2009-07-12 07:07:00
Discovery of this issue is credited to Steven Roussey.

- 受影响的程序版本

Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux 8.1
S.u.S.E. Linux 8.0
MySQL AB MySQL 4.0.21
MySQL AB MySQL 4.0.20
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
MySQL AB MySQL 4.0.18
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
MySQL AB MySQL 4.0.15
+ Conectiva Linux 10.0
+ Mandriva Linux Mandrake 9.2 amd64
+ Mandriva Linux Mandrake 9.2
+ OpenPKG OpenPKG Current
MySQL AB MySQL 4.0.14
+ OpenPKG OpenPKG 1.3
+ OpenPKG OpenPKG Current
+ Trustix Secure Linux 2.0
MySQL AB MySQL 4.0.13
MySQL AB MySQL 4.0.12
MySQL AB MySQL 4.0.11 -gamma
MySQL AB MySQL 4.0.11
+ Mandriva Linux Mandrake 9.1 ppc
+ Mandriva Linux Mandrake 9.1
MySQL AB MySQL 4.0.10
MySQL AB MySQL 4.0.9 -gamma
MySQL AB MySQL 4.0.9
MySQL AB MySQL 4.0.8 -gamma
MySQL AB MySQL 4.0.8
MySQL AB MySQL 4.0.7 -gamma
MySQL AB MySQL 4.0.7
MySQL AB MySQL 4.0.6
MySQL AB MySQL 4.0.5 a
MySQL AB MySQL 4.0.5
MySQL AB MySQL 4.0.4
MySQL AB MySQL 4.0.3
MySQL AB MySQL 4.0.2
MySQL AB MySQL 4.0.1
MySQL AB MySQL 4.0 .0
MySQL AB MySQL 4.1.5
MySQL AB MySQL 4.1.4
MySQL AB MySQL 4.1.3 -beta
MySQL AB MySQL 4.1.3 -beta
MySQL AB MySQL 4.1.3 -0
MySQL AB MySQL 4.1.2 -alpha
MySQL AB MySQL 4.0.21
MySQL AB MySQL 4.1.0.0-alpha
MySQL AB MySQL 4.1.0-0

- 不受影响的程序版本

MySQL AB MySQL 4.1.5
MySQL AB MySQL 4.1.4
MySQL AB MySQL 4.1.3 -beta
MySQL AB MySQL 4.1.3 -beta
MySQL AB MySQL 4.1.3 -0
MySQL AB MySQL 4.1.2 -alpha
MySQL AB MySQL 4.0.21
MySQL AB MySQL 4.1.0.0-alpha
MySQL AB MySQL 4.1.0-0

- 漏洞讨论

MySQL is affected by a remote denial of service vulnerability in its FULLTEXT search functionality. This issue is due to a failure of the application to handle exceptional search input.

An attacker can leverage this issue to cause the affected MySQL database to crash, denying service to legitimate users.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Trustix Linux has made an advisory available.

The vendor has made an upgrade available that resolves this issue.

SuSE has released a security summary report (SUSE-SR:2004:001) to address this and other issues. The report indicates that a fix for this issue is available on the SuSE FTP server and also through the YaST Online Update utility. Customers are advised to peruse the referenced advisory for further details regarding obtaining and applying appropriate fixes.

Ubuntu Linux has released advisory USN-32-1 along with fixes to address this, and other issues. Please see the referenced advisory for further information.


MySQL AB MySQL 4.0 .0

MySQL AB MySQL 4.0.1

MySQL AB MySQL 4.0.10

MySQL AB MySQL 4.0.11 -gamma

MySQL AB MySQL 4.0.11

MySQL AB MySQL 4.0.12

MySQL AB MySQL 4.0.13

MySQL AB MySQL 4.0.14

MySQL AB MySQL 4.0.15

MySQL AB MySQL 4.0.18

MySQL AB MySQL 4.0.2

MySQL AB MySQL 4.0.20

MySQL AB MySQL 4.0.21

MySQL AB MySQL 4.0.3

MySQL AB MySQL 4.0.4

MySQL AB MySQL 4.0.5

MySQL AB MySQL 4.0.5 a

MySQL AB MySQL 4.0.6

MySQL AB MySQL 4.0.7

MySQL AB MySQL 4.0.7 -gamma

MySQL AB MySQL 4.0.8 -gamma

MySQL AB MySQL 4.0.8

MySQL AB MySQL 4.0.9 -gamma

MySQL AB MySQL 4.0.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站