CVE-2004-0955
CVSSN/A
发布时间 :2004-12-23 00:00:00
修订时间 :2008-09-10 15:28:22
NMOPS    

[原文]** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2004-0599. Reason: This candidate is a reservation duplicate of CVE-2004-0599 (the first item listed in that candidate). Notes: All CVE users should reference CVE-2004-0599 instead of this candidate. All references and descriptions have been removed from this candidate to prevent accidental usage.


[CNNVD]CNNVD数据暂缺。


[机译]* REJECT **不要使用该候选号码。

- CVSS (基础分值)

CVSS暂不可用

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0955
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0955
(官方数据源) NVD

- 其它链接及资源

- 漏洞信息 (F34793)

dsa-570.txt (PacketStormID:F34793)
2004-10-27 00:00:00
 
advisory,overflow,arbitrary
linux,debian
CVE-2004-0955
[点击下载]

Debian Security Advisory 570-1 - Several integer overflows have been discovered by its upstream developers in libpng, a commonly used library to display PNG graphics. They could be exploited to cause arbitrary code to be executed when a specially crafted PNG image is processed.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 570-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
October 20th, 2004                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : libpng
Vulnerability  : integer overflow
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0955

Several integer overflows have been discovered by its upstream
developers in libpng, a commonly used library to display PNG graphics.
They could be exploited to cause arbitrary code to be executed when a
specially crafted PNG image is processed.

For the stable distribution (woody) this problem has been fixed in
version 1.0.12-3.woody.9.

For the unstable distribution (sid) this problem has been fixed in
version 1.0.15-8.

We recommend that you upgrade your libpng packages.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng_1.0.12-3.woody.9.dsc
      Size/MD5 checksum:      580 7df7d1e0bbd2332551a14cc0a21dddf7
    http://security.debian.org/pool/updates/main/libp/libpng/libpng_1.0.12-3.woody.9.diff.gz
      Size/MD5 checksum:    10396 dbf46963e7b26473fffba63a92791286
    http://security.debian.org/pool/updates/main/libp/libpng/libpng_1.0.12.orig.tar.gz
      Size/MD5 checksum:   481387 3329b745968e41f6f9e55a4d04a4964c

  Alpha architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_alpha.deb
      Size/MD5 checksum:   130374 1044ec55646f8e94e218bf4613db1f60
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_alpha.deb
      Size/MD5 checksum:   270440 74a5b9e3bc1b2fc2648133e196894b4f

  ARM architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_arm.deb
      Size/MD5 checksum:   109148 60e7475df4f824043242559b7d64322e
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_arm.deb
      Size/MD5 checksum:   241496 f9ad072eb50a9391ce4b105eff9b2cba

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_i386.deb
      Size/MD5 checksum:   107434 e81d90d93fc69329f1fc842666ab8bf2
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_i386.deb
      Size/MD5 checksum:   227648 a5495e210300e511e7c265e86303c909

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_ia64.deb
      Size/MD5 checksum:   147520 5292b0c17956697fa682a95be34abc0d
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_ia64.deb
      Size/MD5 checksum:   271938 ae7b7fed469735915bbdf87ab02f80a3

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_hppa.deb
      Size/MD5 checksum:   128830 b1937fc261ba66c8b69605c0f8df9305
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_hppa.deb
      Size/MD5 checksum:   262630 be93d764c002923fb1e6d5385b12e200

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_m68k.deb
      Size/MD5 checksum:   104172 86a18a750a19efbe94f8b79d9e4e89c8
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_m68k.deb
      Size/MD5 checksum:   220804 d4b278997d86fe7cd824f2ad820a8466

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_mips.deb
      Size/MD5 checksum:   109184 b825d9e4e59ed06f5ff718d86c078714
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_mips.deb
      Size/MD5 checksum:   240698 883d442e57eef30ad86251ce2ffed701

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_mipsel.deb
      Size/MD5 checksum:   109102 eb85fee5ef0e9516372a7e245fd781ce
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_mipsel.deb
      Size/MD5 checksum:   240576 da9b75f48689e9277b8a053c014e8ddc

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_powerpc.deb
      Size/MD5 checksum:   110504 b7ab6493588e05c09811e3f58fa747b2
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_powerpc.deb
      Size/MD5 checksum:   234800 1e1bacb0bbe2d80166d4ce9f96348828

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_s390.deb
      Size/MD5 checksum:   110520 29172e2fc592785d44b5779ed7787f08
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_s390.deb
      Size/MD5 checksum:   229560 2577f1ecee02f71af34ca9aecbd70dd7

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/libp/libpng/libpng2_1.0.12-3.woody.9_sparc.deb
      Size/MD5 checksum:   110564 2eac357f311054279ef941a87befb62f
    http://security.debian.org/pool/updates/main/libp/libpng/libpng2-dev_1.0.12-3.woody.9_sparc.deb
      Size/MD5 checksum:   232302 7691bd27595acd87249be24746f47186


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBdoygW5ql+IAeqTIRAoMNAKCfndrl8yChYh6+2naQdhcT+xpYPACeOeUE
ZCFqX8nZqf7QJLxtj9G1wKI=
=YmFn
-----END PGP SIGNATURE-----

    

- 漏洞信息 (F34792)

dsa-571.txt (PacketStormID:F34792)
2004-10-27 00:00:00
 
advisory,overflow,arbitrary
linux,debian
CVE-2004-0955
[点击下载]

Debian Security Advisory 571-1 - Several integer overflows have been discovered by its upstream developers in libpng, a commonly used library to display PNG graphics. They could be exploited to cause arbitrary code to be executed when a specially crafted PNG image is processed.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 571-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
October 20th, 2004                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : libpng3
Vulnerability  : buffer overflows, integer overflow
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0955

Several integer overflows have been discovered by its upstream
developers in libpng, a commonly used library to display PNG graphics.
They could be exploited to cause arbitrary code to be executed when a
specially crafted PNG image is processed.

For the stable distribution (woody) these problems have been fixed in
version 1.2.1-1.1.woody.9.

For the unstable distribution (sid) these problems have been fixed in
version 1.2.5.0-9.

We recommend that you upgrade your libpng3 packages.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9.dsc
      Size/MD5 checksum:      583 a11e8a7d236ca98e6581b6066a35c7f9
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9.diff.gz
      Size/MD5 checksum:    10791 a68eee4690473d8402743f30d431db4d
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1.orig.tar.gz
      Size/MD5 checksum:   493105 75a21cbfae566158a0ac6d9f39087c4d

  Alpha architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_alpha.deb
      Size/MD5 checksum:   276634 dc9d30c7bb1213bf339e96a9d9b4c4ad
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_alpha.deb
      Size/MD5 checksum:   133666 1441a7afe56c6d0b01c09b635026a2b4

  ARM architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_arm.deb
      Size/MD5 checksum:   247780 97f36aa3e35547e3b095999fcf3fb694
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_arm.deb
      Size/MD5 checksum:   112314 2f5c3fe3190ce8d52836cfe682236cbb

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_i386.deb
      Size/MD5 checksum:   233356 480296fd503d8de105716bca44c59136
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_i386.deb
      Size/MD5 checksum:   110678 60cbe7dcb206efcc95add2e83b1e06e5

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_ia64.deb
      Size/MD5 checksum:   279022 22c86cf1b67c6a1d162eb42a9202a237
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_ia64.deb
      Size/MD5 checksum:   151874 82e6a6772fe5506c93cb90c52de2891e

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_hppa.deb
      Size/MD5 checksum:   269872 036ce4ca8f8934b00d4b2af6f05ff552
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_hppa.deb
      Size/MD5 checksum:   133022 ee3c8bb4e5b820be62d1efd8c708559c

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_m68k.deb
      Size/MD5 checksum:   226502 8ba581615baf0983b2e86c2b9ccfc187
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_m68k.deb
      Size/MD5 checksum:   107094 7923c57162269188601cb00763465584

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_mips.deb
      Size/MD5 checksum:   247200 0aa9e85a752c4759a43c591a97655208
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_mips.deb
      Size/MD5 checksum:   112508 5fa27ff5c3bef5f58be7337468c21f76

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_mipsel.deb
      Size/MD5 checksum:   247134 f1b8922fff3d7ae70201b07697c97a92
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_mipsel.deb
      Size/MD5 checksum:   112416 eea654666ee8a3402f3bd3af95bdbfe3

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_powerpc.deb
      Size/MD5 checksum:   240886 9ad9c699045cea5f31c9e49ef8625583
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_powerpc.deb
      Size/MD5 checksum:   113642 763d6a6a326a7fcb81d94ad630594aee

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_s390.deb
      Size/MD5 checksum:   235188 c94798e9f884e98276544afbda776a10
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_s390.deb
      Size/MD5 checksum:   113662 f0d50c1b3b29347e0cc36a6eee2171f3

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/libp/libpng3/libpng-dev_1.2.1-1.1.woody.9_sparc.deb
      Size/MD5 checksum:   237942 17fbcdce55e78974c9cc0d6003905e92
    http://security.debian.org/pool/updates/main/libp/libpng3/libpng3_1.2.1-1.1.woody.9_sparc.deb
      Size/MD5 checksum:   114004 57b22ae95161928ff01797cb823efdfc


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBdpnWW5ql+IAeqTIRAjG+AJoD3n7QFtjK1Opz+0thBI/DLnkWMACgj8J/
b67yNVrnGR869dQEP7TV4GI=
=cHt6
-----END PGP SIGNATURE-----

    

- 漏洞信息

11027
libpng/libpng3 Image Height Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-10-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

LibPNG Graphics Library Image Height Integer Overflow Vulnerability
Input Validation Error 11481
Yes Yes
2004-10-20 12:00:00 2009-07-12 08:06:00
The vendor disclosed this vulnerability.

- 受影响的程序版本

Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
S.u.S.E. Linux Personal 9.1
libpng libpng3 1.2.6 rc1
libpng libpng3 1.2.6
libpng libpng3 1.2.5
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
+ Gentoo Linux 1.2
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
+ Mandriva Linux Mandrake 10.0
+ Mandriva Linux Mandrake 9.2 amd64
+ Mandriva Linux Mandrake 9.2 amd64
+ Mandriva Linux Mandrake 9.2
+ Mandriva Linux Mandrake 9.2
+ Mandriva Linux Mandrake 9.1 ppc
+ Mandriva Linux Mandrake 9.1 ppc
+ Mandriva Linux Mandrake 9.1
+ Mandriva Linux Mandrake 9.1
+ Red Hat Fedora Core1
+ Slackware Linux 10.0
+ Slackware Linux 9.1
+ Slackware Linux 9.1
+ Slackware Linux 9.0
+ Slackware Linux 9.0
+ Slackware Linux -current
+ Slackware Linux -current
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
+ Ubuntu Ubuntu Linux 4.1 ia32
libpng libpng3 1.2.4
+ Conectiva Linux 8.0
+ MandrakeSoft Corporate Server 2.1 x86_64
+ MandrakeSoft Corporate Server 2.1
+ MandrakeSoft Multi Network Firewall 2.0
+ Mandriva Linux Mandrake 9.0
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ S.u.S.E. Linux 8.1
libpng libpng3 1.2.3
libpng libpng3 1.2.2
+ RedHat Linux 8.0 i386
libpng libpng3 1.2.1
+ Debian Linux 3.0
+ Debian Linux 3.0
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ Mandriva Linux Mandrake 8.2
+ Slackware Linux 8.1
libpng libpng3 1.2 .0
+ Conectiva Linux 8.0
libpng libpng 1.0.17
libpng libpng 1.0.16
libpng libpng 1.0.15
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
libpng libpng 1.0.14
+ Conectiva Linux 7.0
+ Conectiva Linux 6.0
+ RedHat Linux 7.3 i386
+ RedHat Linux 7.2 ia64
+ RedHat Linux 7.2 i386
+ RedHat Linux 7.1 i386
+ RedHat Linux 7.0 i386
+ RedHat Linux 6.2 i386
libpng libpng 1.0.13
libpng libpng 1.0.12
- Caldera OpenLinux Server 3.1.1
- Caldera OpenLinux Server 3.1
- Caldera OpenLinux Workstation 3.1.1
- Caldera OpenLinux Workstation 3.1
+ Debian Linux 3.0
+ Mandriva Linux Mandrake 8.1 ia64
+ Mandriva Linux Mandrake 8.1
+ S.u.S.E. Linux 8.0
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3
libpng libpng 1.0.11
+ Conectiva Linux 8.0
+ Conectiva Linux 7.0
+ Conectiva Linux 6.0
libpng libpng 1.0.10
+ S.u.S.E. Linux 7.2
libpng libpng 1.0.9
+ Mandriva Linux Mandrake 8.0 ppc
+ Mandriva Linux Mandrake 8.0
libpng libpng 1.0.8
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1
+ Caldera OpenLinux Workstation 3.1.1
+ Caldera OpenLinux Workstation 3.1
+ MandrakeSoft Single Network Firewall 7.2
+ Mandriva Linux Mandrake 7.2
+ S.u.S.E. Linux 7.1 sparc
+ S.u.S.E. Linux 7.1 ppc
+ S.u.S.E. Linux 7.1 alpha
+ S.u.S.E. Linux 7.1
- Ximian GNOME 1.4
libpng libpng 1.0.7
libpng libpng 1.0.6
libpng libpng 1.0.5
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 IA-32
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ MandrakeSoft Corporate Server 1.0.1
+ Mandriva Linux Mandrake 7.1
libpng libpng 1.0
+ S.u.S.E. Linux 7.0 sparc
+ S.u.S.E. Linux 7.0 ppc
+ S.u.S.E. Linux 7.0 alpha
+ S.u.S.E. Linux 7.0
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0

- 漏洞讨论

LibPNG is the official Portable Network Graphics (PNG) reference library.

LibPNG is reported susceptible to an image height integer overflow vulnerability.

A specially crafted PNG image could reportedly overflow an integer value, and possibly result in overwriting of critical memory regions allowing for the alteration of proper program execution. This vulnerability may be exploited to execute attacker-supplied code in the context of an application that utilized the affected library.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

SuSE has released advisory SUSE-SA:2004:037 mainly to address the vulnerabilities described in BID 11488 and 11489. However, in the addendum of this advisory, it is reported that fixes for the issue described in this BID are now available on the SuSE update FTP server for download. Customers are advised to see the referenced advisory for further information regarding obtaining and applying appropriate updates.

Debian GNU/Linux has released advisories DSA 570-1, and DSA 571-1 to address this issue in libpng and libpng3 respectively. Please see the referenced advisories for further information.

Ubuntu Linux has released security advisory USN-1-1 to address this issue. Please refer to the advisory for further information on obtaining and applying fixes.


libpng libpng 1.0.12

libpng libpng 1.0.15

libpng libpng3 1.2.1

libpng libpng3 1.2.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站