CVE-2004-0938
CVSS5.0
发布时间 :2004-11-03 00:00:00
修订时间 :2010-08-21 00:21:30
NMCOS    

[原文]FreeRADIUS before 1.0.1 allows remote attackers to cause a denial of service (server crash) by sending an Ascend-Send-Secret attribute without the required leading packet.


[CNNVD]FreeRADIUS 'Ascend-Send-Secret'远程拒绝服务漏洞(CNNVD-200411-034)

        
        FreeRadius是一款开放源代码使用RADIUS协议的验证和帐户系统。
        FreeRadius 'Ascend-Send-Secret'处理存在错误,远程攻击者可以利用这个漏洞对服务进行拒绝服务攻击。
        FreeRADIUS的'Ascend-Send-Secret'类似Tunnel-Password,需要一"original"包对属性进行解码,问题存在于'radius.c'和'eap_tls.c'中,对Tunnel-Password进行了检查,而对'Ascend-Send-Secret'没有进行任何检查。使用VulnDisco RADIUS工具进行测试可导致程序崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:1347FreeRADIUS Ascend-Send-Secret Server Crash
oval:org.mitre.oval:def:10837FreeRADIUS before 1.0.1 allows remote attackers to cause a denial of service (server crash) by sending an Ascend-Send-Secret attribute witho...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0938
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0938
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-034
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/541574
(VENDOR_ADVISORY)  CERT-VN  VU#541574
http://xforce.iss.net/xforce/xfdb/17440
(VENDOR_ADVISORY)  XF  freeradius-dos(17440)
http://www.securityfocus.com/bid/11222
(VENDOR_ADVISORY)  BID  11222
http://www.osvdb.org/10178
(VENDOR_ADVISORY)  OSVDB  10178
http://security.gentoo.org/glsa/glsa-200409-29.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200409-29

- 漏洞信息

FreeRADIUS 'Ascend-Send-Secret'远程拒绝服务漏洞
中危 其他
2004-11-03 00:00:00 2005-10-20 00:00:00
远程  
        
        FreeRadius是一款开放源代码使用RADIUS协议的验证和帐户系统。
        FreeRadius 'Ascend-Send-Secret'处理存在错误,远程攻击者可以利用这个漏洞对服务进行拒绝服务攻击。
        FreeRADIUS的'Ascend-Send-Secret'类似Tunnel-Password,需要一"original"包对属性进行解码,问题存在于'radius.c'和'eap_tls.c'中,对Tunnel-Password进行了检查,而对'Ascend-Send-Secret'没有进行任何检查。使用VulnDisco RADIUS工具进行测试可导致程序崩溃。
        

- 公告与补丁

        厂商补丁:
        FreeRADIUS
        ----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载FreeRADIUS 1.0.1:
        ftp://ftp.freeradius.org/pub/radius/

- 漏洞信息

10178
FreeRADIUS Ascend-Send-Secret Processing Remote DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

FreeRADIUS contains a flaw that may allow a remote denial of service. The issue is triggered when an Ascend-Send-Secret packet without an original packet occurs, and will result in loss of availability for the service.

- 时间线

2004-09-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

FreeRADIUS Multiple Attribute Decoding Denial Of Service Vulnerabilities
Failure to Handle Exceptional Conditions 11222
Yes No
2004-09-20 12:00:00 2009-07-12 07:06:00
The individual responsible for the discovery of these issues is currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

RedHat Enterprise Linux ES 3
Red Hat Fedora Core2
Red Hat Fedora Core1
Red Hat Enterprise Linux AS 3
FreeRADIUS FreeRADIUS 1.0
FreeRADIUS FreeRADIUS 0.9.3
FreeRADIUS FreeRADIUS 0.9.2
FreeRADIUS FreeRADIUS 0.9.1
FreeRADIUS FreeRADIUS 0.9
FreeRADIUS FreeRADIUS 0.8.1
FreeRADIUS FreeRADIUS 0.8
FreeRADIUS FreeRADIUS 0.5
FreeRADIUS FreeRADIUS 0.4
FreeRADIUS FreeRADIUS 0.3
FreeRADIUS FreeRADIUS 0.2
FreeRADIUS FreeRADIUS 1.0.1

- 不受影响的程序版本

FreeRADIUS FreeRADIUS 1.0.1

- 漏洞讨论

Reportedly FreeRADIUS is affected by multiple remote denial of service vulnerabilities. These issues are due to a failure of the application to handle malformed packets.

An attacker may leverage these issues to cause the affected server to crash, denying service to legitimate users.

- 漏洞利用

No exploit is required to leverage these issues.

- 解决方案

Fedora Legacy has released advisory FLSA:2187 along with fixes for Fedora Core1 dealing with these issues. Please see the referenced advisory for more information.

RedHat has released advisory FEDORA-2004-355 along with fixes to address these issues in FreeRADIUS for Fedora Core 2. Please see the referenced advisory for further information.

Gentoo Linux has made an advisory (GLSA 200409-29) along with fixes available dealing with these issues. It has been advised that all FreeRADIUS users should upgrade to the latest version:
emerge sync
emerge -pv ">=net-dialup/freeradius-1.0.1"
emerge ">=net-dialup/freeradius-1.0.1"
For more information please see the referenced Gentoo Linux advisory.

The vendor has released an upgrade dealing with these issues.

RedHat has released advisory RHSA-2004:609-06 dealing with these issues for their Enterprise Linux products. Please see the referenced advisory for more information.


FreeRADIUS FreeRADIUS 0.2

FreeRADIUS FreeRADIUS 0.3

FreeRADIUS FreeRADIUS 0.4

FreeRADIUS FreeRADIUS 0.5

FreeRADIUS FreeRADIUS 0.8

FreeRADIUS FreeRADIUS 0.8.1

FreeRADIUS FreeRADIUS 0.9

FreeRADIUS FreeRADIUS 0.9.1

FreeRADIUS FreeRADIUS 0.9.2

FreeRADIUS FreeRADIUS 0.9.3

FreeRADIUS FreeRADIUS 1.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站