CVE-2004-0931
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2011-03-07 21:16:25
NMCOPS    

[原文]MySQL MaxDB before 7.5.00.18 allows remote attackers to cause a denial of service (crash) via an HTTP request to webdbm with high ASCII values in the Server field, which triggers an assert error in the IsAscii7 function.


[CNNVD]MySQL MaxDB WebDBM服务器名称服务拒绝漏洞(CNNVD-200412-644)

        MySQL MaxDB 7.5.00.18之前版本存在漏洞。远程攻击者可以借助Server字段中对带有高ASCII值的webdbm的HTTP请求来导致服务拒绝(崩溃),该漏洞在IsAscii7函数中触发了一个断言错误。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mysql:maxdb:7.5.00.12MySQL MaxDB 7.5.00.12
cpe:/a:mysql:maxdb:7.5.00.08MySQL MaxDB 7.5.00.08
cpe:/a:mysql:maxdb:7.5.00.15MySQL MaxDB 7.5.00.15
cpe:/a:mysql:maxdb:7.5.00.14MySQL MaxDB 7.5.00.14
cpe:/a:mysql:maxdb:7.5.00.16MySQL MaxDB 7.5.00.16
cpe:/a:mysql:maxdb:7.5.00.11MySQL MaxDB 7.5.00.11

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0931
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0931
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-644
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11346
(PATCH)  BID  11346
http://www.secunia.com/advisories/12756
(PATCH)  SECUNIA  12756
http://xforce.iss.net/xforce/xfdb/17633
(UNKNOWN)  XF  maxdb-isascii7dos(17633)
http://www.osvdb.org/10532
(UNKNOWN)  OSVDB  10532
http://www.idefense.com/application/poi/display?id=150&type=vulnerabilities&flashstatus=false
(UNKNOWN)  IDEFENSE  20041006 MySQL MaxDB Web Agent WebDBMServer Name Denial of Service Vulnerability

- 漏洞信息

MySQL MaxDB WebDBM服务器名称服务拒绝漏洞
中危 输入验证
2004-12-31 00:00:00 2006-03-28 00:00:00
远程  
        MySQL MaxDB 7.5.00.18之前版本存在漏洞。远程攻击者可以借助Server字段中对带有高ASCII值的webdbm的HTTP请求来导致服务拒绝(崩溃),该漏洞在IsAscii7函数中触发了一个断言错误。

- 公告与补丁

        This issue has been addressed in MaxDB 7.5.00.18.
        MySQL AB MaxDB 7.5 .00.14
        
        MySQL AB MaxDB 7.5 .00.11
        
        MySQL AB MaxDB 7.5 .00.15
        
        MySQL AB MaxDB 7.5 .00.08
        
        MySQL AB MaxDB 7.5 .00.12
        
        MySQL AB MaxDB 7.5 .00.16
        

- 漏洞信息 (F34608)

10.06.04a.txt (PacketStormID:F34608)
2004-10-13 00:00:00
 
advisory,remote,denial of service
CVE-2004-0931
[点击下载]

iDEFENSE Security Advisory 10.06.04a - Remote exploitation of an input validation error in MySQL MaxDB could allow attackers to trigger a denial of service condition.

MySQL MaxDB Web Agent WebDBM Server Name Denial of Service Vulnerability

iDEFENSE Security Advisory 10.06.04a:
www.idefense.com/application/poi/display?id=150&type=vulnerabilities
October 6, 2004

I. BACKGROUND

MaxDB by MySQL is a re-branded and enhanced version of SAP DB, SAP AG's
open source database. MaxDB is a heavy-duty, SAP-certified open source
database that offers high availability, scalability and a comprehensive
feature set. MaxDB complements the MySQL database server, targeted for
large mySAP ERP environments and other applications that require maximum
enterprise-level database functionality.

II. DESCRIPTION

Remote exploitation of an input validation error in MySQL MaxDB could
allow attackers to trigger a denial of service condition.

The problem specifically exists due to improper input validation of a
user-supplied variable in the IsAscii7() function. Remote attackers can
send a specially crafted HTTP request to webdbm with the 'Server' value
containing ASCII values above 0x7F to cause an assert directive to fail,
resulting in a DoS condition.

    wahttp:
    ToolsCommon/Tools_DynamicUTF8String.hpp:249:
    Tools_DynamicUTF8String::Tools_DynamicUTF8String(const SAPDB_Char *)
    Assertion `IsAscii7(src)' failed.

    Program received signal SIGABRT, Aborted.
    [Switching to Thread 10251 (LWP 12706)]
    0x40429781 in kill () from /lib/libc.so.6

III. ANALYSIS

Successful exploitation allows remote attackers to trigger a denial of
service condition on the web agent component of MaxDB.

IV. DETECTION

iDEFENSE has confirmed that SAP DB version 7.5 for both Linux and
Windows is vulnerable.

V. WORKAROUND

Use of an ingress perimeter firewall filter can help detect and mitigate
the risk of attack.

VI. VENDOR RESPONSE

"A solution for the issue is available with MaxDB 7.5.00.18."

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
names CAN-2004-0931 to these issues. This is a candidate for inclusion
in the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

08/16/2004   Initial vendor notification
08/16/2004   iDEFENSE clients notified
08/19/2004   Initial vendor response
10/06/2004   Coordinated public disclosure

IX. CREDIT

Patrik Karlsson (cqure.net) is credited with this discovery.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

X. LEGAL NOTICES

Copyright (c) 2004 iDEFENSE, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html
    

- 漏洞信息

10532
MySQL MaxDB webdbm Server Field DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

MaxDB webdmn contains a flaw that may allow a remote denial of service. The issue is triggered when a specially crafted HTTP request containing a value higher than 0x7F in the "Server" field is sent, and will result in loss of availability for the web agent component of MaxDB.

- 时间线

2004-10-07 2004-08-16
2004-10-06 Unknow

- 解决方案

Upgrade to version 7.5.00.18 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

MySQL MaxDB WebDBM Server Name Denial of Service Vulnerability
Input Validation Error 11346
Yes No
2004-10-07 12:00:00 2009-07-12 07:06:00
Discovery is credited to Patrik Karlsson.

- 受影响的程序版本

SAP DB 7.5
MySQL AB MaxDB 7.5 .00.16
MySQL AB MaxDB 7.5 .00.15
MySQL AB MaxDB 7.5 .00.14
MySQL AB MaxDB 7.5 .00.12
MySQL AB MaxDB 7.5 .00.11
MySQL AB MaxDB 7.5 .00.08
MySQL AB MaxDB 7.5 .00.18

- 不受影响的程序版本

MySQL AB MaxDB 7.5 .00.18

- 漏洞讨论

A remotely exploitable denial of service vulnerability exists in MaxDB. The cause of this condition is an input validation error that is exposed when an internal function in the WebDBM handles a client-supplied 'Server' name in an HTTP request that includes specific values.

This will reportedly trigger an exception due to an assert directive failing, resulting in a denial of service condition in the web agent.

This issue was reportedly tested on Windows and Linux versions. Other versions could also be affected.

- 漏洞利用

There is no exploit required.

- 解决方案

This issue has been addressed in MaxDB 7.5.00.18.


MySQL AB MaxDB 7.5 .00.14

MySQL AB MaxDB 7.5 .00.11

MySQL AB MaxDB 7.5 .00.15

MySQL AB MaxDB 7.5 .00.08

MySQL AB MaxDB 7.5 .00.12

MySQL AB MaxDB 7.5 .00.16

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站