CVE-2004-0916
CVSS5.0
发布时间 :2005-01-27 00:00:00
修订时间 :2008-09-05 16:39:46
NMCOPS    

[原文]Directory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.


[CNNVD]cabextract 目录遍历漏洞(CNNVD-200501-283)

        cabextract是一个用于解压.cab文件的免费工具软件。
        cabextract 1.1之前版本中存在目录遍历漏洞。远程攻击者可通过文件名种包含".."序列的压缩文件,重写任意性文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cabextract:cabextract:1.0cabextract 1.0
cpe:/a:cabextract:cabextract:0.2cabextract 0.2
cpe:/a:cabextract:cabextract:0.6cabextract 0.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0916
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0916
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-283
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2004/dsa-574
(VENDOR_ADVISORY)  DEBIAN  DSA-574
http://secunia.com/advisories/12882/
(VENDOR_ADVISORY)  SECUNIA  12882
http://xforce.iss.net/xforce/xfdb/17766
(VENDOR_ADVISORY)  XF  cabextract-directory-traversal(17766)
http://www.securityfocus.com/bid/11460
(VENDOR_ADVISORY)  BID  11460
http://www.kyz.uklinux.net/cabextract.php#changes
(UNKNOWN)  CONFIRM  http://www.kyz.uklinux.net/cabextract.php#changes

- 漏洞信息

cabextract 目录遍历漏洞
中危 路径遍历
2005-01-27 00:00:00 2005-10-20 00:00:00
远程  
        cabextract是一个用于解压.cab文件的免费工具软件。
        cabextract 1.1之前版本中存在目录遍历漏洞。远程攻击者可通过文件名种包含".."序列的压缩文件,重写任意性文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.cabextract.org.uk/

- 漏洞信息 (F34878)

dsa-574.txt (PacketStormID:F34878)
2004-10-28 00:00:00
 
advisory,arbitrary
linux,debian
CVE-2004-0916
[点击下载]

Debian Security Advisory 574-1 - The upstream developers discovered a problem in cabextract, a tool to extract cabinet files. The program was able to overwrite files in upper directories. This could lead an attacker to overwrite arbitrary files.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 574-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
October 28th, 2004                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : cabextract
Vulnerability  : missing directory sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0916
Debian Bug     : 277522

The upstream developers discovered a problem in cabextract, a tool to
extract cabinet files.  The program was able to overwrite files in
upper directories.  This could lead an attacker to overwrite arbitrary
files.

For the stable distribution (woody) this problem has been fixed in
version 0.2-2b.

For the unstable distribution (sid) this problem has been fixed in
version 1.1-1.

We recommend that you upgrade your cabextract package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b.dsc
      Size/MD5 checksum:      568 72c81704917abe1f37ae4694392c97e3
    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b.diff.gz
      Size/MD5 checksum:     2314 d31e74e1186f00a60dc944bec28829f9
    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2.orig.tar.gz
      Size/MD5 checksum:    66136 8f59514ec67cfb43658c57c67c864b74

  Alpha architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_alpha.deb
      Size/MD5 checksum:    20344 2eba57f87ea2348e3e0322eb5d7ce3a5

  ARM architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_arm.deb
      Size/MD5 checksum:    16514 0c1b72dfef4454c9a4140d4728b6d56d

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_i386.deb
      Size/MD5 checksum:    15054 f0b5a915d31a51dbad5df5163c326204

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_ia64.deb
      Size/MD5 checksum:    23934 7a180cb2c7321533839d88edfde0664e

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_hppa.deb
      Size/MD5 checksum:    17784 50e507a1108c883a550f6b14b01238be

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_m68k.deb
      Size/MD5 checksum:    15034 e576be7c48a6217bc3d04f850b622ea9

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_mips.deb
      Size/MD5 checksum:    17948 427396df5074b07059f35d1603512423

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_mipsel.deb
      Size/MD5 checksum:    17884 de2d86ebeb9fdcaf58f99e403ca4ba86

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_powerpc.deb
      Size/MD5 checksum:    16572 f087bc23f1a5ff782ad4a15563482af0

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_s390.deb
      Size/MD5 checksum:    16658 44e78328ade15ef1b71fe5fec2738bc7

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/c/cabextract/cabextract_0.2-2b_sparc.deb
      Size/MD5 checksum:    18692 ad98229293a9a753db5d371cab657d06


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBgH7wW5ql+IAeqTIRAo/oAKCp8cfa0FAGZccSf1Z/cThHrha8dACePC+c
RFwKfrysKwA898z3JLSmEGw=
=rbCk
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html
    

- 漏洞信息

10953
cabextract Traversal Arbitrary File Overwrite
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

cabextract contains a flaw that allows a remote attacker to overwrite arbitrary files outside of the extraction path. The issue is due to the program not properly sanitizing cabinet files containing "./", "../", and ".." as part of the filename.

- 时间线

2004-10-18 Unknow
2004-10-18 Unknow

- 解决方案

Upgrade to version 1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Cabextract Remote Directory Traversal Vulnerability
Input Validation Error 11460
Yes No
2004-10-19 12:00:00 2009-07-12 08:06:00
The vendor reported this issue.

- 受影响的程序版本

cabextract cabextract 1.0
cabextract cabextract 0.6
cabextract cabextract 0.2
cabextract cabextract 1.1

- 不受影响的程序版本

cabextract cabextract 1.1

- 漏洞讨论

cabextract is reported prone to a remote directory traversal vulnerability. This issue presents itself due to insufficient sanitization of user-supplied data.

An attacker may exploit this issue to corrupt or manipulate sensitive data. This may aid in further attacks against a computer.

cabextract versions 1.0 and prior are reported prone to this issue.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has released an upgrade to address this issue.

Debian has released an advisory (DSA 574-1) to address this issue. Please see the referenced advisory for more information.


cabextract cabextract 0.2

cabextract cabextract 0.6

cabextract cabextract 1.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站