CVE-2004-0875
CVSS6.8
发布时间 :2004-12-23 00:00:00
修订时间 :2008-09-05 16:39:38
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Phpgroupware (aka webdistro) 0.9.16.002 and earlier allow remote attackers to insert arbitrary HTML or web script, as demonstrated with a request to the wiki module.


[CNNVD]PHPGroupWare Wiki跨站脚本漏洞(CNNVD-200412-093)

        Phpgroupware (又称为webdistro)0.9.16.002及其以前的版本存在多个跨站脚本(XSS)漏洞。远程攻击者利用该漏洞插入任意HTML或网页脚本,正如wiki模块的请求。
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpgroupware:phpgroupware:0.9.13
cpe:/a:phpgroupware:phpgroupware:0.9.16.000
cpe:/a:phpgroupware:phpgroupware:0.9.14.007
cpe:/a:phpgroupware:phpgroupware:0.9.12
cpe:/a:phpgroupware:phpgroupware:0.9.16.002
cpe:/a:phpgroupware:phpgroupware:0.9.14.005
cpe:/a:phpgroupware:phpgroupware:0.9.14.003
cpe:/a:phpgroupware:phpgroupware:0.9.16_rc1
cpe:/a:phpgroupware:phpgroupware:0.9.14.006

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0875
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0875
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-093
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17289
(VENDOR_ADVISORY)  XF  phpgroupware-xss(17289)
http://www.gentoo.org/security/en/glsa/glsa-200409-22.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200409-22
http://downloads.phpgroupware.org/changelog
(UNKNOWN)  CONFIRM  http://downloads.phpgroupware.org/changelog

- 漏洞信息

PHPGroupWare Wiki跨站脚本漏洞
中危 跨站脚本
2004-12-23 00:00:00 2005-10-20 00:00:00
远程  
        Phpgroupware (又称为webdistro)0.9.16.002及其以前的版本存在多个跨站脚本(XSS)漏洞。远程攻击者利用该漏洞插入任意HTML或网页脚本,正如wiki模块的请求。
        

- 公告与补丁

        Gentoo has released updates that may be applied with the following commands:
        emerge sync
        emerge -pv ">=www-apps/phpgroupware-0.9.16.003"
        emerge ">=www-apps/phpgroupware-0.9.16.003"
        The vendor has released version 0.9.16.003 addressing this issue:
        PHPGroupWare PHPGroupWare 0.9.12
        
        PHPGroupWare PHPGroupWare 0.9.13
        
        PHPGroupWare PHPGroupWare 0.9.14 .006
        
        PHPGroupWare PHPGroupWare 0.9.14 .005
        
        PHPGroupWare PHPGroupWare 0.9.14 .003
        
        PHPGroupWare PHPGroupWare 0.9.14 .007
        
        PHPGroupWare PHPGroupWare 0.9.16 RC1
        
        PHPGroupWare PHPGroupWare 0.9.16 .000
        
        PHPGroupWare PHPGroupWare 0.9.16 .002
        

- 漏洞信息

9729
phpGroupWare Wiki Module XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

phpGroupWare contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate a variable upon submission to the "transforms.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-09-06 Unknow
2004-09-06 Unknow

- 解决方案

Upgrade to version 0.9.16.003 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPGroupWare Wiki Cross-Site Scripting Vulnerability
Input Validation Error 11130
Yes No
2004-09-07 12:00:00 2009-07-12 07:06:00
This vulnerability was reported by the vendor.

- 受影响的程序版本

PHPGroupWare PHPGroupWare 0.9.16 RC1
PHPGroupWare PHPGroupWare 0.9.16 .002
PHPGroupWare PHPGroupWare 0.9.16 .000
PHPGroupWare PHPGroupWare 0.9.14 .007
PHPGroupWare PHPGroupWare 0.9.14 .006
PHPGroupWare PHPGroupWare 0.9.14 .005
- Conectiva Linux 9.0
- Conectiva Linux 8.0
- Conectiva Linux 7.0
PHPGroupWare PHPGroupWare 0.9.14 .003
PHPGroupWare PHPGroupWare 0.9.13
- Debian Linux 2.2
PHPGroupWare PHPGroupWare 0.9.12
- Conectiva Linux 9.0
- Conectiva Linux 8.0
- Conectiva Linux 7.0
- MySQL AB MySQL 3.23.36
- MySQL AB MySQL 3.23.34
- MySQL AB MySQL 3.23.31
- PostgreSQL PostgreSQL 6.5.3
- PostgreSQL PostgreSQL 6.3.2
PHPGroupWare PHPGroupWare 0.9.16 .003
+ Gentoo Linux

- 不受影响的程序版本

PHPGroupWare PHPGroupWare 0.9.16 .003
+ Gentoo Linux

- 漏洞讨论

It is reported that PHPGroupWare is affected by a cross-site scripting vulnerability in its wiki application. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in versions prior to 0.9.16.003 of PHPGroupWare.

- 漏洞利用

An exploit is not required.

- 解决方案

Gentoo has released updates that may be applied with the following commands:
emerge sync
emerge -pv ">=www-apps/phpgroupware-0.9.16.003"
emerge ">=www-apps/phpgroupware-0.9.16.003"

The vendor has released version 0.9.16.003 addressing this issue:


PHPGroupWare PHPGroupWare 0.9.12

PHPGroupWare PHPGroupWare 0.9.13

PHPGroupWare PHPGroupWare 0.9.14 .006

PHPGroupWare PHPGroupWare 0.9.14 .005

PHPGroupWare PHPGroupWare 0.9.14 .003

PHPGroupWare PHPGroupWare 0.9.14 .007

PHPGroupWare PHPGroupWare 0.9.16 RC1

PHPGroupWare PHPGroupWare 0.9.16 .000

PHPGroupWare PHPGroupWare 0.9.16 .002

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站