CVE-2004-0811
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:39:28
NMCOS    

[原文]Unknown vulnerability in Apache 2.0.51 prevents "the merging of the Satisfy directive," which could allow attackers to obtain access to restricted resources contrary to the specified authentication configuration.


[CNNVD]Apache Satisfy命令访问控制绕过漏洞(CNNVD-200412-526)

        
        Apache是一款开放源代码WEB服务程序。
        Apache Web Server中存在访问控制绕过漏洞,起因是在合并Satisfy命令时的未明错误。远程攻击者可以利用这个漏洞绕过访问控制,非授权访问受限的资源。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0811
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0811
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-526
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17473
(PATCH)  XF  apache-satisfy-gain-access(17473)
http://www.apache.org/dist/httpd/patches/apply_to_2.0.51/CAN-2004-0811.patch
(PATCH)  CONFIRM  http://www.apache.org/dist/httpd/patches/apply_to_2.0.51/CAN-2004-0811.patch
http://www.apacheweek.com/features/security-20
(UNKNOWN)  CONFIRM  http://www.apacheweek.com/features/security-20
http://www.trustix.org/errata/2004/0049
(UNKNOWN)  TRUSTIX  2004-0049
http://www.securityfocus.com/bid/11239
(UNKNOWN)  BID  11239
http://security.gentoo.org/glsa/glsa-200409-33.xml
(UNKNOWN)  GENTOO  GLSA-200409-33
http://fedoranews.org/updates/FEDORA-2004-313.shtml
(UNKNOWN)  FEDORA  FEDORA-2004-313

- 漏洞信息

Apache Satisfy命令访问控制绕过漏洞
高危 设计错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        
        Apache是一款开放源代码WEB服务程序。
        Apache Web Server中存在访问控制绕过漏洞,起因是在合并Satisfy命令时的未明错误。远程攻击者可以利用这个漏洞绕过访问控制,非授权访问受限的资源。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
         --- httpd-2.0/server/core.c 2004/08/31 08:16:56 1.225.2.27
        +++ httpd-2.0/server/core.c 2004/09/21 13:21:16 1.225.2.28
        @@ -351,9 +351,13 @@
         /* Otherwise we simply use the base->sec_file array
         */
        
        + /* use a separate ->satisfy[] array either way */
        + conf->satisfy = apr_palloc(a, sizeof(*conf->satisfy) * METHODS);
         for (i = 0; i < METHODS; ++i) {
         if (new->satisfy[i] != SATISFY_NOSPEC) {
         conf->satisfy[i] = new->satisfy[i];
        + } else {
        + conf->satisfy[i] = base->satisfy[i];
         }
         }
        厂商补丁:
        Apache Group
        ------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://httpd.apache.org/download.cgi

- 漏洞信息

10218
Apache HTTP Server Satisfy Directive Access Control Bypass
Remote / Network Access Authentication Management, Information Disclosure
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

Apache Web Server contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a "merging of the Satisfy Directive" occurs, which will disclose resources despite configured authentication resulting in a loss of confidentiality.

- 时间线

2004-09-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.52-dev or higher, as it has been reported to fix this vulnerability. If an upgrade is not possible, apply the patch provided by the Apache Software Foundation.

- 相关参考

- 漏洞作者

- 漏洞信息

Apache Satisfy Directive Access Control Bypass Vulnerability
Design Error 11239
Yes No
2004-09-23 12:00:00 2009-07-12 07:06:00
The discoverer of this issue is not known at the moment.

- 受影响的程序版本

HP Tru64 UNIX Compaq Secure Web Server 6.3
HP Tru64 UNIX Compaq Secure Web Server 5.9.2
HP Tru64 UNIX Compaq Secure Web Server 5.9.1
HP Tru64 UNIX Compaq Secure Web Server 5.8.2
HP Tru64 UNIX Compaq Secure Web Server 5.8.1
HP Tru64 UNIX Compaq Secure Web Server 5.1 A
HP Tru64 UNIX Compaq Secure Web Server 5.1
HP Tru64 UNIX Compaq Secure Web Server 5.0 A
HP Tru64 UNIX Compaq Secure Web Server 4.0 G
HP Tru64 UNIX Compaq Secure Web Server 4.0 F
HP HP-UX B.11.23
HP HP-UX B.11.22
HP HP-UX B.11.11
HP HP-UX B.11.00
Apache Software Foundation Apache 2.0.51
+ Red Hat Fedora Core2
+ Red Hat Fedora Core1
HP Tru64 UNIX Compaq Secure Web Server 6.3.2 a
Apache Software Foundation Apache 2.0.52
+ Apple Mac OS X 10.3.6
+ Apple Mac OS X 10.2.8
+ Apple Mac OS X Server 10.3.6
+ Apple Mac OS X Server 10.2.8
+ Red Hat Enterprise Linux AS 4
+ RedHat Desktop 4.0
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux WS 4
+ Sun Solaris 10

- 不受影响的程序版本

HP Tru64 UNIX Compaq Secure Web Server 6.3.2 a
Apache Software Foundation Apache 2.0.52
+ Apple Mac OS X 10.3.6
+ Apple Mac OS X 10.2.8
+ Apple Mac OS X Server 10.3.6
+ Apple Mac OS X Server 10.2.8
+ Red Hat Enterprise Linux AS 4
+ RedHat Desktop 4.0
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux WS 4
+ Sun Solaris 10

- 漏洞讨论

Apache Web Server is reportedly affected by an access control bypass vulnerability. This issue presents itself due to an unspecified error in the merging of the 'Satisfy' directive. As a result, a remote attacker may bypass access controls and gain unauthorized access to restricted resources.

It is reported that this issue only affects Apache 2.0.51.

Due to a lack of details, further information is not available at the moment. This BID will be updated as more information becomes available.

- 漏洞利用

An exploit is not required.

- 解决方案

HP has released an advisory (HPSBGN01091) and an update to fix this vulnerability and other vulnerabilities in Secure Web Server for Tru64 UNIX; the Secure Web Server product is based on Apache.

Trustix Linux has released an advisory (TSLSA-2004-0049) along with fixes dealing with this issue. Please see the referenced advisory for more information.

Gentoo has released advisory (GLSA 200409-33) to address this issue. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their systems:

emerge sync
emerge -pv ">=net-www/apache-2.0.51-r1"
emerge ">=net-www/apache-2.0.51-r1"

Red Hat Fedora has released an advisory (FEDORA-2004-313) along with fixes dealing with this and other issues. Please see the referenced advisory for more information.

The vendor has released version 2.0.52 to address this issue:

HP has released an advisory (HPSBUX01090) to address various issues affecting HP-UX running Apache and PHP. Please see the referenced advisory for more information.


Apache Software Foundation Apache 2.0.51

HP Tru64 UNIX Compaq Secure Web Server 4.0 F

HP Tru64 UNIX Compaq Secure Web Server 4.0 G

HP Tru64 UNIX Compaq Secure Web Server 5.0 A

HP Tru64 UNIX Compaq Secure Web Server 5.1 A

HP Tru64 UNIX Compaq Secure Web Server 5.1

HP Tru64 UNIX Compaq Secure Web Server 5.8.1

HP Tru64 UNIX Compaq Secure Web Server 5.8.2

HP Tru64 UNIX Compaq Secure Web Server 5.9.1

HP Tru64 UNIX Compaq Secure Web Server 5.9.2

HP Tru64 UNIX Compaq Secure Web Server 6.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站