CVE-2004-0800
CVSS4.6
发布时间 :2004-08-24 00:00:00
修订时间 :2008-09-10 15:27:48
NMCOS    

[原文]Format string vulnerability in CDE Mailer (dtmail) on Solaris 8 and 9 allows local users to gain privileges via format strings in the argv[0] value.


[CNNVD]Sun DtMail本地命令行格式化字符串漏洞(CNNVD-200408-215)

        Solaris 8和9版本的CDE Mailer (dtmail)存在格式化字符串漏洞。本地用户借助argv[0]值格式化字符串提升权限。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:9.0::sparc
cpe:/o:sun:solaris:8.0
cpe:/a:avaya:call_management_system_server:11.0
cpe:/a:avaya:call_management_system_server:9.0
cpe:/o:sun:solaris:9.0::x86
cpe:/o:sun:solaris:8.0::x86
cpe:/a:sun:dtmailSun DtMail
cpe:/a:avaya:call_management_system_server:12.0

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:4030DtMail Local Command Line Format String Vulnerability
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0800
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0800
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-215
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/928598
(VENDOR_ADVISORY)  CERT-VN  VU#928598
http://www.idefense.com/application/poi/display?id=132&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20040824 CDE Mailer argv[0] Format String Vulnerability
http://xforce.iss.net/xforce/xfdb/17095
(UNKNOWN)  XF  dtmail-argv-format-string(17095)
http://www.securityfocus.com/bid/11027
(UNKNOWN)  BID  11027
http://www.ciac.org/ciac/bulletins/o-202.shtml
(UNKNOWN)  CIAC  O-202

- 漏洞信息

Sun DtMail本地命令行格式化字符串漏洞
中危 格式化字符串
2004-08-24 00:00:00 2005-10-20 00:00:00
本地  
        Solaris 8和9版本的CDE Mailer (dtmail)存在格式化字符串漏洞。本地用户借助argv[0]值格式化字符串提升权限。

- 公告与补丁

        Sun has released Sun Alert 5762 along with patches dealing with this issue. Please see the referenced web advisory for more information.
        Avaya has released advisory ASA-2005-110 to identify affected versions of CMS. Patches will be released in the near future. Please see the referenced Avaya advisory for more information.
        Sun Solaris 9_x86
        
        Sun Solaris 8_x86
        
        Sun Solaris 8
        
        Sun Solaris 9
        

- 漏洞信息

9145
CDE dtmail Local Format String Privilege Escalation
Local Access Required, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Patch / RCS
Exploit Public Vendor Verified

- 漏洞描述

A local overflow exists in the Common Desktop Environment (CDE) dtmail program. dtmail fails to sanitize format string characters passed on the command line resulting in a heap overflow. With a specially crafted format string, an attacker can cause arbitrary code to be executed with the privledges of the mail group resulting in a loss of confidentiality, integrity, or availability.

- 时间线

2004-08-24 2004-03-04
2004-08-24 Unknow

- 解决方案

Upgrade CDE with the latest patches referenced by the vendor, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): Remove the "set-group-ID" bit from dtmail(1X) by doing the following: # chmod 0555 /usr/dt/bin/dtmail

- 相关参考

- 漏洞作者

- 漏洞信息

Sun DtMail Local Command Line Format String Vulnerability
Input Validation Error 11027
No Yes
2004-08-24 12:00:00 2009-07-12 06:17:00
iDEFENSE Labs is credited with discovering this vulnerability.

- 受影响的程序版本

Sun Solaris 9_x86
Sun Solaris 9
Sun Solaris 8_x86
Sun Solaris 8_sparc
Sun DtMail
+ Sun Solaris 9_x86
+ Sun Solaris 9
+ Sun Solaris 8_x86
+ Sun Solaris 8_sparc
Avaya CMS Server 12.0
Avaya CMS Server 11.0
Avaya CMS Server 9.0

- 漏洞讨论

Reportedly Sun DtMail is affected by a local format string vulnerability in its processing of command line arguments. This issue is due to a failure to securely implement a formatted string function.

Successful exploitation of this issue will allow an attacker to execute arbitrary code on the affected computer with the privileges of the mail group.

NOTE: This issue is reported by Sun to be a buffer overflow vulnerability, however iDEFENSE has defined it as a format string vulnerability. It is currently believed that these issues are the same, and that some misclassification has occurred. If there is more than a single issue a new BID will be created.

Avaya Call Management System (CMS) is affected by this issue as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Sun has released Sun Alert 5762 along with patches dealing with this issue. Please see the referenced web advisory for more information.

Avaya has released advisory ASA-2005-110 to identify affected versions of CMS. Patches will be released in the near future. Please see the referenced Avaya advisory for more information.


Sun Solaris 9_x86

Sun Solaris 8_x86

Sun Solaris 8_sparc

Sun Solaris 9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站