CVE-2004-0799
CVSS5.0
发布时间 :2004-10-20 00:00:00
修订时间 :2008-09-05 16:39:26
NMCOPS    

[原文]The HTTP daemon in Ipswitch WhatsUp Gold 8.03 and 8.03 Hotfix 1 allows remote attackers to cause a denial of service (server crash) via a GET request containing an MS-DOS device name, as demonstrated using "prn.htm".


[CNNVD]Ipswitch WhatsUp Gold远程拒绝服务漏洞(CNNVD-200410-058)

        
        Ipswitch WhatsUp Gold是一款基于Windows的网络监视应用程序。
        Ipswitch WhatsUp Gold在处理GET请求时存在问题,远程攻击者可以利用这个漏洞对这个服务进行拒绝服务攻击。
        通过向WhatsUp Gold安装的HTTP守护进程提交针对'prn.htm'的GET请求,应用程序就会崩溃,并显示如下错误信息:
         Runtime Error!
         Program: C:\Program Files\WhatsUp\whatsupg.exe
         abnormal program termination
        成功利用此漏洞可进行拒绝服务攻击。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ipswitch:whatsup_gold:8.03_hotfix_1
cpe:/a:ipswitch:whatsup_gold:8.01Ipswitch WhatsUp Gold 8.01
cpe:/a:ipswitch:whatsup_gold:7.0Ipswitch WhatsUp Gold 7.0
cpe:/a:ipswitch:whatsup_gold:8.03Ipswitch WhatsUp Gold 8.03
cpe:/a:ipswitch:whatsup_gold:8.0Ipswitch WhatsUp Gold 8.0
cpe:/a:ipswitch:whatsup_gold:7.03Ipswitch WhatsUp Gold 7.03
cpe:/a:ipswitch:whatsup_gold:7.04Ipswitch WhatsUp Gold 7.04

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0799
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0799
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200410-058
(官方数据源) CNNVD

- 其它链接及资源

http://www.ipswitch.com/Support/WhatsUp/patch-upgrades.html
(PATCH)  CONFIRM  http://www.ipswitch.com/Support/WhatsUp/patch-upgrades.html
http://www.idefense.com/application/poi/display?id=142&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20040916 Ipswitch WhatsUp Gold Remote Denial of Service Vulnerability
http://xforce.iss.net/xforce/xfdb/17418
(UNKNOWN)  XF  whatsup-get-prn-dos(17418)

- 漏洞信息

Ipswitch WhatsUp Gold远程拒绝服务漏洞
中危 其他
2004-10-20 00:00:00 2005-10-20 00:00:00
远程  
        
        Ipswitch WhatsUp Gold是一款基于Windows的网络监视应用程序。
        Ipswitch WhatsUp Gold在处理GET请求时存在问题,远程攻击者可以利用这个漏洞对这个服务进行拒绝服务攻击。
        通过向WhatsUp Gold安装的HTTP守护进程提交针对'prn.htm'的GET请求,应用程序就会崩溃,并显示如下错误信息:
         Runtime Error!
         Program: C:\Program Files\WhatsUp\whatsupg.exe
         abnormal program termination
        成功利用此漏洞可进行拒绝服务攻击。
        

- 公告与补丁

        厂商补丁:
        Ipswitch
        --------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.ipswitch.com/Support/WhatsUp/patch-upgrades.html

- 漏洞信息 (F34397)

iDEFENSE Security Advisory 2004-09-16.t (PacketStormID:F34397)
2004-09-21 00:00:00
iDefense Labs  idefense.com
advisory,remote,denial of service
CVE-2004-0799
[点击下载]

iDEFENSE Security Advisory 09.16.04 - Remote exploitation of a denial of service vulnerability in Ipswitch Inc.'s WhatsUp Gold versions 8.03 and below allows attackers to cause the application to crash.

Ipswitch WhatsUp Gold Remote Denial of Service Vulnerability

iDEFENSE Security Advisory 09.16.04
www.idefense.com/application/poi/display?id=142&type=vulnerabilities
September 16, 2004

I. BACKGROUND

Ipswitch WhatsUp Gold is a Microsoft Windows based network monitoring
application. More information is available at

    http://www.Ipswitch.com/products/whatsup/index.html

II. DESCRIPTION

Remote exploitation of a denial of service vulnerability in Ipswitch
Inc.'s WhatsUp Gold allows attackers to cause the application to crash.

The problem specifically exists in the handling of reserved DOS device
names. By generating a GET request for 'prn.htm' to the HTTP daemon
installed by WhatsUp Gold, the application crashes and the following
Runtime Library error is displayed:

    Runtime Error!
    Program: C:\Program Files\WhatsUp\whatsupg.exe
    abnormal program termination

III. ANALYSIS

Successful exploitation allows unauthenticated remote attackers to crash
the WhatsUp Gold application, thereby preventing legitimate usage. The
WhatsUp Gold web server is not enabled by default.

IV. DETECTION

iDEFENSE has confirmed the existence of this vulnerability against
WhatsUp Gold versions 8.03 and the latest version 8.03 Hotfix 1. It is
suspected that earlier versions are also vulnerable.

V. WORKAROUNDS

Disable the WhatsUp Gold web server if it is not required.

VI. VENDOR RESPONSE

A patch to address this issue is available at:

http://www.ipswitch.com/Support/WhatsUp/patch-upgrades.html

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CAN-2004-0799 to this issue. This is a candidate for inclusion in
the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

08/12/2004   Initial vendor notification
08/12/2004   iDEFENSE clients notified
08/12/2004   Initial vendor response
09/16/2004   Coordinated public disclosure

IX. CREDIT

The discoverer wishes to remain anonymous.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

X. LEGAL NOTICES

Copyright (c) 2004 iDEFENSE, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.
    

- 漏洞信息

9743
Ipswitch WhatsUp Gold Notification Instance Names Overflow
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Impact Unknown
Exploit Unknown

- 漏洞描述

Ipswitch WhatsUp Gold contains a flaw that may allow a remote denial of service. The issue is triggered when a buffer overrun for Notification instance names via the web interface occurs, and will result in loss of availability for the service.

- 时间线

2004-09-03 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Ipswitch has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Ipswitch WhatsUp Gold prn.htm Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 11110
Yes No
2004-09-04 12:00:00 2009-07-12 07:06:00
The individual responsible for the discovery of this issue is currently unknown.

- 受影响的程序版本

Ipswitch WhatsUp Gold 8.0 3 hotfix 1
Ipswitch WhatsUp Gold 8.0 3
Ipswitch WhatsUp Gold 8.0 1
Ipswitch WhatsUp Gold 8.0
Ipswitch WhatsUp Gold 7.0 4
Ipswitch WhatsUp Gold 7.0 3
Ipswitch WhatsUp Gold 7.0
Ipswitch WhatsUp Gold 8.0 3 hotfix 2

- 不受影响的程序版本

Ipswitch WhatsUp Gold 8.0 3 hotfix 2

- 漏洞讨论

Ipswitch WhatsUp Gold is prone to a remotely exploitable denial of service vulnerability when handling certain HTTP GET requests to the web interface by authenticated users.

- 漏洞利用

There is no exploit required.

- 解决方案

This issue has been addressed in WhatsUp Gold 8.03 hotfix 2.


Ipswitch WhatsUp Gold 7.0 4

Ipswitch WhatsUp Gold 7.0 3

Ipswitch WhatsUp Gold 7.0

Ipswitch WhatsUp Gold 8.0

Ipswitch WhatsUp Gold 8.0 3 hotfix 1

Ipswitch WhatsUp Gold 8.0 1

Ipswitch WhatsUp Gold 8.0 3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站