CVE-2004-0781
CVSS4.3
发布时间 :2004-10-20 00:00:00
修订时间 :2008-09-05 16:39:22
NMCOPS    

[原文]Cross-site scripting (XSS) vulnerability in list.cgi in the Icecast internal web server (icecast-server) 1.3.12 and earlier allows remote attackers to inject arbitrary web script via the UserAgent parameter.


[CNNVD]Icecast服务器状态显示跨站脚本漏洞(CNNVD-200410-044)

        Icecast内部网络服务器(icecast-server) 1.3.12版本及之前的版本中的list.cgi存在跨站脚本(XSS)漏洞。远程攻击者借助UserAgent参数注入任意web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:icecast:icecast:1.3.8
cpe:/a:icecast:icecast:1.3.10.1
cpe:/a:icecast:icecast:1.3.10
cpe:/a:icecast:icecast:1.3.9.2
cpe:/a:icecast:icecast:1.3.12
cpe:/a:icecast:icecast:1.3.0
cpe:/a:icecast:icecast:1.3.9.1
cpe:/a:icecast:icecast:1.3.7
cpe:/a:icecast:icecast:1.3.9
cpe:/a:icecast:icecast:1.3.5.1
cpe:/a:icecast:icecast:1.3.7.1
cpe:/a:icecast:icecast:1.3.5
cpe:/a:icecast:icecast:1.3.11

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0781
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0781
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200410-044
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17086
(VENDOR_ADVISORY)  XF  icecast-list-useragent-xss(17086)
http://www.securityfocus.com/bid/11021
(VENDOR_ADVISORY)  BID  11021
http://www.debian.org/security/2004/dsa-541
(VENDOR_ADVISORY)  DEBIAN  DSA-541

- 漏洞信息

Icecast服务器状态显示跨站脚本漏洞
中危 跨站脚本
2004-10-20 00:00:00 2005-10-20 00:00:00
远程  
        Icecast内部网络服务器(icecast-server) 1.3.12版本及之前的版本中的list.cgi存在跨站脚本(XSS)漏洞。远程攻击者借助UserAgent参数注入任意web脚本。

- 公告与补丁

        Debian has released advisory DSA 541-1 dealing with this issue. Please see the referenced advisory for more information.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .
        Icecast Icecast 1.3.11
        

- 漏洞信息 (F34133)

dsa-541.txt (PacketStormID:F34133)
2004-08-26 00:00:00
Debian  debian.org
advisory,java,arbitrary
linux,debian
CVE-2004-0781
[点击下载]

Debian Security Advisory DSA 541-1 - In icecast-server, the UserAgent variable is not properly html_escaped allowing an an attacker the ability to cause the client to execute arbitrary Java script commands.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 541-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
August 24th, 2004                       http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : icecast-server
Vulnerability  : missing escape
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0781

Markus W    

- 漏洞信息

9143
Icecast list.cgi User-Agent XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Icecast contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate UserAgent variables upon submission to the "list.cgi" script. This could allow a user to create a specially crafted URL that would execute arbitrary Javascript code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-24 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Debian has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Icecast Server Status Display Cross-Site Scripting Vulnerability
Input Validation Error 11021
Yes No
2004-08-24 12:00:00 2009-07-12 06:17:00
Discovery of this issue is credited to Markus Wörle.

- 受影响的程序版本

Icecast Icecast 1.3.12
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1
Icecast Icecast 1.3.11
- BSDI BSD/OS 4.2
- BSDI BSD/OS 4.1
- BSDI BSD/OS 4.0.1
- BSDI BSD/OS 4.0
- BSDI BSD/OS 3.1
- BSDI BSD/OS 3.0
- Caldera OpenLinux Server 3.1.1
- Caldera OpenLinux Server 3.1
- Caldera OpenLinux Workstation 3.1.1
- Caldera OpenLinux Workstation 3.1
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- FreeBSD FreeBSD 4.5
- FreeBSD FreeBSD 4.4
- FreeBSD FreeBSD 4.3
- FreeBSD FreeBSD 4.2
- Mandriva Linux Mandrake 8.1 ia64
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0 ppc
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.1
- OpenBSD OpenBSD 2.9
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.6
- OpenBSD OpenBSD 3.0
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.2 alpha
- RedHat Linux 7.1 ia64
- RedHat Linux 7.1 i386
- RedHat Linux 7.1 alpha
- RedHat Linux 7.0 sparc
- RedHat Linux 7.0 i386
- RedHat Linux 7.0 alpha
- RedHat Linux 6.2 sparc
- RedHat Linux 6.2 i386
- RedHat Linux 6.2 alpha
- Sun Solaris 8_x86
- Sun Solaris 8_sparc
- Sun Solaris 7.0_x86
- Sun Solaris 7.0
- Sun Solaris 2.6_x86
- Sun Solaris 2.6
Icecast Icecast 1.3.10 -1
Icecast Icecast 1.3.9 -2
Icecast Icecast 1.3.9 -1
Icecast Icecast 1.3.9
+ Conectiva Linux 6.0
+ Conectiva Linux 5.1
+ Conectiva Linux 5.0
+ Conectiva Linux 4.2
+ Conectiva Linux 4.1
Icecast Icecast 1.3.8
Icecast Icecast 1.3.7 -1
Icecast Icecast 1.3.7
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server
Icecast Icecast 1.3.5 -1
Icecast Icecast 1.3.5
Icecast Icecast 1.3 .10
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1
Icecast Icecast 1.3 .0

- 漏洞讨论

Reportedly Icecast Server is affected by a cross-site scripting vulnerability in the status display functionality. This issue is due to a failure of the application to properly sanitize user-supplied input.

As a result of this vulnerability, it is possible for a remote attacker to create a malicious link containing script code that will be executed in the browser of an unsuspecting user when followed. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Debian has released advisory DSA 541-1 dealing with this issue. Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


Icecast Icecast 1.3.11

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站