CVE-2004-0770
CVSS2.1
发布时间 :2005-01-10 00:00:00
修订时间 :2008-09-05 16:39:21
NMCOS    

[原文]romload.c in DGen Emulator 1.23 and earlier allows local users to overwrite arbitrary files via a symlink attack on temporary files during decompression of (1) gzip or (2) bzip ROM files.


[CNNVD]Dgen 文件覆盖漏洞(CNNVD-200501-100)

        DGen Emulator是一个Sega游戏模拟器。
        DGen Emulator 1.23及之前版本中的romload.c存在漏洞。
        本地用户在解压缩gzip或bzip格式的ROM文件时,通过对临时文件的链接攻击方式,可覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:debian:debian_linux:3.0::hppa
cpe:/a:dgen:emulator:1.22
cpe:/o:debian:debian_linux:3.0::mips
cpe:/a:dgen:emulator:1.23
cpe:/o:debian:debian_linux:3.0::ia-32
cpe:/o:debian:debian_linux:3.0::m68k
cpe:/o:debian:debian_linux:3.0::s-390
cpe:/o:debian:debian_linux:3.0::alpha
cpe:/o:debian:debian_linux:3.0::arm
cpe:/o:debian:debian_linux:3.0::ia-64
cpe:/a:dgen:emulator:1.15
cpe:/a:dgen:emulator:1.16
cpe:/a:dgen:emulator:1.20
cpe:/a:dgen:emulator:1.17
cpe:/o:debian:debian_linux:3.0::mipsel
cpe:/a:dgen:emulator:1.18
cpe:/a:dgen:emulator:1.20_a
cpe:/o:debian:debian_linux:3.0::sparc
cpe:/a:dgen:emulator:1.21
cpe:/o:debian:debian_linux:3.0::ppc
cpe:/o:debian:debian_linux:3.0Debian Debian Linux 3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0770
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0770
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-100
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16884
(VENDOR_ADVISORY)  XF  dgen-rom-decompression-symlink(16884)
http://www.securityfocus.com/bid/10855
(VENDOR_ADVISORY)  BID  10855
http://secunia.com/advisories/12214
(UNKNOWN)  SECUNIA  12214
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=263282&archive=yes
(UNKNOWN)  CONFIRM  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=263282&archive=yes

- 漏洞信息

Dgen 文件覆盖漏洞
低危 设计错误
2005-01-10 00:00:00 2005-10-20 00:00:00
本地  
        DGen Emulator是一个Sega游戏模拟器。
        DGen Emulator 1.23及之前版本中的romload.c存在漏洞。
        本地用户在解压缩gzip或bzip格式的ROM文件时,通过对临时文件的链接攻击方式,可覆盖任意文件。

- 公告与补丁

        目前厂商还没有提供此漏洞的相关补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://tamentis.com/projects/dgen/

- 漏洞信息

8300
DGen Symlink Arbitrary File Creation
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown

- 漏洞描述

DGen contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when temporary files are insecurely created during ROM decompression, allowing a malicious user to create a symbolic link from a temporary file to an arbitrary file. This flaw may lead to a loss of integrity.

- 时间线

2004-08-04 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue. Furthermore, DGen has been discontinued and is no longer maintained.

- 相关参考

- 漏洞作者

- 漏洞信息

DGen Emulator Symbolic Link Vulnerability
Design Error 10855
No Yes
2004-08-04 12:00:00 2009-07-12 06:16:00
Discovery of this issue is credited to Joey Hess.

- 受影响的程序版本

DGen Emulator 1.23
DGen Emulator 1.22
DGen Emulator 1.21
DGen Emulator 1.20 a
DGen Emulator 1.20
DGen Emulator 1.18
DGen Emulator 1.17
DGen Emulator 1.16
DGen Emulator 1.15
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0

- 漏洞讨论

DGen is reportedly affected by a symbolic link vulnerability. This issue is due to a design error that fails to properly verify files prior to writing to them.

Successful exploitation of this issue will allow a local attacker to cause the affected application to overwrite arbitrary files with the privileges of the user that invoked the affected application. Reportedly this issue could be leveraged to facilitate privilege escalation.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Debian GNU/Linux has released fixed packages. Users of affected packages are urged to utilize Debian's package management software to install version 1.23-6 or later of 'dgen'.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站