CVE-2004-0767
CVSS5.0
发布时间 :2004-08-18 00:00:00
修订时间 :2008-09-05 16:39:20
NMCOS    

[原文]NGSEC StackDefender 1.10 allows attackers to cause a denial of service (system crash) via an invalid address for the ObjectAttribues parameter to the hooks for the (1) ZwCreateFile or (2) ZwOpenFile functions.


[CNNVD]StackDefender ObjectAttributes无效指针解除引用服务拒绝漏洞(CNNVD-200408-199)

        NGSEC StackDefender 1.10版本存在漏洞。攻击者可以通过(1) ZwCreateFile 或(2) ZwOpenFile函数hooks中ObjectAttribues参数的无效地址导致服务拒绝(系统崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0767
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0767
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-199
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16879
(UNKNOWN)  XF  stackdefender-objectattributes-dos(16879)
http://www.idefense.com/application/poi/display?id=118&type=vulnerabilities&flashstatus=false
(VENDOR_ADVISORY)  MISC  http://www.idefense.com/application/poi/display?id=118&type=vulnerabilities&flashstatus=false

- 漏洞信息

StackDefender ObjectAttributes无效指针解除引用服务拒绝漏洞
中危 其他
2004-08-18 00:00:00 2005-10-20 00:00:00
远程※本地  
        NGSEC StackDefender 1.10版本存在漏洞。攻击者可以通过(1) ZwCreateFile 或(2) ZwOpenFile函数hooks中ObjectAttribues参数的无效地址导致服务拒绝(系统崩溃)。

- 公告与补丁

        This issue has been addressed with the release of StackDefender 2.10. Users are advised to upgrade.
        Next Generation Security Technologies StackDefender 1.10
        

- 漏洞信息

8297
StackDefender Invalid ObjectAttribues Address Remote DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

StackDefender contains a flaw that may allow a remote denial of service. The issue is triggered when StackDefender fails to verify 'ObjectAttributes' as a valid address before accessing structure members, and will result in loss of availability for the users system.

- 时间线

2004-08-04 Unknow
2004-08-04 Unknow

- 解决方案

Upgrade to version 2.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

StackDefender ObjectAttributes Invalid Pointer Dereference Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 10849
Yes Yes
2004-08-04 12:00:00 2009-07-12 06:16:00
Discovery is credited iDEFENSE.

- 受影响的程序版本

Next Generation Security Technologies StackDefender 1.10
Next Generation Security Technologies StackDefender 2.10

- 不受影响的程序版本

Next Generation Security Technologies StackDefender 2.10

- 漏洞讨论

StackDefender is prone to a vulnerability that may permit attackers to crash the computer. This issue may be triggered if the program attempts to dereference an invalid pointer.

To exploit this issue, the attacker must be able to cause memory corruption on the host computer, such as through exploitation of buffer overflow in another application. This will force the software to attempt to block attempts to exploit the memory corruption vulnerability and in turn expose this vulnerability.

This issue is known to affect StackDefender 1.10.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

This issue has been addressed with the release of StackDefender 2.10. Users are advised to upgrade.


Next Generation Security Technologies StackDefender 1.10

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站