CVE-2004-0754
CVSS7.5
发布时间 :2004-10-20 00:00:00
修订时间 :2010-08-21 00:21:12
NMCOP    

[原文]Integer overflow in Gaim before 0.82 allows remote attackers to cause a denial of service and possibly execute arbitrary code via the size variable in Groupware server messages.


[CNNVD]Gaim多个缓冲区溢出安全漏洞(CNNVD-200410-067)

        
        Gaim是一款多协议通信的即时软件。
        Gaim存在多个缓冲区溢出问题,远程攻击者可以利用这些漏洞以进程权限在系统上执行任意指令。
        供应商报告远程群件服务器发送特殊消息给客户端可出发内存堆的整数溢出[CVE: CAN-2004-0754]。结果导致堆溢出允许任意指令执行。
        远程用户可以发送特殊构建的URL,当目标用户接收到时,可发生静态缓冲区溢出 [CVE: CAN-2004-0785]。
        另外主机名查询也可发生缓冲区溢出[CVE: CAN-2004-0785]。如果DNS服务器返回的主机名超过AXHOSTNAMELEN字节,就会发生缓冲区溢出。
        远程用户可以构建非法RICH文本格式消息可触发其中之一的缓冲区溢出。
        根据报告远程WEB服务器可以返回超大HTTP Content-Length头字段值,可引起Gaim解析时崩溃。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:rob_flynn:gaim:0.51
cpe:/a:rob_flynn:gaim:0.65
cpe:/a:rob_flynn:gaim:0.63
cpe:/a:rob_flynn:gaim:0.56
cpe:/a:rob_flynn:gaim:0.69
cpe:/a:rob_flynn:gaim:0.54
cpe:/a:rob_flynn:gaim:0.10.3
cpe:/a:rob_flynn:gaim:0.60
cpe:/a:rob_flynn:gaim:0.10
cpe:/a:rob_flynn:gaim:0.74
cpe:/a:rob_flynn:gaim:0.71
cpe:/a:rob_flynn:gaim:0.58
cpe:/a:rob_flynn:gaim:0.62
cpe:/a:rob_flynn:gaim:0.55
cpe:/a:rob_flynn:gaim:0.75
cpe:/a:rob_flynn:gaim:0.57
cpe:/a:rob_flynn:gaim:0.73
cpe:/a:rob_flynn:gaim:0.53
cpe:/a:rob_flynn:gaim:0.61
cpe:/a:rob_flynn:gaim:0.72
cpe:/a:rob_flynn:gaim:0.50
cpe:/a:rob_flynn:gaim:0.67
cpe:/a:rob_flynn:gaim:0.64
cpe:/a:rob_flynn:gaim:0.59.1
cpe:/a:rob_flynn:gaim:0.70
cpe:/a:rob_flynn:gaim:0.59
cpe:/a:rob_flynn:gaim:0.68
cpe:/a:rob_flynn:gaim:0.66
cpe:/a:rob_flynn:gaim:0.52

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10220Integer overflow in Gaim before 0.82 allows remote attackers to cause a denial of service and possibly execute arbitrary code via the size v...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0754
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0754
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200410-067
(官方数据源) CNNVD

- 其它链接及资源

http://www.fedoranews.org/updates/FEDORA-2004-279.shtml
(VENDOR_ADVISORY)  FEDORA  FEDORA-2004-279
http://www.fedoranews.org/updates/FEDORA-2004-278.shtml
(VENDOR_ADVISORY)  FEDORA  FEDORA-2004-278
http://www.redhat.com/support/errata/RHSA-2004-400.html
(UNKNOWN)  REDHAT  RHSA-2004:400
http://www.gentoo.org/security/en/glsa/glsa-200408-27.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200408-27
http://gaim.sourceforge.net/security/?id=2
(VENDOR_ADVISORY)  CONFIRM  http://gaim.sourceforge.net/security/?id=2
http://xforce.iss.net/xforce/xfdb/17140
(UNKNOWN)  XF  gaim-groupware-integer-overflow(17140)
http://www.securityfocus.com/bid/11056
(UNKNOWN)  BID  11056
http://www.osvdb.org/9260
(UNKNOWN)  OSVDB  9260
http://securitytracker.com/id?1011083
(UNKNOWN)  SECTRACK  1011083
http://secunia.com/advisories/13101
(UNKNOWN)  SECUNIA  13101
http://secunia.com/advisories/12480
(UNKNOWN)  SECUNIA  12480
http://secunia.com/advisories/12383
(UNKNOWN)  SECUNIA  12383

- 漏洞信息

Gaim多个缓冲区溢出安全漏洞
高危 边界条件错误
2004-10-20 00:00:00 2005-10-20 00:00:00
远程  
        
        Gaim是一款多协议通信的即时软件。
        Gaim存在多个缓冲区溢出问题,远程攻击者可以利用这些漏洞以进程权限在系统上执行任意指令。
        供应商报告远程群件服务器发送特殊消息给客户端可出发内存堆的整数溢出[CVE: CAN-2004-0754]。结果导致堆溢出允许任意指令执行。
        远程用户可以发送特殊构建的URL,当目标用户接收到时,可发生静态缓冲区溢出 [CVE: CAN-2004-0785]。
        另外主机名查询也可发生缓冲区溢出[CVE: CAN-2004-0785]。如果DNS服务器返回的主机名超过AXHOSTNAMELEN字节,就会发生缓冲区溢出。
        远程用户可以构建非法RICH文本格式消息可触发其中之一的缓冲区溢出。
        根据报告远程WEB服务器可以返回超大HTTP Content-Length头字段值,可引起Gaim解析时崩溃。
        

- 公告与补丁

        厂商补丁:
        Rob Flynn
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载最新的Gaim 0.82版本:
        
        http://gaim.sourceforge.net/downloads.php

- 漏洞信息 (F34673)

Fedora Legacy Update Advisory 1237 (PacketStormID:F34673)
2004-10-16 00:00:00
The Fedora Legacy project  gaim.sourceforge.net
advisory,overflow,protocol
linux,fedora
CVE-2004-0006,CVE-2004-0007,CVE-2004-0008,CVE-2004-0500,CVE-2004-0754,CVE-2004-0784,CVE-2004-0785
[点击下载]

Fedora Legacy Update Advisory - FLSA:1237. Updated gaim package resolves security issues. Corrects multiple buffer overflows in Gaim 0.75 and earlier, including Yahoo cookie buffer overflows, YMSG protocol overflows, and flaws in URL and proxy handling.

-----------------------------------------------------------------------
               Fedora Legacy Update Advisory

Synopsis:          Updated gaim package resolves security issues
Advisory ID:       FLSA:1237
Issue date:        2004-10-16
Product:           Red Hat Linux
Keywords:          Bugfix
Cross references:  https://bugzilla.fedora.us/show_bug.cgi?id=3D1237
CVE Names:         CAN-2004-0006 CAN-2004-0007 CAN-2004-0008
                   CAN-2004-0500 CAN-2004-0754 CAN-2004-0784
                   CAN-2004-0785
-----------------------------------------------------------------------


-----------------------------------------------------------------------
1. Topic:

An updated gaim package that fixes several security issues is now
available.

2. Relevant releases/architectures:

Red Hat Linux 7.3 - i386
Red Hat Linux 9 - i386

3. Problem description:

Issues fixed with this gaim release include:

Multiple buffer overflows that affect versions of Gaim 0.75 and earlier.
1) When parsing cookies in a Yahoo web connection, 2) YMSG protocol
overflows parsing the Yahoo login webpage, 3) a YMSG packet overflow, 4)
flaws in the URL parser, and 5) flaws in HTTP Proxy connect. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CAN-2004-0006 to these issues.

A buffer overflow in Gaim 0.74 and earlier in the Extract Info Field
Function used for MSN and YMSG protocol handlers. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CAN-2004-0007 to this issue.

An integer overflow in Gaim 0.74 and earlier, when allocating memory for
a directIM packet results in heap overflow. The Common Vulnerabilities
and Exposures project (cve.mitre.org) has assigned the name
CAN-2004-0008 to this issue.

Buffer overflow bugs were found in the Gaim MSN protocol handler. In
order to exploit these bugs, an attacker would have to perform a man in
the middle attack between the MSN server and the vulnerable Gaim client.
Such an attack could allow arbitrary code execution. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CAN-2004-0500 to this issue.

An integer overflow bug has been found in the Gaim Groupware message
receiver. It is possible that if a user connects to a malicious server,
an attacker could send carefully crafted data which could lead to
arbitrary code execution on the victims machine. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CAN-2004-0754 to this issue.

A shell escape bug has been found in the Gaim smiley theme file
installation. When a user installs a smiley theme, which is contained
within a tar file, the unarchiving of the data is done in an unsafe
manner. An attacker could create a malicious smiley theme that would
execute arbitrary commands if the theme was installed by the victim. The
Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CAN-2004-0784 to this issue.

Buffer overflow bugs have been found in the Gaim URL decoder, local
hostname resolver, and the RTF message parser. It is possible that a
remote attacker could send carefully crafted data to a vulnerable client
and lead to a crash or arbitrary code execution. The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CAN-2004-0785 to this issue.

Users of Gaim are advised to upgrade to this updated package which
contains Gaim version 0.82.1 and is not vulnerable to these issues.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which
are not installed but included in the list will not be updated.  Note
that you can also use wildcards (*.rpm) if your current directory *only*
contains the desired RPMs.

Please note that this update is also available via yum and apt.  Many
people find this an easier way to apply updates.  To use yum issue:

yum update

or to use apt:

apt-get update; apt-get upgrade

This will start an interactive process that will result in the
appropriate RPMs being upgraded on your system.  This assumes that you
have yum or apt-get configured for obtaining Fedora Legacy content.
Please visit http://www fedoralegacy.org/docs for directions on how to
configure yum and apt-get.

5. Bug IDs fixed:

http://bugzilla.fedora.us - bug #1237

6. RPMs required:

Red Hat Linux 7.3:

SRPM:
http://download.fedoralegacy.org/redhat/7.3/updates/SRPMS/gaim-0.82.1-0.73.=
2.legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/7.3/updates/i386/gaim-0.82.1-0.73.2=
.legacy.i386.rpm

Red Hat Linux 9:

SRPM:
http://download.fedoralegacy.org/redhat/9/updates/SRPMS/gaim-0.82.1-0.90.3.=
legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/9/updates/i386/gaim-0.82.1-0.90.3.l=
egacy.i386.rpm

7. Verification:

SHA1 sum                                 Package Name
---------------------------------------------------------------------------

cda084b78e263bb725ad92fdef0fc4b329b705d5=20
7.3/updates/i386/gaim-0.82.1-0.73.2.legacy.i386.rpm
e28d0c278324c7a508af7a30565cc5741b7ec4f0=20
7.3/updates/SRPMS/gaim-0.82.1-0.73.2.legacy.src.rpm
958a8c9d2077ae068af20c282e69e64ec8f1a4e7=20
9/updates/i386/gaim-0.82.1-0.90.3.legacy.i386.rpm
211c4e944d0b1178e53f0f1dd8bd303eeee1a6cf=20
9/updates/SRPMS/gaim-0.82.1-0.90.3.legacy.src.rpm

These packages are GPG signed by Fedora Legacy for security.  Our key is
available from http://www.fedoralegacy org/about/security.php

You can verify each package with the following command:

    rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the sha1sum with the following command:

    sha1sum <filename>

8. References:

http://security.e-matters.de/advisories/012004.html
http://gaim.sourceforge.net/security/index.php?id=3D0
http://gaim.sourceforge.net/security/index.php?id=3D1
http://gaim.sourceforge.net/security/index.php?id=3D2
http://gaim.sourceforge.net/security/index.php?id=3D3
http://gaim.sourceforge.net/security/index.php?id=3D4
http://gaim.sourceforge.net/security/index.php?id=3D5
http://gaim.sourceforge.net/security/index.php?id=3D6
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0006
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0007
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0008
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0500
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0754
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0784
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCAN-2004-0785


9. Contact:

The Fedora Legacy security contact is <secnotice@fedoralegacy.org>. More
project details at http://www.fedoralegacy.org

---------------------------------------------------------------------


--=-yT6Wjt5+gK57EgNFrD7m
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQBBcWI7LMAs/0C4zNoRAuwkAJ4n8aqw46Ypr31zcF/agwoWtT3u/wCfc/IB
jfgx69hTPs9W16I7z3TBJ6g=
=mQs0
-----END PGP SIGNATURE-----

--=-yT6Wjt5+gK57EgNFrD7m--


    

- 漏洞信息

9260
Gaim Groupware Message Receive Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in Gaim. Gaim fails to check integer length resulting in a buffer overflow. With a specially crafted request, an attacker running a malicious groupware server can execute arbitrary commands on a gaim client resulting in a loss of integrity.

- 时间线

2004-08-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.82 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站