CVE-2004-0749
CVSS5.0
发布时间 :2004-12-23 00:00:00
修订时间 :2008-09-05 16:39:17
NMCOS    

[原文]The mod_authz_svn module in Subversion 1.0.7 and earlier does not properly restrict access to all metadata on unreadable paths, which could allow remote attackers to gain sensitive information via (1) svn log -v, (2) svn propget, or (3) svn blame, and other commands that follow renames.


[CNNVD]Subversion Mod_Authz_Svn元数据信息泄露漏洞。(CNNVD-200412-111)

        Subversion 1.0.7及其早期版本的mod_authz_svn模块不能正确限制访问所有不可读路径下的元数据。远程攻击者可以借助(1)svn log -v,(2) svn propget,或者(3) svn blame和其它后续改名命令获取敏感信息。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linux:1.4:rc1Gentoo Linux 1.4 rc1
cpe:/o:gentoo:linux:1.2Gentoo Linux 1.2
cpe:/o:gentoo:linux:1.4:rc2Gentoo Linux 1.4 rc2
cpe:/a:subversion:subversion:1.0.2
cpe:/o:gentoo:linux:0.5
cpe:/a:subversion:subversion:1.0.4
cpe:/a:subversion:subversion:1.0.6
cpe:/a:subversion:subversion:1.0.7
cpe:/o:gentoo:linux:1.4:rc3Gentoo Linux 1.4 rc3
cpe:/o:gentoo:linux:0.7
cpe:/a:subversion:subversion:1.1.0_rc3
cpe:/o:gentoo:linux:1.1a
cpe:/a:subversion:subversion:1.0.3
cpe:/o:gentoo:linux:1.4Gentoo Linux 1.4
cpe:/a:subversion:subversion:1.1.0_rc1
cpe:/a:subversion:subversion:1.0.1
cpe:/a:subversion:subversion:1.0.5
cpe:/a:subversion:subversion:1.0
cpe:/a:subversion:subversion:1.1.0_rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0749
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0749
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-111
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17472
(VENDOR_ADVISORY)  XF  subversion-information-disclosure(17472)
http://www.securityfocus.com/bid/11243
(VENDOR_ADVISORY)  BID  11243
http://www.gentoo.org/security/en/glsa/glsa-200409-35.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200409-35
http://subversion.tigris.org/security/CAN-2004-0749-advisory.txt
(VENDOR_ADVISORY)  CONFIRM  http://subversion.tigris.org/security/CAN-2004-0749-advisory.txt
http://fedoranews.org/updates/FEDORA-2004-318.shtml
(UNKNOWN)  FEDORA  FEDORA-2004-318

- 漏洞信息

Subversion Mod_Authz_Svn元数据信息泄露漏洞。
中危 访问验证错误
2004-12-23 00:00:00 2005-10-20 00:00:00
远程  
        Subversion 1.0.7及其早期版本的mod_authz_svn模块不能正确限制访问所有不可读路径下的元数据。远程攻击者可以借助(1)svn log -v,(2) svn propget,或者(3) svn blame和其它后续改名命令获取敏感信息。
        

- 公告与补丁

        The vendor has released versions 1.0.8 and 1.1.0-rc4 addressing this vulnerability.
        Gentoo has released an advisory (GLSA 200409-35) and an updated eBuild to address this issue. Gentoo users are advised to issue the following sequence of commands in order to install the updates:
        emerge sync
        emerge -pv ">=dev-util/subversion-1.0.8"
        emerge ">=dev-util/subversion-1.0.8"
        RedHat has released an advisory (FEDORA-2004-318) to address this issue in Fedora Core 2. Please see the referenced advisory for more information.
        Conectiva Linux has released advisory CLA-2004:883 along with fixes dealing with this issue. Please see the referenced advisory for more information.
        Subversion Subversion 1.0
        
        Subversion Subversion 1.0.1
        
        Subversion Subversion 1.0.2
        
        Subversion Subversion 1.0.3
        
        Subversion Subversion 1.0.4
        
        Subversion Subversion 1.0.5
        
        Subversion Subversion 1.0.6
        
        Subversion Subversion 1.0.7
        
        Subversion Subversion 1.1 .0-rc2
        
        Subversion Subversion 1.1 .0-rc3
        
        Subversion Subversion 1.1 .0-rc1
        

- 漏洞信息

10217
Subversion (SVN) mod_authz_svn Unreadable Path Metadata Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Subversion contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a Subversion commit affects paths that an administrator has marked "unreadable" using mod_authz_svn occurs, which will disclose metadata information about the unreadable paths resulting in a loss of confidentiality.

- 时间线

2004-09-23 Unknow
2004-09-23 Unknow

- 解决方案

Upgrade to version 1.0.8 or 1.1.0-rc4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Subversion Mod_Authz_Svn Metadata Information Disclosure Vulnerability
Access Validation Error 11243
Yes No
2004-09-23 12:00:00 2009-07-12 07:06:00
This vulnerability was disclosed by the vendor.

- 受影响的程序版本

Subversion Subversion 1.1 .0-rc3
Subversion Subversion 1.1 .0-rc2
Subversion Subversion 1.1 .0-rc1
Subversion Subversion 1.0.7
Subversion Subversion 1.0.6
Subversion Subversion 1.0.5
Subversion Subversion 1.0.4
Subversion Subversion 1.0.3
Subversion Subversion 1.0.2
Subversion Subversion 1.0.1
+ Conectiva Linux 10.0
Subversion Subversion 1.0
Gentoo Linux 1.4 _rc3
Gentoo Linux 1.4 _rc2
Gentoo Linux 1.4 _rc1
Gentoo Linux 1.4
Gentoo Linux 1.2
Gentoo Linux 1.1 a
Gentoo Linux 0.7
Gentoo Linux 0.5
Subversion Subversion 1.1 .0-rc4
Subversion Subversion 1.0.8

- 不受影响的程序版本

Subversion Subversion 1.1 .0-rc4
Subversion Subversion 1.0.8

- 漏洞讨论

It is reported that Subversions mod_authz_svn module is susceptible to an information disclosure vulnerability.

This vulnerability is presents itself when paths that are marked as unreadable are accessed by particular Subversion client commands. It is reportedly possible to disclose the existence of files that are inaccessible to users. Under certain circumstances it may also be possible to disclose commit log messages, or even the contents of files that are configured to be inaccessible to users.

This vulnerability is reported to exist in versions prior to 1.0.8 and 1.1.0-rc4.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released versions 1.0.8 and 1.1.0-rc4 addressing this vulnerability.

Gentoo has released an advisory (GLSA 200409-35) and an updated eBuild to address this issue. Gentoo users are advised to issue the following sequence of commands in order to install the updates:
emerge sync
emerge -pv ">=dev-util/subversion-1.0.8"
emerge ">=dev-util/subversion-1.0.8"

RedHat has released an advisory (FEDORA-2004-318) to address this issue in Fedora Core 2. Please see the referenced advisory for more information.

Conectiva Linux has released advisory CLA-2004:883 along with fixes dealing with this issue. Please see the referenced advisory for more information.


Subversion Subversion 1.0

Subversion Subversion 1.0.1

Subversion Subversion 1.0.2

Subversion Subversion 1.0.3

Subversion Subversion 1.0.4

Subversion Subversion 1.0.5

Subversion Subversion 1.0.6

Subversion Subversion 1.0.7

Subversion Subversion 1.1 .0-rc2

Subversion Subversion 1.1 .0-rc3

Subversion Subversion 1.1 .0-rc1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站