CVE-2004-0740
CVSS5.0
发布时间 :2004-07-27 00:00:00
修订时间 :2016-10-17 22:48:33
NMCOE    

[原文]The HTTP server in Lexmark T522 and possibly other models allows remote attackers to cause a denial of service (server crash, reload, or hang) via an HTTP header with a long Host field, possibly triggering a buffer overflow.


[CNNVD]Lexmark打印机HTTP服务远程拒绝服务漏洞(CNNVD-200407-087)

        
        Lexmark Network Printer是一款内置HTTP服务的网络打印机。
        Lexmark打印机HTTP服务程序没有正确处理部分HTTP请求,远程攻击者可以利用这个漏洞对打印机WEB服务进行拒绝服务攻击。
        在HTTP请求头字段中包含超长HOST参数,Lexmark HTTP服务程序就会崩溃,造成拒绝服务攻击。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0740
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0740
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-087
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109035701329111&w=2
(UNKNOWN)  BUGTRAQ  20040720 Denial of Service vulnerability in several Lexmark HTTP servers
http://xforce.iss.net/xforce/xfdb/16752
(VENDOR_ADVISORY)  XF  lexmark-long-host-bo(16752)

- 漏洞信息

Lexmark打印机HTTP服务远程拒绝服务漏洞
中危 未知
2004-07-27 00:00:00 2005-10-20 00:00:00
远程  
        
        Lexmark Network Printer是一款内置HTTP服务的网络打印机。
        Lexmark打印机HTTP服务程序没有正确处理部分HTTP请求,远程攻击者可以利用这个漏洞对打印机WEB服务进行拒绝服务攻击。
        在HTTP请求头字段中包含超长HOST参数,Lexmark HTTP服务程序就会崩溃,造成拒绝服务攻击。
        

- 公告与补丁

        厂商补丁:
        Lexmark
        -------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.lexmark.com/

- 漏洞信息 (358)

Lexmark Multiple HTTP Servers Denial of Service Vulnerability (EDBID:358)
hardware dos
2004-07-22 Verified
0 Peter Kruse
N/A [点击下载]
GET / HTTP/1.0\r\n /Host:AAAAAA[1024]. 

# milw0rm.com [2004-07-22]
		

- 漏洞信息

8141
Lexmark T Series HTTP Host Header DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

The HTTP service running on various Lexmark T series printers contains a flaw that may allow a remote denial of service. The issue is triggered when an HTTP request with a 1024 byte or greater Host header is sent to the HTTP service and will result in loss of availability for the printer.

- 时间线

2004-07-21 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to reduce exposure by implementing the following workaround(s): - Limit access to the HTTP service at the network layer

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站