CVE-2004-0731
CVSS6.8
发布时间 :2004-07-27 00:00:00
修订时间 :2016-10-17 22:48:21
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in index.php in the Search module for Php-Nuke allows remote attackers to inject arbitrary script as other users via the input field.


[CNNVD]PHP-Nuke多个输入验证漏洞(CNNVD-200407-063)

        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke多处不正确处理用户提交的数据,远程攻击者可以利用这个漏洞进行跨站脚本,路径泄露,敏感信息泄露等攻击。
        A. 路径泄露
        "WebLinks"模块对"show"变量缺少过滤,可导致路径泄露:
        http://localhost/nuke73/modules.php?name=Web_Links&l_op=viewlink&cid=1&show=foobar
        Warning: Division by zero in D:\apache_wwwroot\nuke73\modules\Web_Links\index.php on \
        line 774
        B. 多个模块对变量缺少充分过滤,可导致跨站脚本攻击,使的目标用户敏感信息泄露:
        http://localhost/nuke73/modules.php?name=News&file=article&sid=1&optionbox=[xss code \here]
        http://localhost/nuke73/modules.php?name=Statistics&op=DailyStats&year=2004&month=5&da \te=[xss code here]
        http://localhost/nuke73/modules.php?name=Stories_Archive&sa=show_month&year=[xss code \
        here]&month=05&month_l=May \
        http://localhost/nuke73/modules.php?name=Stories_Archive&sa=show_month&year=2004&month \
        =[xss code here]&month_l=May \
        http://localhost/nuke73/modules.php?name=Stories_Archive&sa=show_month&year=2004&month \
        =05&month_l=[xss code here]
        http://localhost/nuke73/modules.php?name=Surveys&file=comments&op=Reply&pid=1&pollID=1 \
        &mode=[xss code here]&order=0&thold=0 \
        http://localhost/nuke73/modules.php?name=Surveys&file=comments&op=Reply&pid=1&pollID=1 \
        &mode=thread&order=[xss code here]&thold=0 \
        http://localhost/nuke73/modules.php?name=Surveys&file=comments&op=Reply&pid=1&pollID=1 \
        &mode=thread&order=&thold=[xss code here]
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0731
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0731
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-063
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=109002107329823&w=2
(UNKNOWN)  BUGTRAQ  20040716 [waraxe-2004-SA#035 - Multiple security holes in PhpNuke - part 2]
http://www.waraxe.us/index.php?modname=sa&id=35
(VENDOR_ADVISORY)  MISC  http://www.waraxe.us/index.php?modname=sa&id=35
http://xforce.iss.net/xforce/xfdb/16721
(VENDOR_ADVISORY)  XF  phpnuke-search-module-xss(16721)

- 漏洞信息

PHP-Nuke多个输入验证漏洞
中危 输入验证
2004-07-27 00:00:00 2005-10-20 00:00:00
远程  
        
        PHP-Nuke是一个广为流行的网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke多处不正确处理用户提交的数据,远程攻击者可以利用这个漏洞进行跨站脚本,路径泄露,敏感信息泄露等攻击。
        A. 路径泄露
        "WebLinks"模块对"show"变量缺少过滤,可导致路径泄露:
        http://localhost/nuke73/modules.php?name=Web_Links&l_op=viewlink&cid=1&show=foobar
        Warning: Division by zero in D:\apache_wwwroot\nuke73\modules\Web_Links\index.php on \
        line 774
        B. 多个模块对变量缺少充分过滤,可导致跨站脚本攻击,使的目标用户敏感信息泄露:
        http://localhost/nuke73/modules.php?name=News&file=article&sid=1&optionbox=[xss code \here]
        http://localhost/nuke73/modules.php?name=Statistics&op=DailyStats&year=2004&month=5&da \te=[xss code here]
        http://localhost/nuke73/modules.php?name=Stories_Archive&sa=show_month&year=[xss code \
        here]&month=05&month_l=May \
        http://localhost/nuke73/modules.php?name=Stories_Archive&sa=show_month&year=2004&month \
        =[xss code here]&month_l=May \
        http://localhost/nuke73/modules.php?name=Stories_Archive&sa=show_month&year=2004&month \
        =05&month_l=[xss code here]
        http://localhost/nuke73/modules.php?name=Surveys&file=comments&op=Reply&pid=1&pollID=1 \
        &mode=[xss code here]&order=0&thold=0 \
        http://localhost/nuke73/modules.php?name=Surveys&file=comments&op=Reply&pid=1&pollID=1 \
        &mode=thread&order=[xss code here]&thold=0 \
        http://localhost/nuke73/modules.php?name=Surveys&file=comments&op=Reply&pid=1&pollID=1 \
        &mode=thread&order=&thold=[xss code here]
        

- 公告与补丁

        厂商补丁:
        Francisco Burzi
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpnuke.org

- 漏洞信息

8506
PHP-Nuke Search Box Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Nuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate Web_Links, Journal, Stories Archive or Topic Archive variables upon submission to the search script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-11 Unknow
2004-08-11 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHP-Nuke Multiple Input Validation Vulnerabilities
Input Validation Error 10367
Yes No
2004-05-17 12:00:00 2009-07-12 05:56:00
The discovery of this issue is credited to Janek Vind waraxe <come2waraxe@yahoo.com>.

- 受影响的程序版本

Francisco Burzi PHP-Nuke 7.3
Francisco Burzi PHP-Nuke 7.2
Francisco Burzi PHP-Nuke 7.1
Francisco Burzi PHP-Nuke 7.0 FINAL
Francisco Burzi PHP-Nuke 7.0
Francisco Burzi PHP-Nuke 6.9
Francisco Burzi PHP-Nuke 6.7
Francisco Burzi PHP-Nuke 6.6
Francisco Burzi PHP-Nuke 6.5 RC3
Francisco Burzi PHP-Nuke 6.5 RC2
Francisco Burzi PHP-Nuke 6.5 RC1
Francisco Burzi PHP-Nuke 6.5 FINAL
Francisco Burzi PHP-Nuke 6.5 BETA 1
Francisco Burzi PHP-Nuke 6.5
Francisco Burzi PHP-Nuke 6.0

- 漏洞讨论

PHP-Nuke is prone to multiple vulnerabilities. The issues result from insufficient sanitization of user-supplied data. An attacker can carry out cross-site scripting and path disclosure attacks.

- 漏洞利用

The following proof of concept is available:
http://www.example.com/nuke73/modules.php?name=Web_Links&amp;l_op=viewlink&amp;cid=1&amp;show=foobar
http://www.example.com/nuke73/modules.php?name=News&amp;file=article&amp;sid=1&amp;optionbox=[xsscode here]
http://www.example.com/nuke73/modules.php?name=Statistics&amp;op=DailyStats&amp;year=2004&amp;month=5&amp;date=[xss
code here]
http://www.example.com/nuke73/modules.php?name=Stories_Archive&amp;sa=show_month&amp;year=[xss
code here]&amp;month=05&amp;month_l=May
http://www.example.com/nuke73/modules.php?name=Stories_Archive&amp;sa=show_month&amp;year=2004&amp;month=[xss
code here]&amp;month_l=May
http://www.example.com/nuke73/modules.php?name=Stories_Archive&amp;sa=show_month&amp;year=2004&amp;month=05&amp;month_l=[xss
code here]
http://www.example.com/nuke73/modules.php?name=Surveys&amp;file=comments&amp;op=Reply&amp;pid=1&amp;pollID=1&amp;mode=[xss
code here]&amp;order=0&amp;thold=0
http://www.example.com/nuke73/modules.php?name=Surveys&amp;file=comments&amp;op=Reply&amp;pid=1&amp;pollID=1&amp;mode=thread&amp;order=[xss
code here]&amp;thold=0
http://www.example.com/nuke73/modules.php?name=Surveys&amp;file=comments&amp;op=Reply&amp;pid=1&amp;pollID=1&amp;mode=thread&amp;order=&amp;thold=[xss
code here]
http://www.example.com/nuke73/index.php?foo=bar%20union%20select%20&lt;script&gt;alert(document.cookie);&lt;/script&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站