CVE-2004-0725
CVSS6.8
发布时间 :2004-07-27 00:00:00
修订时间 :2016-10-17 22:48:14
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in help.php in Moodle 1.3.2 and 1.4 dev allows remote attackers to inject arbitrary web script or HTML via the file parameter.


[CNNVD]Moodle帮助脚本跨站脚本漏洞(CNNVD-200407-052)

        Moodle 1.3.2和1.4 dev版本的help.php存在跨站脚本攻击(XSS)漏洞。远程攻击者借助file参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:1.3Moodle 1.3
cpe:/a:moodle:moodle:1.2Moodle 1.2
cpe:/a:moodle:moodle:1.2.1Moodle 1.2.1
cpe:/a:moodle:moodle:1.3.1Moodle 1.3.1
cpe:/a:moodle:moodle:1.3.2Moodle 1.3.2
cpe:/a:moodle:moodle:1.1.1Moodle 1.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0725
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0725
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-052
(官方数据源) CNNVD

- 其它链接及资源

http://cvs.sourceforge.net/viewcvs.py/moodle/moodle/help.php
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/moodle/moodle/help.php
http://marc.info/?l=bugtraq&m=108973588000027&w=2
(UNKNOWN)  BUGTRAQ  20040713 Moodle XSS Vulnerability
http://www.securityfocus.com/bid/10718
(VENDOR_ADVISORY)  BID  10718
http://xforce.iss.net/xforce/xfdb/16684
(VENDOR_ADVISORY)  XF  moodle-help-file-xss(16684)

- 漏洞信息

Moodle帮助脚本跨站脚本漏洞
中危 跨站脚本
2004-07-27 00:00:00 2005-10-20 00:00:00
远程  
        Moodle 1.3.2和1.4 dev版本的help.php存在跨站脚本攻击(XSS)漏洞。远程攻击者借助file参数注入任意web脚本或HTML。

- 公告与补丁

        This issue has been addressed in version 1.3.3 of the software.
        Moodle moodle 1.1.1
        
        Moodle moodle 1.2
        
        Moodle moodle 1.2.1
        
        Moodle moodle 1.3
        
        Moodle moodle 1.3.1
        
        Moodle moodle 1.3.2
        

- 漏洞信息 (24279)

Moodle Help Script 1.x Cross Site Scripting Vulnerability (EDBID:24279)
php webapps
2004-07-13 Verified
0 morpheus[bd]
N/A [点击下载]
source: http://www.securityfocus.com/bid/10718/info

It is reported that Moodle is susceptible to a cross-site scripting vulnerability in the 'help.php' script. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamic web content.

This issue may allow for theft of cookie-based authentication credentials. Other attacks are also possible.

http://www.example.com/help.php?file={XSS} 		

- 漏洞信息

7865
Moodle help.php file Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Moodle contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "file" parameter upon submission to the "help.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-07-13 Unknow
2004-07-13 Unknow

- 解决方案

Upgrade to version 1.3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Moodle Help Script Cross Site Scripting Vulnerability
Input Validation Error 10718
Yes No
2004-07-13 12:00:00 2009-07-12 06:16:00
Discovery is credited to Thomas Waldegger (morpheus) <morpheus@buha.info>.

- 受影响的程序版本

Moodle moodle 1.3.2
Moodle moodle 1.3.1
Moodle moodle 1.3
Moodle moodle 1.2.1
Moodle moodle 1.2
Moodle moodle 1.1.1
Moodle moodle 1.3.3

- 不受影响的程序版本

Moodle moodle 1.3.3

- 漏洞讨论

It is reported that Moodle is susceptible to a cross-site scripting vulnerability in the 'help.php' script. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamic web content.

This issue may allow for theft of cookie-based authentication credentials. Other attacks are also possible.

- 漏洞利用

No exploit is required.

The following proof of concept is available:
http://www.example.com/help.php?file={XSS}

- 解决方案

This issue has been addressed in version 1.3.3 of the software.


Moodle moodle 1.1.1

Moodle moodle 1.2

Moodle moodle 1.2.1

Moodle moodle 1.3

Moodle moodle 1.3.1

Moodle moodle 1.3.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站