CVE-2004-0712
CVSS4.6
发布时间 :2004-07-27 00:00:00
修订时间 :2008-09-05 16:39:11
NMCOS    

[原文]The configuration tools (1) config.sh in Unix or (2) config.cmd in Windows for BEA WebLogic Server 8.1 through SP2 create a log file that contains the administrative username and password in cleartext, which could allow local users to gain privileges.


[CNNVD]BEA WebLogic Server和WebLogic Express配置工具日志文件明文密码漏洞(CNNVD-200407-051)

        
        BEA Systems WebLogic包含多种应用系统集成方案,包括Server/Express/Integration等。
        BEA WebLogic Server和WebLogic Express存在设计错误,可导致受影响的配置工具产生日志文件时记录明文密码。
        当使用config.sh或者config.cmd配置工具时,产生的日志文件包含明文的管理员用户名和密码信息,本地攻击者可以获得这些信息对站点进行攻击。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:bea:weblogic_server:8.1:sp1BEA Systems WebLogic Server 8.1 SP1
cpe:/a:bea:weblogic_server:8.1:sp1:expressBEA Systems WebLogic Express 8.1 SP1
cpe:/a:bea:weblogic_server:8.1:sp2:expressBEA Systems WebLogic Express 8.1 SP2
cpe:/a:bea:weblogic_server:8.1:sp2BEA Systems WebLogic Server 8.1 SP2
cpe:/a:bea:weblogic_server:8.1:sp1:win32BEA Systems WebLogic Server 8.1 SP1 Win32
cpe:/a:bea:weblogic_server:8.1::win32
cpe:/a:bea:weblogic_server:8.1:sp2:win32BEA Systems WebLogic Server 8.1 SP2 Win32
cpe:/a:bea:weblogic_server:8.1::express
cpe:/a:bea:weblogic_server:8.1BEA Systems WebLogic Server 8.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0712
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0712
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-051
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/574222
(VENDOR_ADVISORY)  CERT-VN  VU#574222
http://www.securityfocus.com/bid/10188
(VENDOR_ADVISORY)  BID  10188
http://xforce.iss.net/xforce/xfdb/15926
(VENDOR_ADVISORY)  XF  weblogic-admin-password-plaintext(15926)
http://dev2dev.bea.com/resourcelibrary/advisoriesnotifications/BEA04_58.00.jsp
(UNKNOWN)  CONFIRM  http://dev2dev.bea.com/resourcelibrary/advisoriesnotifications/BEA04_58.00.jsp

- 漏洞信息

BEA WebLogic Server和WebLogic Express配置工具日志文件明文密码漏洞
中危 设计错误
2004-07-27 00:00:00 2005-10-20 00:00:00
本地  
        
        BEA Systems WebLogic包含多种应用系统集成方案,包括Server/Express/Integration等。
        BEA WebLogic Server和WebLogic Express存在设计错误,可导致受影响的配置工具产生日志文件时记录明文密码。
        当使用config.sh或者config.cmd配置工具时,产生的日志文件包含明文的管理员用户名和密码信息,本地攻击者可以获得这些信息对站点进行攻击。
        

- 公告与补丁

        厂商补丁:
        BEA Systems
        -----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        BEA Systems Patch CR135189_81sp2patch.jar
        ftp://ftpna.beasys.com/pub/releases/security/CR135189_81sp2patch.jar

- 漏洞信息

15380
BEA WebLogic config.cmd Log File Admin Credential Cleartext Disclosure
Local Access Required Authentication Management, Cryptographic, Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

BEA WebLogic contains a flaw that may lead to an unauthorized information disclosure. The issue occurs because config.cmd writes the administrative credentials to a log in plaintext. This will allow a local user to trivially obtain the credentials by browsing the logs generated by the utility.

- 时间线

2004-04-21 Unknow
2004-04-21 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, BEA Weblogic has released a patch to address this vulnerability. Service Pack 2, and the released patch must be applied. The patch will also be included in Service Pack 3.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

BEA WebLogic Server And WebLogic Express Configuration Log Files Plain Text Password Vulnerability
Design Error 10188
No Yes
2004-04-21 12:00:00 2009-07-12 04:06:00
This issue was disclosed in the referenced vendor advisory.

- 受影响的程序版本

BEA Systems WebLogic Server for Win32 8.1 SP 2
BEA Systems WebLogic Server for Win32 8.1 SP 1
BEA Systems WebLogic Server for Win32 8.1
BEA Systems Weblogic Server 8.1 SP 2
BEA Systems Weblogic Server 8.1 SP 1
BEA Systems Weblogic Server 8.1
BEA Systems WebLogic Express for Win32 8.1 SP 2
BEA Systems WebLogic Express for Win32 8.1 SP 1
BEA Systems WebLogic Express for Win32 8.1
BEA Systems WebLogic Express 8.1 SP 2
BEA Systems WebLogic Express 8.1 SP 1
BEA Systems WebLogic Express 8.1

- 漏洞讨论

Reportedly BEA WebLogic Server and WebLogic Express are affected by a log file plain text password vulnerability. This issue is due to a design error that causes the affected configuration applications to display plain text passwords when producing log files.

Any local attacker may be able to leverage this issue to be able to authenticate to the affected system as an administrator.

- 漏洞利用

An exploit is not required to leverage this issue.

- 解决方案

BEA Systems Inc. has released advisory BEA04-58.00 as well as fixes dealing with this issue. They have advised that users upgrade to the WebLogic Server and WebLogic Express version 8.1 Service Pack. Please see the referenced advisory for more information.


BEA Systems Weblogic Server 8.1 SP 2

BEA Systems WebLogic Server for Win32 8.1 SP 2

BEA Systems WebLogic Express for Win32 8.1 SP 2

BEA Systems WebLogic Express 8.1 SP 2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站