CVE-2004-0707
CVSS7.5
发布时间 :2004-07-27 00:00:00
修订时间 :2016-10-17 22:48:08
NMCO    

[原文]SQL injection vulnerability in editusers.cgi in Bugzilla 2.16.x before 2.16.6, and 2.18 before 2.18rc1, allows remote attackers with privileges to grant membership to any group to execute arbitrary SQL.


[CNNVD]Mozilla Bugzilla多个漏洞(CNNVD-200407-067)

        Bugzilla 2.16.6之前的2.16.x版本,以及2.18rc1之前的2.18 版本存在SQL注入漏洞。具有特权的远程攻击者对任意团队授予会员资格来执行任意SQL。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:bugzilla:2.17.6Mozilla Bugzilla 2.17.6
cpe:/a:mozilla:bugzilla:2.17.7Mozilla Bugzilla 2.17.7
cpe:/a:mozilla:bugzilla:2.6Mozilla Bugzilla 2.6
cpe:/a:mozilla:bugzilla:2.14.3Mozilla Bugzilla 2.14.3
cpe:/a:mozilla:bugzilla:2.16.1Mozilla Bugzilla 2.16.1
cpe:/a:mozilla:bugzilla:2.14.4Mozilla Bugzilla 2.14.4
cpe:/a:mozilla:bugzilla:2.16.2Mozilla Bugzilla 2.16.2
cpe:/a:mozilla:bugzilla:2.17.1Mozilla Bugzilla 2.17.1
cpe:/a:mozilla:bugzilla:2.14.5Mozilla Bugzilla 2.14.5
cpe:/a:mozilla:bugzilla:2.16Mozilla Bugzilla 2.16
cpe:/a:mozilla:bugzilla:2.16.3Mozilla Bugzilla 2.16.3
cpe:/a:mozilla:bugzilla:2.16.4Mozilla Bugzilla 2.16.4
cpe:/a:mozilla:bugzilla:2.17.3Mozilla Bugzilla 2.17.3
cpe:/a:mozilla:bugzilla:2.8Mozilla Bugzilla 2.8
cpe:/a:mozilla:bugzilla:2.16.5Mozilla Bugzilla 2.16.5
cpe:/a:mozilla:bugzilla:2.17.4Mozilla Bugzilla 2.17.4
cpe:/a:mozilla:bugzilla:2.17.5Mozilla Bugzilla 2.17.5
cpe:/a:mozilla:bugzilla:2.4Mozilla Bugzilla 2.4
cpe:/a:mozilla:bugzilla:2.10Mozilla Bugzilla 2.10
cpe:/a:mozilla:bugzilla:2.12Mozilla Bugzilla 2.12
cpe:/a:mozilla:bugzilla:2.14.1Mozilla Bugzilla 2.14.1
cpe:/a:mozilla:bugzilla:2.14.2Mozilla Bugzilla 2.14.2
cpe:/a:mozilla:bugzilla:2.17Mozilla Bugzilla 2.17
cpe:/a:mozilla:bugzilla:2.14Mozilla Bugzilla 2.14

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0707
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0707
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-067
(官方数据源) CNNVD

- 其它链接及资源

http://bugzilla.mozilla.org/show_bug.cgi?id=244272
(UNKNOWN)  CONFIRM  http://bugzilla.mozilla.org/show_bug.cgi?id=244272
http://marc.info/?l=bugtraq&m=108965446813639&w=2
(UNKNOWN)  BUGTRAQ  20040710 [BUGZILLA] Multiple vulnerabilities in Bugzilla 2.16.5 and 2.17.7
http://www.securityfocus.com/bid/10698
(VENDOR_ADVISORY)  BID  10698
http://xforce.iss.net/xforce/xfdb/16668
(VENDOR_ADVISORY)  XF  bugzilla-editusers-sql-injection(16668)

- 漏洞信息

Mozilla Bugzilla多个漏洞
高危 SQL注入
2004-07-27 00:00:00 2005-10-20 00:00:00
远程  
        Bugzilla 2.16.6之前的2.16.x版本,以及2.18rc1之前的2.18 版本存在SQL注入漏洞。具有特权的远程攻击者对任意团队授予会员资格来执行任意SQL。
        

- 公告与补丁

        The vendor has released versions 2.16.6 and 2.18rc1 to address these issues. Further information can be found in the referenced advisory:
        Mozilla Bugzilla 2.10
        
        Mozilla Bugzilla 2.12
        
        Mozilla Bugzilla 2.14
        
        Mozilla Bugzilla 2.14.1
        
        Mozilla Bugzilla 2.14.2
        
        Mozilla Bugzilla 2.14.3
        
        Mozilla Bugzilla 2.14.4
        
        Mozilla Bugzilla 2.14.5
        
        Mozilla Bugzilla 2.16
        
        Mozilla Bugzilla 2.16.1
        
        Mozilla Bugzilla 2.16.2
        
        Mozilla Bugzilla 2.16.3
        
        Mozilla Bugzilla 2.16.4
        
        Mozilla Bugzilla 2.16.5
        
        Mozilla Bugzilla 2.17
        
        Mozilla Bugzilla 2.17.1
        
        Mozilla Bugzilla 2.17.3
        
        Mozilla Bugzilla 2.17.4
        
        Mozilla Bugzilla 2.17.5
        
        Mozilla Bugzilla 2.17.6
        
        Mozilla Bugzilla 2.17.7
        
        Mozilla Bugzilla 2.4
        
        Mozilla Bugzilla 2.6
        
        Mozilla Bugzilla 2.8
        

- 漏洞信息

7783
Bugzilla editusers.cgi query Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Bugzilla contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'editusers.cgi' script not properly sanitizing user-supplied input to the 'query' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.

- 时间线

2004-05-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.16.6, 2.18rc1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站