CVE-2004-0698
CVSS3.6
发布时间 :2004-07-27 00:00:00
修订时间 :2008-09-10 15:27:25
NMCO    

[原文]4D WebSTAR 5.3.2 and earlier allows local users to read and modify arbitrary files via a symlink attack.


[CNNVD]4D WebSTAR读取和修改任意文件漏洞(CNNVD-200407-080)

        4D WebSTAR 5.3.2以及之前的版本存在漏洞。本地用户借助符号连接攻击读取和修改任意文件。
        

- CVSS (基础分值)

CVSS分值: 3.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:4d:webstar:5.3.2
cpe:/a:4d:webstar:5.2.4
cpe:/a:4d:webstar:5.3.1
cpe:/a:4d:webstar:5.2.2
cpe:/a:4d:webstar:5.2
cpe:/a:4d:webstar:4.0
cpe:/a:4d:webstar:5.2.3
cpe:/a:4d:webstar:5.3
cpe:/a:4d:webstar:5.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0698
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0698
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-080
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16689
(VENDOR_ADVISORY)  XF  4dwebstar-symlink(16689)
http://www.atstake.com/research/advisories/2004/a071304-1.txt
(VENDOR_ADVISORY)  ATSTAKE  A071304-1
ftp://ftp.4d.com/ACI_PRODUCT_REFERENCE_LIBRARY/4D_PRODUCT_DOCUMENTATION/PDF_Docs_by_4D_Product_A-Z/4D_WebSTAR/Software_Change_History.txt
(UNKNOWN)  MISC  ftp://ftp.4d.com/ACI_PRODUCT_REFERENCE_LIBRARY/4D_PRODUCT_DOCUMENTATION/PDF_Docs_by_4D_Product_A-Z/4D_WebSTAR/Software_Change_History.txt

- 漏洞信息

4D WebSTAR读取和修改任意文件漏洞
低危 未知
2004-07-27 00:00:00 2005-10-20 00:00:00
本地  
        4D WebSTAR 5.3.2以及之前的版本存在漏洞。本地用户借助符号连接攻击读取和修改任意文件。
        

- 公告与补丁

        

- 漏洞信息

7797
4D WebSTAR Symlink Local Privilege Escalation
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown

- 漏洞描述

WebSTAR contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is due to WebSTAR overwriting other files via symlink. By overwriting the files related to the cron subsystem, a local attacker can obtain administrative privileges, resulting in a loss of integrity.

- 时间线

2004-07-13 2004-04-05
Unknow Unknow

- 解决方案

Upgrade to version 5.3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站