CVE-2004-0697
CVSS5.0
发布时间 :2004-07-27 00:00:00
修订时间 :2008-09-05 16:39:08
NMCO    

[原文]Unknown vulnerability in 4D WebSTAR 5.3.2 and earlier allows remote attackers to read the php.ini configuration file and possibly obtain sensitive information.


[CNNVD]4D WebSTAR漏洞(CNNVD-200407-042)

        4D WebSTAR 5.3.2及其早期版本存在未知的漏洞。远程攻击者读取php.ini配置文件和可能获得敏感的信息。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:4d:webstar:5.3.2
cpe:/a:4d:webstar:5.2.4
cpe:/a:4d:webstar:5.3.1
cpe:/a:4d:webstar:5.2.2
cpe:/a:4d:webstar:5.2
cpe:/a:4d:webstar:4.0
cpe:/a:4d:webstar:5.2.3
cpe:/a:4d:webstar:5.3
cpe:/a:4d:webstar:5.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0697
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0697
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-042
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16688
(VENDOR_ADVISORY)  XF  4dwebstar-view-phpini-files(16688)
http://www.atstake.com/research/advisories/2004/a071304-1.txt
(VENDOR_ADVISORY)  ATSTAKE  A071304-1
ftp://ftp.4d.com/ACI_PRODUCT_REFERENCE_LIBRARY/4D_PRODUCT_DOCUMENTATION/PDF_Docs_by_4D_Product_A-Z/4D_WebSTAR/Software_Change_History.txt
(UNKNOWN)  MISC  ftp://ftp.4d.com/ACI_PRODUCT_REFERENCE_LIBRARY/4D_PRODUCT_DOCUMENTATION/PDF_Docs_by_4D_Product_A-Z/4D_WebSTAR/Software_Change_History.txt

- 漏洞信息

4D WebSTAR漏洞
中危 未知
2004-07-27 00:00:00 2005-10-20 00:00:00
远程  
        4D WebSTAR 5.3.2及其早期版本存在未知的漏洞。远程攻击者读取php.ini配置文件和可能获得敏感的信息。

- 公告与补丁

        

- 漏洞信息

7796
4D WebSTAR php.ini System Information Disclosure
Remote / Network Access Information Disclosure, Misconfiguration
Loss of Confidentiality
Exploit Public

- 漏洞描述

WebSTAR contains a flaw that may allow a malicious user to access unauthorized information. The issue is due to WebSTAR's inproper file permission on php.ini within the /cgi-bin or /fcgi-bin directories. This flaw may allow a remote attacker to download the php.ini file and obtain sensitive information of the webserver and database server, resulting in a loss of confidentiality.

- 时间线

2004-07-13 2004-04-05
2004-07-13 Unknow

- 解决方案

Upgrade to version 5.3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站